aboutsummaryrefslogtreecommitdiffstats
path: root/math/saga
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-03-07 03:56:18 +0800
committerriggs <riggs@FreeBSD.org>2016-03-07 03:56:18 +0800
commit3a9f21f9a1b03e78e5be6aa1281679a2e877959e (patch)
treef147f0e4fb992f25cf91add22b4ded218013c7d1 /math/saga
parent05c27a268dc7cdd35d0d8f5422de338786911aad (diff)
downloadfreebsd-ports-gnome-3a9f21f9a1b03e78e5be6aa1281679a2e877959e.tar.gz
freebsd-ports-gnome-3a9f21f9a1b03e78e5be6aa1281679a2e877959e.tar.zst
freebsd-ports-gnome-3a9f21f9a1b03e78e5be6aa1281679a2e877959e.zip
Fix overlinking problem with opencv.
Prior to this changeset, all binaries linked to opencv. This is unneccessary, as only the imagery_opencv module needs to link to opencv to work correctly. PORTREVISION is bumped as package content changes. PR: 207693 Submitted by: rhurlin@gwdg.de (maintainer)
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index e2a11da75059..10f23251362c 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -3,6 +3,7 @@
PORTNAME= saga
PORTVERSION= 2.2.4
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
@@ -27,7 +28,6 @@ CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
--enable-python
CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
GNU_CONFIGURE= yes
-LDFLAGS+= -lopencv_contrib
USE_LDCONFIG= yes
USE_CXXSTD= c++11
USE_WX= 3.0+
@@ -76,6 +76,8 @@ post-extract:
${WRKSRC}/src/modules/pointcloud/pointcloud_viewer/Makefile.am \
${WRKSRC}/src/modules/tin/tin_viewer/Makefile.am \
${WRKSRC}/src/modules/statistics/statistics_kriging/Makefile.am
+ @${REINPLACE_CMD} -e 's|/usr/include/opencv|${LOCALBASE}/include/opencv ${LOCALBASE}/include|g' \
+ ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.am
post-patch:
@${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2832)" + "\\n"|' \
@@ -92,6 +94,8 @@ post-configure:
${WRKSRC}/src/saga_core/saga_gui/Makefile
@${REINPLACE_CMD} -e 's|mv saga_dic.txt saga_prj.dic|mv ${STAGEDIR}${DATADIR}/saga_dic.txt ${STAGEDIR}${DATADIR}/saga_prj.dic|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
+ @${REINPLACE_CMD} -e 's|^LDFLAGS = .*|& -lopencv_contrib|' \
+ ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}