aboutsummaryrefslogtreecommitdiffstats
path: root/math/sage
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2014-02-20 22:47:33 +0800
committerstephen <stephen@FreeBSD.org>2014-02-20 22:47:33 +0800
commitfbc47510c7d400d85867d821431255e907dce767 (patch)
treeeb574f9cc0abe9644aad30cca5c4981c798b636e /math/sage
parent85929e0a6262adc193b5e31dfe5d7fea184979c2 (diff)
downloadfreebsd-ports-gnome-fbc47510c7d400d85867d821431255e907dce767.tar.gz
freebsd-ports-gnome-fbc47510c7d400d85867d821431255e907dce767.tar.zst
freebsd-ports-gnome-fbc47510c7d400d85867d821431255e907dce767.zip
- Fix portlint warnings.
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 7d640ab656ad..76a49e99ab98 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -153,27 +153,27 @@ MAKE_ENV+= MAKE="${MAKE} -j${MAKE_JOBS_NUMBER}"
.ifdef MAINTAINER_MODE
test-fbsd-patches: patch
- rm -rf ${WRKSRC}/build/pkgs/*/src; \
+ ${RM} -rf ${WRKSRC}/build/pkgs/*/src; \
for d in ${WRKSRC}/build/pkgs/*; do \
if ls $$d/fbsd-patch-* > /dev/null 2>&1; then \
- echo Testing patches in $${d##*/}; \
- b=$${d##*/}-`cat $$d/package-version.txt | sed 's/\.p.*//'`; \
+ ${ECHO_MSG} Testing patches in $${d##*/}; \
+ b=$${d##*/}-`${CAT} $$d/package-version.txt | ${SED} 's/\.p.*//'`; \
c=${WRKSRC}/upstream/$$b.tar.bz2 ; \
if [ ! -e $$c ]; then \
- echo Couldn\'t find $$c; \
+ ${ECHO_MSG} Couldn\'t find $$c; \
exit 1; \
fi; \
- if ! (cd $$d && tar xf $$c && mv $$b src); then \
- echo Unable to unarchive $$c; \
+ if ! (cd $$d && tar xf $$c && ${MV} $$b src); then \
+ ${ECHO_MSG} Unable to unarchive $$c; \
exit 1; \
fi; \
- if ! (cd $$d && cat fbsd-patch-* | patch); then \
- echo Patches in $${d##*/} failed; \
+ if ! (cd $$d && ${CAT} fbsd-patch-* | patch); then \
+ ${ECHO_MSG} Patches in $${d##*/} failed; \
exit 1; \
fi; \
fi; \
done; \
- rm -rf ${WRKSRC}/build/pkgs/*/src
+ ${RM} -rf ${WRKSRC}/build/pkgs/*/src
.endif
.include <bsd.port.post.mk>