aboutsummaryrefslogtreecommitdiffstats
path: root/math/scilab
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-06 07:43:15 +0800
committeredwin <edwin@FreeBSD.org>2003-02-06 07:43:15 +0800
commite82c7047b1fada9480ef0171c184867409eb2999 (patch)
tree1eba0018d1ec71b809e68d1f87e87ad3dcf42fe7 /math/scilab
parentfed721a72d8f35deb9eb5b207931be5cac6b1be0 (diff)
downloadfreebsd-ports-gnome-e82c7047b1fada9480ef0171c184867409eb2999.tar.gz
freebsd-ports-gnome-e82c7047b1fada9480ef0171c184867409eb2999.tar.zst
freebsd-ports-gnome-e82c7047b1fada9480ef0171c184867409eb2999.zip
Maintainer fix for math/scilab
The math/scilab port does not work on FreeBSD 5.0 due to an header conflict. The following patch sent by Lyndon Nerenberg (ports/47498) fixes the problem. Reported by: Kris Kennaway (kris@obsecurity.org) Fix by: Lyndon Nerenberg (lyndon@orthanc.ab.ca) PR: ports/47508 Submitted by: Jean-Sebastien Roy <js@jeannot.org>
Diffstat (limited to 'math/scilab')
-rw-r--r--math/scilab/Makefile18
-rw-r--r--math/scilab/files/patch-ay11
-rw-r--r--math/scilab/files/patch-az25
3 files changed, 47 insertions, 7 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index f0fd0d6a7671..86bf9dfd4555 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scilab
PORTVERSION= 2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math cad parallel
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/
EXTRACT_SUFX= .src.tar.gz
@@ -21,7 +21,7 @@ RUN_DEPENDS= xless:${PORTSDIR}/misc/xless \
wish8.3:${PORTSDIR}/x11-toolkits/tk83 \
pvm:${PORTSDIR}/net/pvm
-PVM_ROOT= ${PREFIX}/lib/pvm
+PVM_ROOT= ${LOCALBASE}/lib/pvm
NO_CDROM= "Don't sell for profit."
@@ -29,12 +29,16 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --without-xless --with-tk \
- --with-tk-library=${PREFIX}/lib --with-tk-include=${PREFIX}/include/tk8.3 \
- --with-tcl-library=${PREFIX}/lib --with-tcl-include=${PREFIX}/include/tcl8.3 \
- --with-xaw3d
+ --with-tk-library=${LOCALBASE}/lib \
+ --with-tk-include=${LOCALBASE}/include/tk8.3 \
+ --with-tcl-library=${LOCALBASE}/lib \
+ --with-tcl-include=${LOCALBASE}/include/tcl8.3 \
+ --with-xaw3d \
+ --x-include=${X11BASE}/include \
+ --x-libraries=${X11BASE}/lib
-CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
-MAKE_ENV= PVM_INCLUDE=${PREFIX}/include
+CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} PVM_LIB=${LOCALBASE}/lib X11BASE=${X11BASE}
+MAKE_ENV= PVM_INCLUDE=${LOCALBASE}/include
post-extract:
${RM} ${WRKSRC}/examples/callsci/callsciJava/config/config
diff --git a/math/scilab/files/patch-ay b/math/scilab/files/patch-ay
new file mode 100644
index 000000000000..9a196f79a558
--- /dev/null
+++ b/math/scilab/files/patch-ay
@@ -0,0 +1,11 @@
+--- routines/xsci/wf_fig.h 2003/01/25 17:23:40 1.1
++++ routines/xsci/wf_fig.h 2003/01/25 17:24:04
+@@ -48,7 +48,7 @@
+ #include <errno.h>
+
+ #ifndef linux
+-#if !defined(__bsdi__) && !defined(__NetBSD__)
++#if !defined(__bsdi__) && !defined(__NetBSD__) && !defined(__FreeBSD__)
+ extern int errno;
+ extern int sys_nerr;
+ #if (! (defined(BSD) && (BSD >= 199306))) && !defined(freebsd)
diff --git a/math/scilab/files/patch-az b/math/scilab/files/patch-az
new file mode 100644
index 000000000000..b7d779fb7d98
--- /dev/null
+++ b/math/scilab/files/patch-az
@@ -0,0 +1,25 @@
+--- routines/xsci/x_misc.c 2003/01/25 17:30:25 1.1
++++ routines/xsci/x_misc.c 2003/01/25 17:34:28
+@@ -509,10 +509,10 @@
+
+ /* #include "wf_fig.h" */ /** for sys_errlist **/
+ #ifndef linux
+-#if !defined(__bsdi__) && !defined(__NetBSD__)
++#if !defined(__bsdi__) && !defined(__NetBSD__) && !defined(__FreeBSD__)
+ extern int errno;
+ extern int sys_nerr;
+-#if (! (defined(BSD) && (BSD >= 199306))) && !defined(freebsd)
++#if (! (defined(BSD) && (BSD >= 199306))) && !defined(__FreeBSD__)
+ extern char *sys_errlist[];
+ #endif
+ #endif
+@@ -523,7 +523,9 @@
+ char *SysErrorMsg(n)
+ int n;
+ {
++#ifndef __FreeBSD__
+ extern int sys_nerr;
++#endif /* !__FreeBSD__ */
+ return ((n >= 0 && n < sys_nerr) ? sys_errlist[n] : UE );
+ }
+