aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpa
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-15 02:42:04 +0800
committerbapt <bapt@FreeBSD.org>2014-07-15 02:42:04 +0800
commit2c6a3135268f227c2f016b08155f35b56c7fbd99 (patch)
tree3a1e4c5d813ec945366f43d48f94fa325ba0ead9 /math/sdpa
parent92158ef1a1b16aa6f359266ab3492fc06838b525 (diff)
downloadfreebsd-ports-gnome-2c6a3135268f227c2f016b08155f35b56c7fbd99.tar.gz
freebsd-ports-gnome-2c6a3135268f227c2f016b08155f35b56c7fbd99.tar.zst
freebsd-ports-gnome-2c6a3135268f227c2f016b08155f35b56c7fbd99.zip
Modernize LIB_DEPENDS
With hat: portmgr
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 5151dd98201e..17577e934e1c 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -31,17 +31,17 @@ WITH_BLAS?= reference
.endif
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lgoto2p
LAPACK=
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif