aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpa
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2005-07-04 12:12:12 +0800
committermaho <maho@FreeBSD.org>2005-07-04 12:12:12 +0800
commit53c13ca1e27d1ae5d64d7dcbf4eb5442916c6d68 (patch)
tree1ecd15919e1424ced6e7dfa7923eccdc22f9d331 /math/sdpa
parentb0f9038b9c217fd1168ebed70014b16d4ea5da22 (diff)
downloadfreebsd-ports-gnome-53c13ca1e27d1ae5d64d7dcbf4eb5442916c6d68.tar.gz
freebsd-ports-gnome-53c13ca1e27d1ae5d64d7dcbf4eb5442916c6d68.tar.zst
freebsd-ports-gnome-53c13ca1e27d1ae5d64d7dcbf4eb5442916c6d68.zip
remakeing optimization flags
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 10e5bd42cf06..907fde6c2b02 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -41,13 +41,19 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
#WITH_SMP= yes
#WITH_ICC= yes
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPTIMIZED_FLAGS)
+.if ${ARCH} == "amd64"
+CFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
+CXXFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
+.else if ${ARCH} == "i386"
+CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+.else
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
-.if (${ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
-CFLAGS+= -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
-CXXFLAGS+= -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
-.endif # i386
+.endif
.endif
.if defined(WITH_ICC)
@@ -97,4 +103,4 @@ do-install:
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>