aboutsummaryrefslogtreecommitdiffstats
path: root/math/sfft
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-02-11 23:49:22 +0800
committerlinimon <linimon@FreeBSD.org>2018-02-11 23:49:22 +0800
commit1eefcfa4733910900b40bce1855ef0ac11f28974 (patch)
tree39fb8970bbcc70a170b16467dcef9137a7cd7287 /math/sfft
parent9c66bfc39e0695603aef97334a3568c46c5d7518 (diff)
downloadfreebsd-ports-gnome-1eefcfa4733910900b40bce1855ef0ac11f28974.tar.gz
freebsd-ports-gnome-1eefcfa4733910900b40bce1855ef0ac11f28974.tar.zst
freebsd-ports-gnome-1eefcfa4733910900b40bce1855ef0ac11f28974.zip
Use ONLY_FOR due to specific dependence on x86 instructions.
While here, pet portlint.
Diffstat (limited to 'math/sfft')
-rw-r--r--math/sfft/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/sfft/Makefile b/math/sfft/Makefile
index b31b6f7c852a..6acc80879ccf 100644
--- a/math/sfft/Makefile
+++ b/math/sfft/Makefile
@@ -14,6 +14,9 @@ COMMENT= Optimized Sparse Fast Fourier Transform
LICENSE= GPLv2
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= requires SSE instructions, which are x86-specific
+
LIB_DEPENDS= libfftw3.so:math/fftw3
USES= uidfix zip
@@ -109,6 +112,6 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${_DISTDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>