aboutsummaryrefslogtreecommitdiffstats
path: root/math/triangle
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /math/triangle
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'math/triangle')
-rw-r--r--math/triangle/Makefile4
-rw-r--r--math/triangle/files/patch-makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/math/triangle/Makefile b/math/triangle/Makefile
index b02cee8cd8b0..269ecd6a2ade 100644
--- a/math/triangle/Makefile
+++ b/math/triangle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= triangle
PORTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://cm.bell-labs.com/netlib/voronoi/
DISTNAME= ${PORTNAME}
@@ -20,7 +20,7 @@ NO_CDROM= "Triangle must not be sold for profit"
NO_WRKSUBDIR= yes
USE_ZIP= yes
-USE_XLIB= yes
+USE_XORG= x11
MAKEFILE= makefile
PLIST_FILES= bin/triangle bin/showme
diff --git a/math/triangle/files/patch-makefile b/math/triangle/files/patch-makefile
index abd4ddd335d2..c20ae2a85670 100644
--- a/math/triangle/files/patch-makefile
+++ b/math/triangle/files/patch-makefile
@@ -14,7 +14,7 @@
# CSWITCHES = -O -DNO_TIMER -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
-CSWITCHES = -O -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
-+CSWITCHES = ${CFLAGS} -I${X11BASE}/include -L${X11BASE}/lib
++CSWITCHES = ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib
# TRILIBDEFS is a list of definitions used to compile an object code version
# of Triangle (triangle.o) to be called by another program. The file