aboutsummaryrefslogtreecommitdiffstats
path: root/math/xwpl/Makefile
diff options
context:
space:
mode:
authorjseger <jseger@FreeBSD.org>1998-12-19 22:22:10 +0800
committerjseger <jseger@FreeBSD.org>1998-12-19 22:22:10 +0800
commitde6c07ae27b42465fa6886142486e3c72771b644 (patch)
treef34623f6ae65d4ecb0a205c4203485532d457b37 /math/xwpl/Makefile
parent6dd96fdd8556165188fa81b197b26692ab8a0a02 (diff)
downloadfreebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.tar.gz
freebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.tar.zst
freebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.zip
Initial import of xwpl 1.3
XWPL is an X based tool to examine one-dimensional real-valued signals using wavelets and wavelet packets. It has been designed to be as easy to use as possible for beginners. It is intended more as an educational and exploratory tool than as a numerical analysis program, even though it uses fast, optimized wavelet and wavelet packet transforms. PR: ports/5312 Submitted by: giffunip@asme.org
Diffstat (limited to 'math/xwpl/Makefile')
-rw-r--r--math/xwpl/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/math/xwpl/Makefile b/math/xwpl/Makefile
new file mode 100644
index 000000000000..621a4f780817
--- /dev/null
+++ b/math/xwpl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xwpl
+# Version required: 1.3
+# Date created: 31 Nov 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= xwpl-1.3-freebsd
+PKGNAME= xwpl-1.3
+CATEGORIES= math
+MASTER_SITES= ftp://pascal.math.yale.edu/pub/wavelets/software/xwpl/
+
+MAINTAINER= giffunip@asme.org
+
+NO_CDROM= "Free for Non-Commercial Use Only"
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/xwpl
+STRIP=
+
+MAN1= xwpl.1
+
+do-install:
+ ${INSTALL_PROGRAM} $(WRKSRC)/xwpl $(PREFIX)/bin
+ ${INSTALL_MAN} ${WRKSRC}/xwpl.man ${PREFIX}/man/man1/xwpl.1
+
+post-install:
+ ${MKDIR} $(PREFIX)/share/examples/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/data/* $(PREFIX)/share/examples/xwpl
+.if !defined(NOPORTDOCS)
+ ${MKDIR} $(PREFIX)/share/doc/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/*.ps $(PREFIX)/share/doc/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/README $(PREFIX)/share/doc/xwpl
+.endif
+
+.include <bsd.port.mk>