aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-05 18:55:53 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-05 18:55:53 +0800
commit7bf39e7010629569abcc3e5c7fa1bdaa822a0b2b (patch)
tree96d631407ff8bc759c2cfa0c81b112feaaf62e59 /math
parentb5a75a28952f25ff073f66d44cdb7304ba13c758 (diff)
downloadfreebsd-ports-gnome-7bf39e7010629569abcc3e5c7fa1bdaa822a0b2b.tar.gz
freebsd-ports-gnome-7bf39e7010629569abcc3e5c7fa1bdaa822a0b2b.tar.zst
freebsd-ports-gnome-7bf39e7010629569abcc3e5c7fa1bdaa822a0b2b.zip
Update to 0.8.0.
Diffstat (limited to 'math')
-rw-r--r--math/scigraphica/Makefile8
-rw-r--r--math/scigraphica/distinfo2
-rw-r--r--math/scigraphica/files/patch-af11
-rw-r--r--math/scigraphica/files/patch-ag15
-rw-r--r--math/scigraphica/files/patch-ltmain.sh28
-rw-r--r--math/scigraphica/files/patch-src::Makefile.in12
-rw-r--r--math/scigraphica/pkg-plist282
7 files changed, 209 insertions, 149 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index 9c4b85cdf887..fdf443734238 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= scigraphica
-PORTVERSION= 0.7.1
+PORTVERSION= 0.8.0
CATEGORIES= math gnome
MASTER_SITES= http://scigraphica.sourceforge.net/src/ \
${MASTER_SITE_SOURCEFORGE} \
http://magnet.fsu.edu/~feiguin/scigraphica/src/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= sg-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gtkextra.16:${PORTSDIR}/x11-toolkits/gtkextra
+LIB_DEPENDS= gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra
RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
@@ -25,9 +24,10 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_PYTHON= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
diff --git a/math/scigraphica/distinfo b/math/scigraphica/distinfo
index e07ff4fb5b9f..9d98d11c65b7 100644
--- a/math/scigraphica/distinfo
+++ b/math/scigraphica/distinfo
@@ -1 +1 @@
-MD5 (sg-0.7.1.tar.gz) = 9f8604fc662ae7550bd3a1de81f131c9
+MD5 (scigraphica-0.8.0.tar.gz) = 8527c80fe75bc4f72c14548c7a2b0b71
diff --git a/math/scigraphica/files/patch-af b/math/scigraphica/files/patch-af
deleted file mode 100644
index cd56d4be2e16..000000000000
--- a/math/scigraphica/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- pixmaps/Makefile.in.orig Wed Dec 6 11:14:51 2000
-+++ pixmaps/Makefile.in Wed Dec 6 11:15:36 2000
-@@ -116,7 +116,7 @@
- EXTRA_DIST = $(ICONPIXMAP) $(PIXMAPS)
-
-
--Pixmapdir = $(datadir)/pixmaps/
-+Pixmapdir = $(datadir)/pixmaps/sg/
-
- Pixmap_DATA = $(PIXMAPS) $(ICONPIXMAP)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/math/scigraphica/files/patch-ag b/math/scigraphica/files/patch-ag
index d273d3bb4bc8..efc43e10be0d 100644
--- a/math/scigraphica/files/patch-ag
+++ b/math/scigraphica/files/patch-ag
@@ -1,10 +1,15 @@
---- sg.desktop 2000/12/06 09:45:07 1.1
-+++ sg.desktop 2000/12/06 09:45:20
-@@ -2,6 +2,6 @@
+
+$FreeBSD$
+
+--- sg.desktop.orig Fri Nov 24 21:46:09 2000
++++ sg.desktop Wed Dec 5 12:40:32 2001
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
Name=SciGraphica
Comment=Data Plotting and Visualization
- Exec=sga
+-Exec=sga
-Icon=sg_icon.xpm
-+Icon=sg/sg_icon.xpm
++Exec=scigraphica
++Icon=scigraphica/sg_icon.xpm
Terminal=0
Type=Application
diff --git a/math/scigraphica/files/patch-ltmain.sh b/math/scigraphica/files/patch-ltmain.sh
new file mode 100644
index 000000000000..98cb05e4ddb3
--- /dev/null
+++ b/math/scigraphica/files/patch-ltmain.sh
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/math/scigraphica/files/patch-src::Makefile.in b/math/scigraphica/files/patch-src::Makefile.in
index 4b43c972e057..b81e93782b80 100644
--- a/math/scigraphica/files/patch-src::Makefile.in
+++ b/math/scigraphica/files/patch-src::Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- src/Makefile.in 2001/07/04 14:09:22 1.1
-+++ src/Makefile.in 2001/07/04 14:10:08
-@@ -139,7 +139,7 @@
- INCLUDES = -Ipython $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS) $(XML_CFLAGS) $(PY_CFLAGS) $(BONOBO_CFLAGS) $(OAF_CFLAGS)
+--- src/Makefile.in.orig Wed Dec 5 11:13:00 2001
++++ src/Makefile.in Wed Dec 5 11:14:40 2001
+@@ -148,7 +148,7 @@
+ INCLUDES = -Ipython $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS) $(XML_CFLAGS) $(PY_CFLAGS) $(BONOBO_CFLAGS) $(OAF_CFLAGS) $(LIBART_CFLAGS) $(GNOME_PRINT_CFLAGS)
--sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
-+sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -pthread -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
+-scigraphica_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB) $(LIBART_LIBS) $(GNOME_PRINT_LIBS)
++scigraphica_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config $(PTHREAD_LIBS) -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB) $(LIBART_LIBS) $(GNOME_PRINT_LIBS)
LIBS = @LIBS@
diff --git a/math/scigraphica/pkg-plist b/math/scigraphica/pkg-plist
index 85e5adee04d0..5219f9091b72 100644
--- a/math/scigraphica/pkg-plist
+++ b/math/scigraphica/pkg-plist
@@ -1,132 +1,158 @@
-bin/sga
+bin/scigraphica
share/gnome/apps/Applications/sg.desktop
share/gnome/help/scigraphica/C/FAQ.html
share/gnome/help/scigraphica/C/Introduction.html
+share/gnome/help/scigraphica/C/Modules-1.html
+share/gnome/help/scigraphica/C/Modules-2.html
+share/gnome/help/scigraphica/C/Modules.html
share/gnome/help/scigraphica/C/Tutorial.html
share/gnome/help/scigraphica/C/UserGuide.html
share/gnome/help/scigraphica/C/topic.dat
-share/gnome/pixmaps/sg/2d_small.xpm
-share/gnome/pixmaps/sg/3d_small.xpm
-share/gnome/pixmaps/sg/about_small.xpm
-share/gnome/pixmaps/sg/add_column.xpm
-share/gnome/pixmaps/sg/arrange.xpm
-share/gnome/pixmaps/sg/arrow.xpm
-share/gnome/pixmaps/sg/arrow2.xpm
-share/gnome/pixmaps/sg/arrow_down.xpm
-share/gnome/pixmaps/sg/arrow_left.xpm
-share/gnome/pixmaps/sg/arrow_right.xpm
-share/gnome/pixmaps/sg/arrow_up.xpm
-share/gnome/pixmaps/sg/autoscale.xpm
-share/gnome/pixmaps/sg/bold.xpm
-share/gnome/pixmaps/sg/book_small.xpm
-share/gnome/pixmaps/sg/bullet.xpm
-share/gnome/pixmaps/sg/button_ok.xpm
-share/gnome/pixmaps/sg/color.xpm
-share/gnome/pixmaps/sg/control.xpm
-share/gnome/pixmaps/sg/copy.xpm
-share/gnome/pixmaps/sg/cut.xpm
-share/gnome/pixmaps/sg/dennied.xpm
-share/gnome/pixmaps/sg/empty.xpm
-share/gnome/pixmaps/sg/error.xpm
-share/gnome/pixmaps/sg/exec_small.xpm
-share/gnome/pixmaps/sg/exit_small.xpm
-share/gnome/pixmaps/sg/eye.xpm
-share/gnome/pixmaps/sg/fitpage.xpm
-share/gnome/pixmaps/sg/folder.xpm
-share/gnome/pixmaps/sg/font.xpm
-share/gnome/pixmaps/sg/function_small.xpm
-share/gnome/pixmaps/sg/g_2dlayer.xpm
-share/gnome/pixmaps/sg/g_3dcontour.xpm
-share/gnome/pixmaps/sg/g_3dlayer.xpm
-share/gnome/pixmaps/sg/g_bars.xpm
-share/gnome/pixmaps/sg/g_boxes.xpm
-share/gnome/pixmaps/sg/g_bubbles.xpm
-share/gnome/pixmaps/sg/g_bubbles3d.xpm
-share/gnome/pixmaps/sg/g_colors.xpm
-share/gnome/pixmaps/sg/g_colors3d.xpm
-share/gnome/pixmaps/sg/g_contour.xpm
-share/gnome/pixmaps/sg/g_csurface.xpm
-share/gnome/pixmaps/sg/g_density.xpm
-share/gnome/pixmaps/sg/g_flux3d.xpm
-share/gnome/pixmaps/sg/g_function.xpm
-share/gnome/pixmaps/sg/g_hbars.xpm
-share/gnome/pixmaps/sg/g_hbox.xpm
-share/gnome/pixmaps/sg/g_impulses.xpm
-share/gnome/pixmaps/sg/g_lines.xpm
-share/gnome/pixmaps/sg/g_lpoints.xpm
-share/gnome/pixmaps/sg/g_python.xpm
-share/gnome/pixmaps/sg/g_scatter.xpm
-share/gnome/pixmaps/sg/g_scatter3d.xpm
-share/gnome/pixmaps/sg/g_surface.xpm
-share/gnome/pixmaps/sg/g_vectors.xpm
-share/gnome/pixmaps/sg/italic.xpm
-share/gnome/pixmaps/sg/layer.xpm
-share/gnome/pixmaps/sg/logo.xpm
-share/gnome/pixmaps/sg/new.xpm
-share/gnome/pixmaps/sg/new_2d.xpm
-share/gnome/pixmaps/sg/new_2d_small.xpm
-share/gnome/pixmaps/sg/new_3d.xpm
-share/gnome/pixmaps/sg/new_3d_small.xpm
-share/gnome/pixmaps/sg/new_function.xpm
-share/gnome/pixmaps/sg/new_plot.xpm
-share/gnome/pixmaps/sg/new_polar.xpm
-share/gnome/pixmaps/sg/new_polar_small.xpm
-share/gnome/pixmaps/sg/new_sheet.xpm
-share/gnome/pixmaps/sg/new_small.xpm
-share/gnome/pixmaps/sg/open.xpm
-share/gnome/pixmaps/sg/open_small.xpm
-share/gnome/pixmaps/sg/paint.xpm
-share/gnome/pixmaps/sg/paste.xpm
-share/gnome/pixmaps/sg/pixmaps.h
-share/gnome/pixmaps/sg/plot_icon.xpm
-share/gnome/pixmaps/sg/plot_icon2.xpm
-share/gnome/pixmaps/sg/plot_small.xpm
-share/gnome/pixmaps/sg/point.xpm
-share/gnome/pixmaps/sg/pointers.xpm
-share/gnome/pixmaps/sg/polar_small.xpm
-share/gnome/pixmaps/sg/preferences_small.xpm
-share/gnome/pixmaps/sg/print.xpm
-share/gnome/pixmaps/sg/python_small.xpm
-share/gnome/pixmaps/sg/reload.xpm
-share/gnome/pixmaps/sg/reset.xpm
-share/gnome/pixmaps/sg/rotate_x.xpm
-share/gnome/pixmaps/sg/rotate_y.xpm
-share/gnome/pixmaps/sg/rotate_z.xpm
-share/gnome/pixmaps/sg/save.xpm
-share/gnome/pixmaps/sg/save_as.xpm
-share/gnome/pixmaps/sg/save_as_small.xpm
-share/gnome/pixmaps/sg/save_small.xpm
-share/gnome/pixmaps/sg/sg.xpm
-share/gnome/pixmaps/sg/sg_icon.xpm
-share/gnome/pixmaps/sg/sg_small.xpm
-share/gnome/pixmaps/sg/sheet_icon.xpm
-share/gnome/pixmaps/sg/sheet_icon2.xpm
-share/gnome/pixmaps/sg/sheet_small.xpm
-share/gnome/pixmaps/sg/sorry.xpm
-share/gnome/pixmaps/sg/symbol_circle.xpm
-share/gnome/pixmaps/sg/symbol_cross.xpm
-share/gnome/pixmaps/sg/symbol_diamond.xpm
-share/gnome/pixmaps/sg/symbol_dntriangle.xpm
-share/gnome/pixmaps/sg/symbol_dot.xpm
-share/gnome/pixmaps/sg/symbol_impulse.xpm
-share/gnome/pixmaps/sg/symbol_ltriangle.xpm
-share/gnome/pixmaps/sg/symbol_none.xpm
-share/gnome/pixmaps/sg/symbol_plus.xpm
-share/gnome/pixmaps/sg/symbol_rtriangle.xpm
-share/gnome/pixmaps/sg/symbol_square.xpm
-share/gnome/pixmaps/sg/symbol_star.xpm
-share/gnome/pixmaps/sg/symbol_uptriangle.xpm
-share/gnome/pixmaps/sg/target.xpm
-share/gnome/pixmaps/sg/text.xpm
-share/gnome/pixmaps/sg/tools.xpm
-share/gnome/pixmaps/sg/warning.xpm
-share/gnome/pixmaps/sg/zoom.xpm
-share/gnome/pixmaps/sg/zoom_minus.xpm
-share/gnome/pixmaps/sg/zoom_plus.xpm
-share/gnome/pixmaps/sg/zoomin.xpm
-share/gnome/pixmaps/sg/zoomout.xpm
+share/gnome/pixmaps/scigraphica/2d_small.xpm
+share/gnome/pixmaps/scigraphica/3d_small.xpm
+share/gnome/pixmaps/scigraphica/about_small.xpm
+share/gnome/pixmaps/scigraphica/add_column.xpm
+share/gnome/pixmaps/scigraphica/arrange.xpm
+share/gnome/pixmaps/scigraphica/arrow.xpm
+share/gnome/pixmaps/scigraphica/arrow2.xpm
+share/gnome/pixmaps/scigraphica/arrow_down.xpm
+share/gnome/pixmaps/scigraphica/arrow_left.xpm
+share/gnome/pixmaps/scigraphica/arrow_right.xpm
+share/gnome/pixmaps/scigraphica/arrow_up.xpm
+share/gnome/pixmaps/scigraphica/as.xpm
+share/gnome/pixmaps/scigraphica/autoscale.xpm
+share/gnome/pixmaps/scigraphica/bold.xpm
+share/gnome/pixmaps/scigraphica/book_small.xpm
+share/gnome/pixmaps/scigraphica/bullet.xpm
+share/gnome/pixmaps/scigraphica/button_ok.xpm
+share/gnome/pixmaps/scigraphica/color.xpm
+share/gnome/pixmaps/scigraphica/control.xpm
+share/gnome/pixmaps/scigraphica/copy.xpm
+share/gnome/pixmaps/scigraphica/cut.xpm
+share/gnome/pixmaps/scigraphica/dennied.xpm
+share/gnome/pixmaps/scigraphica/empty.xpm
+share/gnome/pixmaps/scigraphica/error.xpm
+share/gnome/pixmaps/scigraphica/exec_small.xpm
+share/gnome/pixmaps/scigraphica/exit_small.xpm
+share/gnome/pixmaps/scigraphica/eye.xpm
+share/gnome/pixmaps/scigraphica/fit5.xpm
+share/gnome/pixmaps/scigraphica/fit_page.xpm
+share/gnome/pixmaps/scigraphica/fitpage.xpm
+share/gnome/pixmaps/scigraphica/folder.xpm
+share/gnome/pixmaps/scigraphica/font.xpm
+share/gnome/pixmaps/scigraphica/function_small.xpm
+share/gnome/pixmaps/scigraphica/g_2dlayer.xpm
+share/gnome/pixmaps/scigraphica/g_3dcontour.xpm
+share/gnome/pixmaps/scigraphica/g_3dlayer.xpm
+share/gnome/pixmaps/scigraphica/g_bars.xpm
+share/gnome/pixmaps/scigraphica/g_boxes.xpm
+share/gnome/pixmaps/scigraphica/g_bubbles.xpm
+share/gnome/pixmaps/scigraphica/g_bubbles3d.xpm
+share/gnome/pixmaps/scigraphica/g_colors.xpm
+share/gnome/pixmaps/scigraphica/g_colors3d.xpm
+share/gnome/pixmaps/scigraphica/g_contour.xpm
+share/gnome/pixmaps/scigraphica/g_csurface.xpm
+share/gnome/pixmaps/scigraphica/g_density.xpm
+share/gnome/pixmaps/scigraphica/g_flux3d.xpm
+share/gnome/pixmaps/scigraphica/g_function.xpm
+share/gnome/pixmaps/scigraphica/g_hbars.xpm
+share/gnome/pixmaps/scigraphica/g_hbox.xpm
+share/gnome/pixmaps/scigraphica/g_impulses.xpm
+share/gnome/pixmaps/scigraphica/g_lines.xpm
+share/gnome/pixmaps/scigraphica/g_lpoints.xpm
+share/gnome/pixmaps/scigraphica/g_python.xpm
+share/gnome/pixmaps/scigraphica/g_scatter.xpm
+share/gnome/pixmaps/scigraphica/g_scatter3d.xpm
+share/gnome/pixmaps/scigraphica/g_surface.xpm
+share/gnome/pixmaps/scigraphica/g_vectors.xpm
+share/gnome/pixmaps/scigraphica/italic.xpm
+share/gnome/pixmaps/scigraphica/layer.xpm
+share/gnome/pixmaps/scigraphica/layer_control.xpm
+share/gnome/pixmaps/scigraphica/logo.xpm
+share/gnome/pixmaps/scigraphica/markers.xpm
+share/gnome/pixmaps/scigraphica/matrix_icon.xpm
+share/gnome/pixmaps/scigraphica/new.xpm
+share/gnome/pixmaps/scigraphica/new_2d.xpm
+share/gnome/pixmaps/scigraphica/new_2d_small.xpm
+share/gnome/pixmaps/scigraphica/new_3d.xpm
+share/gnome/pixmaps/scigraphica/new_3d_small.xpm
+share/gnome/pixmaps/scigraphica/new_function.xpm
+share/gnome/pixmaps/scigraphica/new_plot.xpm
+share/gnome/pixmaps/scigraphica/new_polar.xpm
+share/gnome/pixmaps/scigraphica/new_polar_small.xpm
+share/gnome/pixmaps/scigraphica/new_sheet.xpm
+share/gnome/pixmaps/scigraphica/new_small.xpm
+share/gnome/pixmaps/scigraphica/open.xpm
+share/gnome/pixmaps/scigraphica/open_small.xpm
+share/gnome/pixmaps/scigraphica/paint.xpm
+share/gnome/pixmaps/scigraphica/paste.xpm
+share/gnome/pixmaps/scigraphica/pixmaps.h
+share/gnome/pixmaps/scigraphica/plot_icon.xpm
+share/gnome/pixmaps/scigraphica/plot_icon2.xpm
+share/gnome/pixmaps/scigraphica/plot_small.xpm
+share/gnome/pixmaps/scigraphica/point.xpm
+share/gnome/pixmaps/scigraphica/pointers.xpm
+share/gnome/pixmaps/scigraphica/polar_small.xpm
+share/gnome/pixmaps/scigraphica/preferences_small.xpm
+share/gnome/pixmaps/scigraphica/print.xpm
+share/gnome/pixmaps/scigraphica/python_small.xpm
+share/gnome/pixmaps/scigraphica/reload.xpm
+share/gnome/pixmaps/scigraphica/reset.xpm
+share/gnome/pixmaps/scigraphica/rotate_x.xpm
+share/gnome/pixmaps/scigraphica/rotate_y.xpm
+share/gnome/pixmaps/scigraphica/rotate_z.xpm
+share/gnome/pixmaps/scigraphica/save.xpm
+share/gnome/pixmaps/scigraphica/save_as.xpm
+share/gnome/pixmaps/scigraphica/save_as_small.xpm
+share/gnome/pixmaps/scigraphica/save_small.xpm
+share/gnome/pixmaps/scigraphica/set_column.xpm
+share/gnome/pixmaps/scigraphica/sg.xpm
+share/gnome/pixmaps/scigraphica/sg_icon.xpm
+share/gnome/pixmaps/scigraphica/sg_small.xpm
+share/gnome/pixmaps/scigraphica/sheet_icon.xpm
+share/gnome/pixmaps/scigraphica/sheet_icon2.xpm
+share/gnome/pixmaps/scigraphica/sheet_small.xpm
+share/gnome/pixmaps/scigraphica/sorry.xpm
+share/gnome/pixmaps/scigraphica/stock_button_apply.xpm
+share/gnome/pixmaps/scigraphica/stock_button_cancel.xpm
+share/gnome/pixmaps/scigraphica/stock_button_close.xpm
+share/gnome/pixmaps/scigraphica/stock_button_no.xpm
+share/gnome/pixmaps/scigraphica/stock_button_ok.xpm
+share/gnome/pixmaps/scigraphica/stock_button_yes.xpm
+share/gnome/pixmaps/scigraphica/stock_down_arrow.xpm
+share/gnome/pixmaps/scigraphica/stock_font.xpm
+share/gnome/pixmaps/scigraphica/stock_help.xpm
+share/gnome/pixmaps/scigraphica/stock_left_arrow.xpm
+share/gnome/pixmaps/scigraphica/stock_open.xpm
+share/gnome/pixmaps/scigraphica/stock_pixmaps.h
+share/gnome/pixmaps/scigraphica/stock_right_arrow.xpm
+share/gnome/pixmaps/scigraphica/stock_up_arrow.xpm
+share/gnome/pixmaps/scigraphica/symbol_circle.xpm
+share/gnome/pixmaps/scigraphica/symbol_cross.xpm
+share/gnome/pixmaps/scigraphica/symbol_diamond.xpm
+share/gnome/pixmaps/scigraphica/symbol_dntriangle.xpm
+share/gnome/pixmaps/scigraphica/symbol_dot.xpm
+share/gnome/pixmaps/scigraphica/symbol_impulse.xpm
+share/gnome/pixmaps/scigraphica/symbol_ltriangle.xpm
+share/gnome/pixmaps/scigraphica/symbol_none.xpm
+share/gnome/pixmaps/scigraphica/symbol_plus.xpm
+share/gnome/pixmaps/scigraphica/symbol_rtriangle.xpm
+share/gnome/pixmaps/scigraphica/symbol_square.xpm
+share/gnome/pixmaps/scigraphica/symbol_star.xpm
+share/gnome/pixmaps/scigraphica/symbol_uptriangle.xpm
+share/gnome/pixmaps/scigraphica/target.xpm
+share/gnome/pixmaps/scigraphica/text.xpm
+share/gnome/pixmaps/scigraphica/tools.xpm
+share/gnome/pixmaps/scigraphica/warning.xpm
+share/gnome/pixmaps/scigraphica/zoom.xpm
+share/gnome/pixmaps/scigraphica/zoom_minus.xpm
+share/gnome/pixmaps/scigraphica/zoom_plus.xpm
+share/gnome/pixmaps/scigraphica/zoomin.xpm
+share/gnome/pixmaps/scigraphica/zoomout.xpm
+share/gnome/pixmaps/sg_icon.xpm
share/gnome/scigraphica/examples/3d.sg
share/gnome/scigraphica/examples/image.sg
+share/gnome/scigraphica/examples/matrix.sg
share/gnome/scigraphica/examples/multicolumn.sg
share/gnome/scigraphica/examples/polar.sg
share/gnome/scigraphica/examples/py_example1.py
@@ -140,6 +166,18 @@ share/gnome/scigraphica/examples/test.dat
share/gnome/scigraphica/examples/ticks.sg
share/gnome/scigraphica/examples/trigonometric.sg
share/gnome/scigraphica/examples/vectors.sg
+share/gnome/scigraphica/python/FitWizard.py
+share/gnome/scigraphica/python/FitWizard.pyc
+share/gnome/scigraphica/python/FitWizard.pyo
+share/gnome/scigraphica/python/SimpleStats.py
+share/gnome/scigraphica/python/SimpleStats.pyc
+share/gnome/scigraphica/python/SimpleStats.pyo
+share/gnome/scigraphica/python/clarens.py
+share/gnome/scigraphica/python/clarens.pyc
+share/gnome/scigraphica/python/clarens.pyo
+share/gnome/scigraphica/python/clarens_histograms.py
+share/gnome/scigraphica/python/clarens_histograms.pyc
+share/gnome/scigraphica/python/clarens_histograms.pyo
share/gnome/scigraphica/python/gtkLeastSquares.py
share/gnome/scigraphica/python/gtkLeastSquares.pyc
share/gnome/scigraphica/python/gtkLeastSquares.pyo
@@ -164,6 +202,6 @@ share/gnome/scigraphica/python/unpickler.pyo
@dirrm share/gnome/scigraphica/python
@dirrm share/gnome/scigraphica/examples
@dirrm share/gnome/scigraphica
-@dirrm share/gnome/pixmaps/sg
+@dirrm share/gnome/pixmaps/scigraphica
@dirrm share/gnome/help/scigraphica/C
@dirrm share/gnome/help/scigraphica
tw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/archivers?id=819f8f985baf8e5241b4c89ccbd20328fe7ec0d9'>This software is licensed under the GNU GPL. As mentioned in thetrevor2005-06-121-1/+2 * Explain more clearly why users might need to install this port.trevor2005-06-121-16/+15 * * reflect renaming on CPAN File-Spec to PathToolsskv2005-06-123-22/+10 * Update to 1.5.a.60lawrance2005-06-102-3/+3 * Suppress compiler warnings.jylefort2005-06-091-0/+49 * Add gzrecover.jylefort2005-06-084-0/+44 * Add Dzip, file compression utility specializing in Quake demo compression.danfe2005-06-084-0/+52 * - Update to 1.4.0pav2005-06-072-22/+28 * update to 4.20.sf2005-06-072-3/+4 * - Add lzo2, version 2.00 of archivers/lzo.flz2005-06-076-55/+41 * . This version isn't the version in FreeBSD 5.3, so update the COMMENTglewis2005-06-071-1/+1 * . Update to 1.02.026.glewis2005-06-074-6/+6 * - Update to 2.1.4pav2005-06-042-7/+13 * . Change rpmrc to support amd64 and also to indicate that i386 and amd64glewis2005-06-034-2/+108 * - Backout latest commit, it needs a repocopy due to API change.flz2005-06-012-4/+4 * - Backout latest commit, it needs a repocopy due to API change.flz2005-06-0110-72/+112 * - Bump lzo lib version.flz2005-06-012-2/+4 * - Update to 2.0.flz2005-06-0110-110/+72 * don't install .la filesoliver2005-06-014-4/+2 * fix MASTER_SITESoliver2005-05-312-2/+2 * change the libtool version to use from 1.3 to 1.5oliver2005-05-314-2/+4 * change the libtool version to use from 1.3 to 1.5oliver2005-05-312-9/+1 * Mark these ports DEPRECATED due to being unmaintained and one or morelawrance2005-05-311-0/+3 * - Update to 1.3.0.flz2005-05-312-22/+24 * - sync rpmrc with FC3 only to make i386 and amd64 archspat2005-05-282-1/+46 * - Update to 1.2.0pav2005-05-283-25/+24 * - Unquote IGNORE message [1]danfe2005-05-271-1/+1 * - Use DISTVERSIONdanfe2005-05-272-7/+11 * Add lcab, Microsoft cabinet (.CAB) file creator.danfe2005-05-274-0/+29 * - Improve on port description [1]danfe2005-05-271-4/+15 * - Fix bug: Torrentzip uses the read permission flag to check if a zip filepav2005-05-272-0/+33 * - Respect ${CC} and ${CXX}jylefort2005-05-271-1/+3 * Update to 1.5.a.59.novel2005-05-212-4/+3 * Remove duplicated category.tobez2005-05-201-1/+1 * IGNORE if perl version < 5.6.demon2005-05-201-1/+7 * Change my email address.jylefort2005-05-152-2/+2 * update to 4.18.sf2005-05-142-3/+3 * Update to version 2.08.demon2005-05-122-4/+4 * - Sweep directories on amd64pav2005-05-111-0/+2 * Update to 1.1.0arved2005-05-092-3/+3 * Update to 4.17jylefort2005-05-092-5/+6 * Simple command line version of compression program using LZMA compressionjylefort2005-05-084-0/+58 * The second attempt to fix plistnovel2005-05-062-4/+33 * Fix plistnovel2005-05-041-1/+1 * TorrentZip creates byte-for-byte exact zip files on any machine. This allowspav2005-05-044-0/+50 * Update to 4.3.80novel2005-05-033-41/+6 * . Update to 1.02.023.glewis2005-05-022-3/+3 * . Update to 1.02.023.glewis2005-05-022-3/+3 * unbreak amd64 and ia64.sf2005-04-301-0/+4 * update to 4.16.sf2005-04-293-31/+33 * - Update to 1.14leeym2005-04-292-7/+4 * + update port: archivers/pear-File_Archive to 1.0.1novel2005-04-263-6/+5 * Move shared directory for klirc profiles into kdehier.lofi2005-04-251-1/+0 * Update to 2.10.3.mezz2005-04-236-28/+32 * - Depend on Perl (gremsync is not installed unless Perl is available).jylefort2005-04-221-0/+8 * - Update to 4.3.77jylefort2005-04-216-230/+17 * New port: archivers/pear-File_Archive PEAR class to easily manipulate tar, gz...pav2005-04-204-0/+77 * - Remove redundant patch (dupe of patch-Makefile)vs2005-04-192-19/+1 * Minimize Makefile-patch by using MAKE_ARGSvs2005-04-192-16/+2 * Use MAKE_ARGS instead of Makefile-patchvs2005-04-192-35/+1 * . Add long option support on FreeBSD 4.x and early FreeBSD 5.x by settingglewis2005-04-191-0/+4 * . Update to 1.02.019.glewis2005-04-184-6/+6 * . Update to 1.02.017.glewis2005-04-132-3/+3 * Set my ports to their shiny new MAINTAINER address.lawrance2005-04-124-4/+4 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-1214-16/+16 * Update to 2.10.2.adamw2005-04-126-6/+8 * Change maintainer's email address.barner2005-04-111-1/+1 * - ARCH is defined in bsd.port.mkflz2005-04-111-1/+3 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-1114-16/+16 * - Add unmakeself 0.99, a tool to extract makeself archives.flz2005-04-114-0/+296 * Depend on archivers/gtar on CURRENT later than 600022lofi2005-04-041-0/+3 * Update PHP ports to 4.3.11 and 5.0.4 releases:ale2005-04-041-2/+0 * Update to 2.10.1.mezz2005-04-034-8/+6 * BROKEN: Incomplete pkg-plistkris2005-03-271-0/+2 * Update to KDE 3.4lofi2005-03-214-12/+17 * Update to to 1.3.1.thierry2005-03-192-5/+9 * Fully-qualify the path to update-desktop-database and update-mime-database inmezz2005-03-174-4/+6 * . Update to 1.02.016.glewis2005-03-172-4/+4 * . Update to 1.02.016.glewis2005-03-172-3/+3 * . Update to 1.02.015.glewis2005-03-163-22/+3 * . Update to 1.02.014.glewis2005-03-153-3/+22 * Unbreak: Fix plistvs2005-03-142-2/+2 * upgrade to 0.9.2ijliao2005-03-132-3/+3 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-1/+1 * Presenting GNOME 2.10 for FreeBSD!marcus2005-03-128-164/+66 * - Upgrade to to 1.3.0:thierry2005-03-083-7/+7 * Respect the user's USE_LINUX setting.trevor2005-03-021-1/+1 * Upgdrade to Feb 28 versionache2005-03-022-2/+3 * - missing section 5 manfile in Makefilevs2005-03-011-2/+5 * Upgrade to 5.52ache2005-03-012-5/+5 * Install lzx_constants.h too.skv2005-02-283-2/+3 * BROKEN: Incomplete pkg-plistkris2005-02-281-0/+2 * Add liblzxcomp 20020618, LZX compression library.skv2005-02-287-0/+82 * . Update to 1.02.010.glewis2005-02-272-3/+3 * - Update to 1.5.a.58sem2005-02-268-82/+52 * - update Martin's email addressleeym2005-02-242-4/+4 * . Update to 1.02.009.glewis2005-02-242-3/+3 * Fix multiple security vulnerabilities:naddy2005-02-224-1/+177 * . Change the default path to search for the source when building an RPMglewis2005-02-192-0/+26 * . Update to 1.02.006.glewis2005-02-172-3/+3 * Miguel Mendez is the new victim of these ports. Thanks!erwin2005-02-151-1/+1 * Update to 2.8.4.adamw2005-02-154-8/+6 * With portmgr hat on, reset maintainership of these ports. Maintainer'slinimon2005-02-141-1/+1 * Add a patch to work around on 4-stable (perl-5.00503's Fcntl.pm doeskuriyama2005-02-132-0/+12 * - Fix build errors, now using autoconf-2.59leeym2005-02-111-2/+1 * Remove the double post-install target.mezz2005-02-102-8/+4 * Add manual to update the mimetype database, it seems like GNOME developersmezz2005-02-102-2/+8 * - Grant maintainership to submittersem2005-02-021-1/+1 * . Update to 1.02.002.glewis2005-02-022-3/+3 * Add target to kill the configure warning and games/wesnoth's many compilemezz2005-02-011-0/+1 * - Update to 0.9.1sem2005-01-312-3/+3 * - Install zipios-config.hpav2005-01-312-0/+4 * - Update to 0.1.5.9-cvs-2004.02.07 tarball provided by Debianpav2005-01-3111-198/+30 * Fix command line parsing.naddy2005-01-302-0/+18 * Fix post-patch: sed(1) expression s/// cannot receive tokens withlioux2005-01-301-2/+2 * - Update to bsd.java.mk 2.0hq2005-01-292-4/+14 * Remove libtool archive.kevlo2005-01-282-2/+0 * Update to 0.31perky2005-01-263-29/+7 * Update to 0.7.6perky2005-01-262-3/+3 * Seems to work on amd64 tooarved2005-01-251-1/+1 * Seems to work on amd64arved2005-01-251-1/+1 * Set LATEST_LINK.krion2005-01-221-0/+1 * - Update to 0.90.3.bclement2005-01-192-4/+4 * - Update to 0.8.39clement2005-01-194-7/+36 * update to 4.14.sf2005-01-182-3/+3 * [NEW PORT] archivers/orange: Extract Microsoft Cabinet files from self-extrac...edwin2005-01-1411-0/+245 * [NEW PORT] archivers/dynamite: Decompress data compressed withedwin2005-01-149-0/+87 * Update to 1.04.kuriyama2005-01-112-3/+3 * upgrade to 0.8.3ijliao2005-01-112-3/+3 * Update to 1.15.1. Notable changes:naddy2005-01-105-3/+47 * - Update to 1.01.022sem2005-01-092-3/+3 * Update to 1.25.fjoe2005-01-0813-650/+358 * o Fix PLISTlioux2005-01-031-0/+4 * Say hello to the linux mega patch, it consolidates our linux bits anetchild2005-01-011-0/+1 * New port jzlib version 1.0.5: A re-implementation of zlib in pure Javalioux2004-12-314-0/+85 * Update to 1.23mat2004-12-292-4/+5 * . Update to 1.01.022.glewis2004-12-292-3/+3 * . Try to remove ${PREFIX}/src when deinstalling as the port creates thisglewis2004-12-292-0/+2 * update to 4.13.sf2004-12-284-9/+68 * Apparently, distfile got rerolled for some reason, but diff(1) shows nodanfe2004-12-272-3/+1 * Update to 0.5.6.knu2004-12-263-3/+4