aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2016-11-28 21:57:58 +0800
committerstephen <stephen@FreeBSD.org>2016-11-28 21:57:58 +0800
commit00d27b556a4f3300049944130510c5c4c36ab295 (patch)
tree82ef74900ba1445070a826eb6214b23f633f0af4 /math
parent03da24b9f3d7dfa15acc847e41976be3808cb833 (diff)
downloadfreebsd-ports-gnome-00d27b556a4f3300049944130510c5c4c36ab295.tar.gz
freebsd-ports-gnome-00d27b556a4f3300049944130510c5c4c36ab295.tar.zst
freebsd-ports-gnome-00d27b556a4f3300049944130510c5c4c36ab295.zip
- A better patch to fix the problem purportedly solved in r427058.
- Bump portrevision. Submitted by: Oliver Heimlich <oheim@posteo.de>
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-interval/Makefile2
-rw-r--r--math/octave-forge-interval/files/patch-mpfr__to__string__d.cc12
2 files changed, 5 insertions, 9 deletions
diff --git a/math/octave-forge-interval/Makefile b/math/octave-forge-interval/Makefile
index 35e5c2900e94..64a178a59212 100644
--- a/math/octave-forge-interval/Makefile
+++ b/math/octave-forge-interval/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-interval
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
diff --git a/math/octave-forge-interval/files/patch-mpfr__to__string__d.cc b/math/octave-forge-interval/files/patch-mpfr__to__string__d.cc
index 5e70c15b6fb9..110ec181d5ff 100644
--- a/math/octave-forge-interval/files/patch-mpfr__to__string__d.cc
+++ b/math/octave-forge-interval/files/patch-mpfr__to__string__d.cc
@@ -1,15 +1,11 @@
---- mpfr_to_string_d.cc.orig 2016-11-24 18:19:39 UTC
+--- mpfr_to_string_d.cc.orig 2016-11-20 13:47:35 UTC
+++ mpfr_to_string_d.cc
-@@ -201,10 +201,10 @@ DEFUN_DLD (mpfr_to_string_d, args, nargo
+@@ -201,7 +201,7 @@ DEFUN_DLD (mpfr_to_string_d, args, nargo
// Make subnormal numbers use the exponent -1022
if (exponent < std::numeric_limits <double>::min_exponent)
{
- mantissa /= std::pow (2.0,
-+ mantissa /= std::pow (2.0, (int)(
++ mantissa /= uint64_t (1) << (
std::numeric_limits
<double>::min_exponent - 1
-- - exponent);
-+ - exponent));
- exponent = std::numeric_limits <double>::min_exponent - 1;
- }
-
+ - exponent);