aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-10-03 16:52:08 +0800
committerpi <pi@FreeBSD.org>2019-10-03 16:52:08 +0800
commit0235581c8e5c6529395095f7b1068725b0c68b1c (patch)
tree5c1887b3310b897b9ef70ab51ff58b1f49523dfa /math
parent2634ef2b4b0c93f518baff47a0fa77f6149b5cc3 (diff)
downloadfreebsd-ports-gnome-0235581c8e5c6529395095f7b1068725b0c68b1c.tar.gz
freebsd-ports-gnome-0235581c8e5c6529395095f7b1068725b0c68b1c.tar.zst
freebsd-ports-gnome-0235581c8e5c6529395095f7b1068725b0c68b1c.zip
New port: math/mcsim
GNU MCSim is a simulation package, written in C, which allows you to: * design and run your own statistical or simulation models * perform Monte Carlo stochastic simulations * do Bayesian inference through Markov Chain Monte Carlo simulations * formally optimize experimental designs WWW: https://www.gnu.org/software/mcsim/ PR: 240966 Submitted by: Alessandro Sagratini <ale_sagra@hotmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/mcsim/Makefile46
-rw-r--r--math/mcsim/distinfo3
-rw-r--r--math/mcsim/pkg-descr8
-rw-r--r--math/mcsim/pkg-plist85
5 files changed, 143 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 2ce6f16ca1e7..316bb3323758 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -354,6 +354,7 @@
SUBDIR += matlab-installer
SUBDIR += maxima
SUBDIR += mbasecalc
+ SUBDIR += mcsim
SUBDIR += metis
SUBDIR += metis-edf
SUBDIR += metis4
diff --git a/math/mcsim/Makefile b/math/mcsim/Makefile
new file mode 100644
index 000000000000..330a9486ecb0
--- /dev/null
+++ b/math/mcsim/Makefile
@@ -0,0 +1,46 @@
+# Created by: Alessando Sagratini <ale_sagra@hotmail.com>
+# $FreeBSD$
+
+PORTNAME= mcsim
+PORTVERSION= 6.1.0
+CATEGORIES= math
+MASTER_SITES= GNU
+
+MAINTAINER= ale_sagra@hotmail.com
+COMMENT= Monte Carlo stochastic simulations and Bayesian inference
+
+LICENSE= GPLv3+
+
+BUILD_DEPENDS= indexinfo>=0.3.0:print/indexinfo
+
+USES= libtool shebangfix
+
+USE_LDCONFIG= yes
+
+INFO= mcsim
+
+SHEBANG_FILES= sim/makemcsim.in sim/makemcsims.in sim/makemcsimd.in
+
+INSTALL_TARGET= install-strip
+
+GNU_CONFIGURE= yes
+OPTIONS_SUB= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+OPTIONS_DEFINE= GSL SUNDIALS
+GSL_DESC= GNU Scientific Library support (recommended)
+SUNDIALS_DESC= Sundial's Cvodes integrator
+
+OPTIONS_DEFAULT=GSL
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSUNDIALS}
+BUILD_DEPENDS+= sundials>=3.0.0:math/sundials
+.endif
+
+.if ${PORT_OPTIONS:MGSL}
+BUILD_DEPENDS+= gsl>=2.5:math/gsl
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/mcsim/distinfo b/math/mcsim/distinfo
new file mode 100644
index 000000000000..fc799484c494
--- /dev/null
+++ b/math/mcsim/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569855064
+SHA256 (mcsim-6.1.0.tar.gz) = ab50d8cc89cf307a1d3442dfc53cc07d11f911f390df768ce8e32db6dcf56553
+SIZE (mcsim-6.1.0.tar.gz) = 2292988
diff --git a/math/mcsim/pkg-descr b/math/mcsim/pkg-descr
new file mode 100644
index 000000000000..4302fd7eddf5
--- /dev/null
+++ b/math/mcsim/pkg-descr
@@ -0,0 +1,8 @@
+GNU MCSim is a simulation package, written in C, which allows you to:
+
+ * design and run your own statistical or simulation models
+ * perform Monte Carlo stochastic simulations
+ * do Bayesian inference through Markov Chain Monte Carlo simulations
+ * formally optimize experimental designs
+
+WWW: https://www.gnu.org/software/mcsim/
diff --git a/math/mcsim/pkg-plist b/math/mcsim/pkg-plist
new file mode 100644
index 000000000000..a0a4e7e3e45f
--- /dev/null
+++ b/math/mcsim/pkg-plist
@@ -0,0 +1,85 @@
+bin/makemcsim
+bin/mod
+bin/makemcsims
+bin/makemcsimd
+include/delays.h
+include/matutil.h
+include/list.h
+include/lex.h
+include/sim.h
+include/lexfn.h
+include/hungtype.h
+include/modiface.h
+include/modelu.h
+include/random.h
+include/yourcode.h
+include/config.h
+lib/libmcsim.so.0.0.0
+lib/libmcsim.so.0
+lib/libmcsim.so
+lib/libmcsim.a
+%%DATADIR%%/mod/getopt.c
+%%DATADIR%%/mod/getopt.h
+%%DATADIR%%/mod/hungtype.h
+%%DATADIR%%/mod/lex.c
+%%DATADIR%%/mod/lex.h
+%%DATADIR%%/mod/lexerr.c
+%%DATADIR%%/mod/lexerr.h
+%%DATADIR%%/mod/lexfn.c
+%%DATADIR%%/mod/lexfn.h
+%%DATADIR%%/mod/mod.c
+%%DATADIR%%/mod/mod.h
+%%DATADIR%%/mod/modd.c
+%%DATADIR%%/mod/modd.h
+%%DATADIR%%/mod/modi.c
+%%DATADIR%%/mod/modi.h
+%%DATADIR%%/mod/modiSBML.c
+%%DATADIR%%/mod/modiSBML2.c
+%%DATADIR%%/mod/modiSBML.h
+%%DATADIR%%/mod/modo.c
+%%DATADIR%%/mod/modo.h
+%%DATADIR%%/mod/strutil.c
+%%DATADIR%%/mod/strutil.h
+%%DATADIR%%/sim/delays.c
+%%DATADIR%%/sim/delays.h
+%%DATADIR%%/sim/getopt.c
+%%DATADIR%%/sim/getopt.h
+%%DATADIR%%/sim/hungtype.h
+%%DATADIR%%/sim/lex.c
+%%DATADIR%%/sim/lex.h
+%%DATADIR%%/sim/lexerr.c
+%%DATADIR%%/sim/lexerr.h
+%%DATADIR%%/sim/lexfn.c
+%%DATADIR%%/sim/lexfn.h
+%%DATADIR%%/sim/list.c
+%%DATADIR%%/sim/list.h
+%%DATADIR%%/sim/lsodes.h
+%%DATADIR%%/sim/lsodes1.c
+%%DATADIR%%/sim/lsodes2.c
+%%DATADIR%%/sim/matutil.c
+%%DATADIR%%/sim/matutil.h
+%%DATADIR%%/sim/matutilo.c
+%%DATADIR%%/sim/matutilo.h
+%%DATADIR%%/sim/mh.c
+%%DATADIR%%/sim/mh.h
+%%DATADIR%%/sim/modelu.c
+%%DATADIR%%/sim/modelu.h
+%%DATADIR%%/sim/modiface.h
+%%DATADIR%%/sim/optdsign.c
+%%DATADIR%%/sim/optdsign.h
+%%DATADIR%%/sim/random.c
+%%DATADIR%%/sim/random.h
+%%DATADIR%%/sim/sim.c
+%%DATADIR%%/sim/sim.h
+%%DATADIR%%/sim/simi.c
+%%DATADIR%%/sim/simi.h
+%%DATADIR%%/sim/siminit.c
+%%DATADIR%%/sim/siminit.h
+%%DATADIR%%/sim/simmonte.c
+%%DATADIR%%/sim/simmonte.h
+%%DATADIR%%/sim/simo.c
+%%DATADIR%%/sim/simo.h
+%%DATADIR%%/sim/strutil.c
+%%DATADIR%%/sim/strutil.h
+%%DATADIR%%/sim/yourcode.c
+%%DATADIR%%/sim/yourcode.h