aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-21 10:59:06 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-21 10:59:06 +0800
commit05606ff0e97340c17084cfc6d3805e47616276d9 (patch)
tree01d9d038491835b38cf9c10505c5bf16c598b35b /math
parent5dbfc8f5c7cc493800cc4615d1c404269192dca7 (diff)
downloadfreebsd-ports-gnome-05606ff0e97340c17084cfc6d3805e47616276d9.tar.gz
freebsd-ports-gnome-05606ff0e97340c17084cfc6d3805e47616276d9.tar.zst
freebsd-ports-gnome-05606ff0e97340c17084cfc6d3805e47616276d9.zip
New port: math/py-spectral: Spectral Python (SPy) is a Python module for hyperspectral image processing
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-spectral/Makefile21
-rw-r--r--math/py-spectral/distinfo3
-rw-r--r--math/py-spectral/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 08de40163024..b7fe6af0f32f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -719,6 +719,7 @@
SUBDIR += py-seaborn
SUBDIR += py-secp256k1
SUBDIR += py-simhash
+ SUBDIR += py-spectral
SUBDIR += py-statsmodels
SUBDIR += py-svgmath
SUBDIR += py-sym
diff --git a/math/py-spectral/Makefile b/math/py-spectral/Makefile
new file mode 100644
index 000000000000..872433189165
--- /dev/null
+++ b/math/py-spectral/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= spectral
+DISTVERSION= 0.19
+CATEGORIES= math
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Spectral Python (SPy) is a Python module for hyperspectral image processing
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-spectral/distinfo b/math/py-spectral/distinfo
new file mode 100644
index 000000000000..aad80bba81c3
--- /dev/null
+++ b/math/py-spectral/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529549527
+SHA256 (spectral-0.19.tar.gz) = b8d5dc9e2e36d45d1f55bf95528a63d7a95dd049857c98f86d400a3f0c7c86f1
+SIZE (spectral-0.19.tar.gz) = 141565
diff --git a/math/py-spectral/pkg-descr b/math/py-spectral/pkg-descr
new file mode 100644
index 000000000000..dac5b4beb707
--- /dev/null
+++ b/math/py-spectral/pkg-descr
@@ -0,0 +1,12 @@
+Spectral Python (SPy) is a pure Python module for processing hyperspectral
+image data. It has functions for reading, displaying, manipulating, and
+classifying hyperspectral imagery. It can be used interactively from the Python
+command prompt or via Python scripts. SPy is free, open source software
+distributed under the GNU General Public License. To see some examples of how
+SPy can be used, you may want to jump straight to the documentation sections
+on Displaying Data or Spectral Algorithms. A categorized listing of the main
+classes and functions are in the Class/Function Glossary. You can download SPy
+from GitHub or the Python Package Index (PyPI). See the Installing SPy section
+section of the documentation for details.
+
+WWW: http://www.spectralpython.net/