aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-02-07 15:41:28 +0800
committerBrendan Fabeny <bf@FreeBSD.org>2011-02-07 15:41:28 +0800
commit067f883824555a8dd8f73dc55a8571638a891e6d (patch)
tree2a4f6ee82c0b745762e3559d241a83c26a980d80 /math
parent768e7ec67462e425c0425f077c40d746c4ec998b (diff)
downloadfreebsd-ports-gnome-067f883824555a8dd8f73dc55a8571638a891e6d.tar.gz
freebsd-ports-gnome-067f883824555a8dd8f73dc55a8571638a891e6d.tar.zst
freebsd-ports-gnome-067f883824555a8dd8f73dc55a8571638a891e6d.zip
Update to 1.48
Approved by: makc, miwi (mentors, implicit) Feature safe: yes
Diffstat (limited to 'math')
-rw-r--r--math/msieve/Makefile7
-rw-r--r--math/msieve/distinfo5
-rw-r--r--math/msieve/files/patch-Makefile9
3 files changed, 12 insertions, 9 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 1102041b7a8f..8f6afb77b1a7 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msieve
-PORTVERSION= 1.46
+PORTVERSION= 1.48
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= \
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:${PORTSDIR}/math/gmp-ecm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-CFLAGS+= -D_FILE_OFFSET_BITS=64 -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= LDFLAGS="${LDFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" ECM=1
@@ -61,4 +61,7 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+regression-test test check: build
+ @( cd ${WRKSRC} ; ./msieve -q -d 1 2385734365243128176756453434347656453122245767798 )
+
.include <bsd.port.post.mk>
diff --git a/math/msieve/distinfo b/math/msieve/distinfo
index 07848315c276..adfed15909c3 100644
--- a/math/msieve/distinfo
+++ b/math/msieve/distinfo
@@ -1,3 +1,2 @@
-MD5 (msieve146.tar.gz) = d54ef004aedeef9ee4994a44137f9b43
-SHA256 (msieve146.tar.gz) = 227295fd2f87658b48fe10bbc30bc86c985c871a95c38b12892acd40db86d026
-SIZE (msieve146.tar.gz) = 409970
+SHA256 (msieve148.tar.gz) = c3c0b36d230a797de84b3da18e073a328c8ae2d28308d5b0d67c6977eb109515
+SIZE (msieve148.tar.gz) = 369047
diff --git a/math/msieve/files/patch-Makefile b/math/msieve/files/patch-Makefile
index 534786cb12f7..8daa6f6014f5 100644
--- a/math/msieve/files/patch-Makefile
+++ b/math/msieve/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2010-08-28 03:28:32.000000000 -0400
-+++ Makefile 2010-08-28 03:39:28.000000000 -0400
+--- Makefile.orig 2011-02-06 19:12:31.000000000 -0500
++++ Makefile 2011-02-06 19:12:39.000000000 -0500
@@ -14,12 +14,12 @@
# gcc with basic optimization (-march flag could
@@ -8,15 +8,16 @@
+#CC = gcc -D_FILE_OFFSET_BITS=64
WARN_FLAGS = -Wall -W
-OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -DNDEBUG
+-OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8 -DNDEBUG -D_LARGEFILE64_SOURCE
+#OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -DNDEBUG
- #OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8 -DNDEBUG
++#OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8 -DNDEBUG -D_LARGEFILE64_SOURCE
-CFLAGS = $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) \
+CFLAGS += $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) \
-I. -Iinclude -Ignfs -Ignfs/poly -Ignfs/poly/stage1
# tweak the compile flags
-@@ -60,7 +60,7 @@
+@@ -61,7 +61,7 @@
# win32 or win64, so it's safe to pull libpthread into the link line.
# Of course this does mean you have to install the minGW pthreads bundle...