aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-05-07 03:49:54 +0800
committermaho <maho@FreeBSD.org>2004-05-07 03:49:54 +0800
commit0b7cae99d95cb6f9e01f28b743bfe78cdd891f95 (patch)
tree05d7dd670545ccd765b1c382417da5761c7fdd1a /math
parent50f19019ab8b4be06345305a6d009ab3abf9e483 (diff)
downloadfreebsd-ports-gnome-0b7cae99d95cb6f9e01f28b743bfe78cdd891f95.tar.gz
freebsd-ports-gnome-0b7cae99d95cb6f9e01f28b743bfe78cdd891f95.tar.zst
freebsd-ports-gnome-0b7cae99d95cb6f9e01f28b743bfe78cdd891f95.zip
Make portlint happy by replacing space to tab
PR: 65409 Submitted by: trevor
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile14
-rw-r--r--math/atlas/Makefile12
-rw-r--r--math/blacs/Makefile6
-rw-r--r--math/lapack++/Makefile2
-rw-r--r--math/scalapack/Makefile4
-rw-r--r--math/sdpa/Makefile12
-rw-r--r--math/spooles-mpich/Makefile4
-rw-r--r--math/spooles/Makefile18
8 files changed, 36 insertions, 36 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index a664daec1f14..01699b7a4233 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -13,16 +13,16 @@ PORTVERSION= 3.7.3
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= math-atlas
-PKGNAMESUFFIX= -devel
+PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
-COMMENT= Development version of math/atlas
+COMMENT= Development version of math/atlas
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/ATLAS
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
NO_PACKAGE= runtime performance heavily depends on building environment
.include <bsd.port.pre.mk>
@@ -33,9 +33,9 @@ USE_GCC=3.3
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
-FFLAGS+= -pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
+FFLAGS+=-pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
-FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
+FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
.endif
@@ -50,7 +50,7 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
-PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
+PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index bc1b265ecc2f..cf22251ae149 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -17,12 +17,12 @@ MASTER_SITE_SUBDIR= math-atlas
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
-COMMENT= Automatically Tuned Linear Algebra Software (ATLAS)
+COMMENT= Automatically Tuned Linear Algebra Software (ATLAS)
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/ATLAS
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -32,9 +32,9 @@ USE_GCC=3.3
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
-FFLAGS+= -pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
+FFLAGS+=-pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
-FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
+FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
.endif
@@ -49,7 +49,7 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
-PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
+PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 8a35cb4f4ee0..11d3cfbb8cf6 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.netlib.org/blacs/
DISTNAME= BLACS
DISTFILES= mpiblacs.tgz blacstester.tgz mpiblacs-patch03.tgz
.if !defined(NOPORTDOCS)
-DISTFILES+= blacs_install.ps f77blacsqref.ps lawn94.ps \
+DISTFILES+= blacs_install.ps f77blacsqref.ps lawn94.ps \
cblacsqref.ps mpi_prop.ps mpiblacs_issues.ps
.endif
DIST_SUBDIR= blacs
@@ -34,9 +34,9 @@ pre-fetch:
F77?= f77
.if !defined(NO_GNUF77)
-F77EXTRAFLAGS= -w -fno-globals -fugly-complex
+F77EXTRAFLAGS= -w -fno-globals -fugly-complex
.endif
-USE_REINPLACE= yes
+USE_REINPLACE= yes
DEBUG_LEVEL= 0
pre-patch:
diff --git a/math/lapack++/Makefile b/math/lapack++/Makefile
index d7e01f1f3003..e9a73197584f 100644
--- a/math/lapack++/Makefile
+++ b/math/lapack++/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.1
CATEGORIES= math
MASTER_SITES= http://math.nist.gov/lapack++/
DISTNAME= Lapackpp1_1a
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tgz
.if !defined(NOPORTDOCS)
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} lapack++.ps.gz lapackpp1_1.ps.gz \
lapackppman1_1.ps.gz lapack++_install.ps.gz
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index fb73fb42077d..1a1cea41ad95 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.netlib.org/scalapack/
DISTNAME= SCALAPACK
DISTFILES= scalapack.tgz manpages.tgz
.if !defined(NOPORTDOCS)
-DISTFILES+= scalapack_install.ps scalapackqref.ps \
+DISTFILES+= scalapack_install.ps scalapackqref.ps \
lawn100.ps pblasqref.ps manual.ps design.ps \
pumma_refmanual.ps trans.ps
.endif
@@ -30,7 +30,7 @@ LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
atlas:${PORTSDIR}/math/atlas
F77?= f77
-USE_REINPLACE= yes
+USE_REINPLACE= yes
.include "files/manpages"
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 40307cc5f244..86121db812b8 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sdpa
PORTVERSION= 6.00
-PORTREVISION= 2
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://sdpa.is.titech.ac.jp/
DISTFILES= ${PORTNAME}.${PORTVERSION}.src.tar.gz
@@ -16,7 +16,7 @@ DISTFILES+= ${PORTNAME}.${PORTVERSION}.manual.ps.gz \
${PORTNAME}.${PORTVERSION}.manual.pdf \
${PORTNAME}.${PORTVERSION}.install.txt
.endif
-DIST_SUBDIR= sdpa
+DIST_SUBDIR= sdpa
EXTRACT_ONLY= ${PORTNAME}.${PORTVERSION}.src.tar.gz
MAINTAINER= maho@FreeBSD.org
@@ -34,11 +34,11 @@ LAPACK= -lalapack
CBLAS= -lcblas -lf77blas -latlas -lg2c
.if defined(WITH_OPTIMIZED_FLAGS)
-CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
-CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
+CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
+CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
.if (${MACHINE_ARCH} == "i386")
-CFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
-CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CFLAGS+=-mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CXXFLAGS+=-mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
.endif # i386
.endif
diff --git a/math/spooles-mpich/Makefile b/math/spooles-mpich/Makefile
index 25a8a2dcb764..00699ab0b3c6 100644
--- a/math/spooles-mpich/Makefile
+++ b/math/spooles-mpich/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../spooles/
+MASTERDIR= ${.CURDIR}/../spooles/
USE_MPI= YES
.include "${MASTERDIR}/Makefile"
-PKGNAMESUFFIX= -mpich
+PKGNAMESUFFIX= -mpich
diff --git a/math/spooles/Makefile b/math/spooles/Makefile
index 3e44f21da7bb..6d943b4236b6 100644
--- a/math/spooles/Makefile
+++ b/math/spooles/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://www.netlib.org/linalg/spooles/
DISTNAME= ${PORTNAME}.${PORTVERSION}
EXTRACT_SUFX= .tgz
.ifndef NOPORTDOCS
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} AllInOne.ps.gz Eigen.ps.gz \
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} AllInOne.ps.gz Eigen.ps.gz \
Install.ps.gz LinSol.ps.gz Ordering.ps.gz \
PP99.ps.gz ReferenceManual.ps.gz
.endif
-DIST_SUBDIR= spooles
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= spooles
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= SParse Object Oriented Linear Equations Solver
@@ -34,15 +34,15 @@ MAKEFILE= makefile
ALL_TARGET= global
.if defined(USE_THREADS)
-PLIST_SUB+= MT=""
-CFLAGS+= ${PTHREAD_CFLAGS}
+PLIST_SUB+= MT=""
+CFLAGS+= ${PTHREAD_CFLAGS}
.else
-PLIST_SUB+= MT="@comment "
+PLIST_SUB+= MT="@comment "
.endif
.if defined(USE_MPI)
-PLIST_SUB+= MPI=""
+PLIST_SUB+= MPI=""
.else
-PLIST_SUB+= MPI="@comment "
+PLIST_SUB+= MPI="@comment "
.endif
.SILENT:
@@ -56,7 +56,7 @@ pre-everything::
.endif
.if defined (USE_THREADS) && (USE_MPI)
-BROKEN= mpich is *NOT* threadsafe at the moment
+BROKEN= mpich is *NOT* threadsafe at the moment
.endif
post-patch: