aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /math
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadfreebsd-ports-gnome-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
freebsd-ports-gnome-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.zst
freebsd-ports-gnome-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-BaseCnv/Makefile7
-rw-r--r--math/p5-Math-BigInt-FastCalc/Makefile2
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile2
-rw-r--r--math/p5-Math-BigInt-Pari/Makefile2
-rw-r--r--math/p5-Math-BigRat/Makefile5
-rw-r--r--math/p5-Math-String/Makefile5
6 files changed, 9 insertions, 14 deletions
diff --git a/math/p5-Math-BaseCnv/Makefile b/math/p5-Math-BaseCnv/Makefile
index 912bbdee3ea5..0a30cffd94b6 100644
--- a/math/p5-Math-BaseCnv/Makefile
+++ b/math/p5-Math-BaseCnv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Math-BaseCnv
PORTVERSION= 1.4.75
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,9 +12,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}O6Pbr
MAINTAINER= perl@FreeBSD.org
COMMENT= Fast functions to convert between number Bases
-BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
- p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+BUILD_DEPENDS= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
RUN_DEPENDS= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
+TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
USES= perl5 tar:tgz
USE_PERL5= configure
diff --git a/math/p5-Math-BigInt-FastCalc/Makefile b/math/p5-Math-BigInt-FastCalc/Makefile
index 7382db47bd0d..8c7e7f30b6f8 100644
--- a/math/p5-Math-BigInt-FastCalc/Makefile
+++ b/math/p5-Math-BigInt-FastCalc/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Math::BigInt::Calc with some XS for more speed
-BUILD_DEPENDS= p5-Math-BigInt>=1.997:${PORTSDIR}/math/p5-Math-BigInt
+BUILD_DEPENDS= p5-Math-BigInt>=1.9993:${PORTSDIR}/math/p5-Math-BigInt
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
index 95bdb313366c..430bbc2987f8 100644
--- a/math/p5-Math-BigInt-GMP/Makefile
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -14,7 +14,7 @@ COMMENT= Math::BigInt::GMP - Use the GMP library for Math::BigInt routines
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Math-BigInt>=1.997:${PORTSDIR}/math/p5-Math-BigInt
+BUILD_DEPENDS= p5-Math-BigInt>=1.9993:${PORTSDIR}/math/p5-Math-BigInt
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/math/p5-Math-BigInt-Pari/Makefile b/math/p5-Math-BigInt-Pari/Makefile
index 42ddf64da365..4fddec47af23 100644
--- a/math/p5-Math-BigInt-Pari/Makefile
+++ b/math/p5-Math-BigInt-Pari/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Use Math::Pari for Math::BigInt routines
-BUILD_DEPENDS= p5-Math-BigInt>=1.997:${PORTSDIR}/math/p5-Math-BigInt \
+BUILD_DEPENDS= p5-Math-BigInt>=1.9993:${PORTSDIR}/math/p5-Math-BigInt \
p5-Math-Pari>=2.010709:${PORTSDIR}/math/p5-Math-Pari
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/math/p5-Math-BigRat/Makefile b/math/p5-Math-BigRat/Makefile
index ec7a855ae890..016a8961af1c 100644
--- a/math/p5-Math-BigRat/Makefile
+++ b/math/p5-Math-BigRat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Math-BigRat
PORTVERSION= 0.26.02
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,9 +12,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Arbitrary big rational numbers
-BUILD_DEPENDS= p5-Math-BigInt>=1.991:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
USES= perl5
USE_PERL5= configure
diff --git a/math/p5-Math-String/Makefile b/math/p5-Math-String/Makefile
index 9d6324862e26..b04dd114e601 100644
--- a/math/p5-Math-String/Makefile
+++ b/math/p5-Math-String/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Math-String
PORTVERSION= 1.28
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,9 +11,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module to calculate with strings as if they were big integers
-BUILD_DEPENDS= p5-Math-BigInt>=1.87:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
USES= perl5
USE_PERL5= configure