aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-01-17 17:54:40 +0800
committeryuri <yuri@FreeBSD.org>2019-01-17 17:54:40 +0800
commit10faafa54d051dc51c74bd7750c44ff89bfcdb4a (patch)
tree77f937a3aad75d450e36982465c88ee28cb53921 /math
parent1cc454fee525ffe02dbb91074a7c7c82acf2a015 (diff)
downloadfreebsd-ports-gnome-10faafa54d051dc51c74bd7750c44ff89bfcdb4a.tar.gz
freebsd-ports-gnome-10faafa54d051dc51c74bd7750c44ff89bfcdb4a.tar.zst
freebsd-ports-gnome-10faafa54d051dc51c74bd7750c44ff89bfcdb4a.zip
New port: math/ascent: C++ simulation engine and differential equation solver
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/ascent/Makefile25
-rw-r--r--math/ascent/distinfo3
-rw-r--r--math/ascent/pkg-descr20
-rw-r--r--math/ascent/pkg-plist22
5 files changed, 71 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 003fe406d5c4..84edd6ca4661 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -130,6 +130,7 @@
SUBDIR += armadillo
SUBDIR += arpack++
SUBDIR += arpack-ng
+ SUBDIR += ascent
SUBDIR += aspcud
SUBDIR += asymptote
SUBDIR += atlas
diff --git a/math/ascent/Makefile b/math/ascent/Makefile
new file mode 100644
index 000000000000..d71bc6af93b0
--- /dev/null
+++ b/math/ascent/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= ascent
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.0-11
+DISTVERSIONSUFFIX= -g0b137ac
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ simulation engine and differential equation solver
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= AnyarInc
+GH_PROJECT= Ascent
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+ @cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/ascent/distinfo b/math/ascent/distinfo
new file mode 100644
index 000000000000..7fa8b8a880ed
--- /dev/null
+++ b/math/ascent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545240849
+SHA256 (AnyarInc-Ascent-v0.3.0-11-g0b137ac_GH0.tar.gz) = 7963ee3b4e842330b5975cf2d2d92deef96fa106c40fad47720c24ecbf8b5ee6
+SIZE (AnyarInc-Ascent-v0.3.0-11-g0b137ac_GH0.tar.gz) = 50402
diff --git a/math/ascent/pkg-descr b/math/ascent/pkg-descr
new file mode 100644
index 000000000000..2b7dc172e7e0
--- /dev/null
+++ b/math/ascent/pkg-descr
@@ -0,0 +1,20 @@
+An extremely fast and flexible C++ simulation engine and differential equation
+solver.
+
+Ascent's integration algorithms are designed for speed, and outperform boost's
+odeint in both Debug and Release.
+
+Features:
+* Header Only
+* Automatic Vectorization: Ascent conforms to vectorization standards
+ (such as Intel's)
+* Modular (Optional): solve systems in an object-oriented manner
+* Variable Tracking: Optimized recording of variable time history
+* Asynchronous Sampling and Event Scheduling
+* Multiple Integration Algorithms (In Progress): adaptive steppers,
+ predictor-correctors, etc.
+* Use boost's odeint library as the numerical integration engine
+* Scripting Interface: Optional ChaiScript interface to easily script
+ simulations
+
+WWW: https://github.com/AnyarInc/Ascent
diff --git a/math/ascent/pkg-plist b/math/ascent/pkg-plist
new file mode 100644
index 000000000000..767220f3f16f
--- /dev/null
+++ b/math/ascent/pkg-plist
@@ -0,0 +1,22 @@
+include/ascent/Ascent.h
+include/ascent/ChaiEngine.h
+include/ascent/Param.h
+include/ascent/ParamV.h
+include/ascent/Recorder.h
+include/ascent/System.h
+include/ascent/Utility.h
+include/ascent/Vector.h
+include/ascent/algorithms/Derivative.h
+include/ascent/containers/stack.h
+include/ascent/integrators/DOPRI45.h
+include/ascent/integrators/Euler.h
+include/ascent/integrators/Midpoint.h
+include/ascent/integrators/PC233.h
+include/ascent/integrators/RK2.h
+include/ascent/integrators/RK4.h
+include/ascent/integrators/RKMM.h
+include/ascent/integrators/RTAM4.h
+include/ascent/threading/Pool.h
+include/ascent/threading/Queue.h
+include/ascent/timing/Sampler.h
+include/ascent/timing/TimeAdvanced.h