aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-05-09 04:58:19 +0800
committerjkim <jkim@FreeBSD.org>2015-05-09 04:58:19 +0800
commit15373accff273879d32a8c6e1f75a335c4112561 (patch)
tree019b7588e49225214b2df0c330ca701df2bcf223 /math
parente5ff1695c0f4f72a28507822b963430ec7387226 (diff)
downloadfreebsd-ports-gnome-15373accff273879d32a8c6e1f75a335c4112561.tar.gz
freebsd-ports-gnome-15373accff273879d32a8c6e1f75a335c4112561.tar.zst
freebsd-ports-gnome-15373accff273879d32a8c6e1f75a335c4112561.zip
- Update to 0.9.6.3.
- Replace the previous hack with a more generic fix for FreeBSD 8.x and 9.x. - Add LICENSE and NO_ARCH. Approved by: demon (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/glm/Makefile12
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/files/patch-glm__detail__type_int.hpp35
-rw-r--r--math/glm/files/patch-glm_detail_setup.hpp54
-rw-r--r--math/glm/pkg-plist36
5 files changed, 83 insertions, 58 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index d6836f3f2923..3eb6b99b25ea 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,21 +2,25 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.5.4
-PORTREVISION= 1
+PORTVERSION= 0.9.6.3
PORTEPOCH= 1
CATEGORIES= math graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= ogl-math/${PORTNAME}-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
COMMENT= C++ mathematics library for software based on the OpenGL GLSL
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/copying.txt
+
USES= zip dos2unix
+NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
- (cd ${WRKSRC} && ${FIND} glm -print -depth | ${CPIO} -pdm ${STAGEDIR}${PREFIX}/include/)
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/include '( ! -name *.orig )'
.include <bsd.port.mk>
diff --git a/math/glm/distinfo b/math/glm/distinfo
index ce4f425e5bba..56b096ac3fe7 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glm-0.9.5.4.zip) = c25002f109104bb8eb37a7e74c745cbc0a713ec5d9a857050c7878edb5ee246c
-SIZE (glm-0.9.5.4.zip) = 4081182
+SHA256 (glm-0.9.6.3.zip) = 14651b56b10fa68082446acaf6a1116d56b757c8d375b34b5226a83140acd2b2
+SIZE (glm-0.9.6.3.zip) = 4233404
diff --git a/math/glm/files/patch-glm__detail__type_int.hpp b/math/glm/files/patch-glm__detail__type_int.hpp
deleted file mode 100644
index 1a3fd5ddc853..000000000000
--- a/math/glm/files/patch-glm__detail__type_int.hpp
+++ /dev/null
@@ -1,35 +0,0 @@
---- glm/detail/type_int.hpp.orig 2014-12-04 12:55:42.000000000 -0500
-+++ glm/detail/type_int.hpp 2014-12-04 12:57:55.000000000 -0500
-@@ -32,22 +32,22 @@
- #include "setup.hpp"
-
- #if GLM_HAS_EXTENDED_INTEGER_TYPE
--# include <cstdint>
-+# include <tr1/cstdint>
- #endif
-
- namespace glm{
- namespace detail
- {
- # if GLM_HAS_EXTENDED_INTEGER_TYPE
-- typedef std::int8_t int8;
-- typedef std::int16_t int16;
-- typedef std::int32_t int32;
-- typedef std::int64_t int64;
--
-- typedef std::uint8_t uint8;
-- typedef std::uint16_t uint16;
-- typedef std::uint32_t uint32;
-- typedef std::uint64_t uint64;
-+ typedef ::int8_t int8;
-+ typedef ::int16_t int16;
-+ typedef ::int32_t int32;
-+ typedef ::int64_t int64;
-+
-+ typedef ::uint8_t uint8;
-+ typedef ::uint16_t uint16;
-+ typedef ::uint32_t uint32;
-+ typedef ::uint64_t uint64;
- # else
- # if(defined(__STDC_VERSION__) && (__STDC_VERSION__ >= 199901L)) // C99 detected, 64 bit types available
- typedef int64_t sint64;
diff --git a/math/glm/files/patch-glm_detail_setup.hpp b/math/glm/files/patch-glm_detail_setup.hpp
new file mode 100644
index 000000000000..f19ff68311a9
--- /dev/null
+++ b/math/glm/files/patch-glm_detail_setup.hpp
@@ -0,0 +1,54 @@
+--- glm/detail/setup.hpp.orig 2015-05-07 21:31:27 UTC
++++ glm/detail/setup.hpp
+@@ -62,6 +62,7 @@
+ #define GLM_PLATFORM_UNIX 0x00400000
+ #define GLM_PLATFORM_QNXNTO 0x00800000
+ #define GLM_PLATFORM_WINCE 0x01000000
++#define GLM_PLATFORM_FREEBSD 0x02000000
+
+ #ifdef GLM_FORCE_PLATFORM_UNKNOWN
+ # define GLM_PLATFORM GLM_PLATFORM_UNKNOWN
+@@ -79,6 +80,8 @@
+ # define GLM_PLATFORM GLM_PLATFORM_ANDROID
+ #elif defined(__linux)
+ # define GLM_PLATFORM GLM_PLATFORM_LINUX
++#elif defined(__FreeBSD__)
++# define GLM_PLATFORM GLM_PLATFORM_FREEBSD
+ #elif defined(__unix)
+ # define GLM_PLATFORM GLM_PLATFORM_UNIX
+ #else
+@@ -104,6 +107,8 @@
+ # pragma message("GLM: Android platform detected")
+ # elif(GLM_PLATFORM & GLM_PLATFORM_LINUX)
+ # pragma message("GLM: Linux platform detected")
++# elif(GLM_PLATFORM & GLM_PLATFORM_FREEBSD)
++# pragma message("GLM: FreeBSD platform detected")
+ # elif(GLM_PLATFORM & GLM_PLATFORM_UNIX)
+ # pragma message("GLM: UNIX platform detected")
+ # elif(GLM_PLATFORM & GLM_PLATFORM_UNKNOWN)
+@@ -523,7 +528,11 @@
+
+ // N1988
+ #if GLM_LANG & GLM_LANG_CXX11_FLAG
+-# define GLM_HAS_EXTENDED_INTEGER_TYPE 1
++# if (GLM_PLATFORM & GLM_PLATFORM_FREEBSD) && (GLM_COMPILER & GLM_COMPILER_LLVM)
++# define GLM_HAS_EXTENDED_INTEGER_TYPE __has_include(<__config>)
++# else
++# define GLM_HAS_EXTENDED_INTEGER_TYPE 1
++# endif
+ #else
+ # define GLM_HAS_EXTENDED_INTEGER_TYPE (\
+ ((GLM_LANG & GLM_LANG_CXX0X_FLAG) && (GLM_COMPILER & GLM_COMPILER_VC) && (GLM_COMPILER >= GLM_COMPILER_VC2012)) || \
+@@ -638,7 +647,11 @@
+
+ //
+ #if GLM_LANG & GLM_LANG_CXX11_FLAG
+-# define GLM_HAS_MAKE_SIGNED 1
++# if (GLM_PLATFORM & GLM_PLATFORM_FREEBSD) && (GLM_COMPILER & GLM_COMPILER_LLVM)
++# define GLM_HAS_MAKE_SIGNED __has_include(<__config>)
++# else
++# define GLM_HAS_MAKE_SIGNED 1
++# endif
+ #else
+ # define GLM_HAS_MAKE_SIGNED (GLM_LANG & GLM_LANG_CXX0X_FLAG) && (\
+ ((GLM_COMPILER & GLM_COMPILER_VC) && (GLM_COMPILER >= GLM_COMPILER_VC2013)))
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index 51d8d284e628..c51b1270e742 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -2,7 +2,6 @@ include/glm/CMakeLists.txt
include/glm/common.hpp
include/glm/detail/_features.hpp
include/glm/detail/_fixes.hpp
-include/glm/detail/_literals.hpp
include/glm/detail/_noise.hpp
include/glm/detail/_swizzle.hpp
include/glm/detail/_swizzle_func.hpp
@@ -27,7 +26,6 @@ include/glm/detail/func_trigonometric.inl
include/glm/detail/func_vector_relational.hpp
include/glm/detail/func_vector_relational.inl
include/glm/detail/glm.cpp
-include/glm/detail/hint.hpp
include/glm/detail/intrinsic_common.hpp
include/glm/detail/intrinsic_common.inl
include/glm/detail/intrinsic_exponential.hpp
@@ -43,7 +41,6 @@ include/glm/detail/intrinsic_trigonometric.inl
include/glm/detail/intrinsic_vector_relational.hpp
include/glm/detail/intrinsic_vector_relational.inl
include/glm/detail/precision.hpp
-include/glm/detail/precision.inl
include/glm/detail/setup.hpp
include/glm/detail/type_float.hpp
include/glm/detail/type_gentype.hpp
@@ -81,15 +78,22 @@ include/glm/detail/type_vec3.hpp
include/glm/detail/type_vec3.inl
include/glm/detail/type_vec4.hpp
include/glm/detail/type_vec4.inl
+include/glm/detail/type_vec4_avx.inl
+include/glm/detail/type_vec4_avx2.inl
+include/glm/detail/type_vec4_sse2.inl
include/glm/exponential.hpp
include/glm/ext.hpp
include/glm/fwd.hpp
include/glm/geometric.hpp
include/glm/glm.hpp
+include/glm/gtc/bitfield.hpp
+include/glm/gtc/bitfield.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
+include/glm/gtc/integer.hpp
+include/glm/gtc/integer.inl
include/glm/gtc/matrix_access.hpp
include/glm/gtc/matrix_access.inl
include/glm/gtc/matrix_integer.hpp
@@ -107,12 +111,16 @@ include/glm/gtc/random.hpp
include/glm/gtc/random.inl
include/glm/gtc/reciprocal.hpp
include/glm/gtc/reciprocal.inl
+include/glm/gtc/round.hpp
+include/glm/gtc/round.inl
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
include/glm/gtc/type_ptr.inl
include/glm/gtc/ulp.hpp
include/glm/gtc/ulp.inl
+include/glm/gtc/vec1.hpp
+include/glm/gtc/vec1.inl
include/glm/gtx/associated_min_max.hpp
include/glm/gtx/associated_min_max.inl
include/glm/gtx/bit.hpp
@@ -123,14 +131,14 @@ include/glm/gtx/color_space.hpp
include/glm/gtx/color_space.inl
include/glm/gtx/color_space_YCoCg.hpp
include/glm/gtx/color_space_YCoCg.inl
+include/glm/gtx/common.hpp
+include/glm/gtx/common.inl
include/glm/gtx/compatibility.hpp
include/glm/gtx/compatibility.inl
include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
-include/glm/gtx/constants.hpp
include/glm/gtx/dual_quaternion.hpp
include/glm/gtx/dual_quaternion.inl
-include/glm/gtx/epsilon.hpp
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
@@ -147,10 +155,6 @@ include/glm/gtx/gradient_paint.hpp
include/glm/gtx/gradient_paint.inl
include/glm/gtx/handed_coordinate_space.hpp
include/glm/gtx/handed_coordinate_space.inl
-include/glm/gtx/inertia.hpp
-include/glm/gtx/inertia.inl
-include/glm/gtx/int_10_10_10_2.hpp
-include/glm/gtx/int_10_10_10_2.inl
include/glm/gtx/integer.hpp
include/glm/gtx/integer.inl
include/glm/gtx/intersect.hpp
@@ -161,6 +165,8 @@ include/glm/gtx/log_base.hpp
include/glm/gtx/log_base.inl
include/glm/gtx/matrix_cross_product.hpp
include/glm/gtx/matrix_cross_product.inl
+include/glm/gtx/matrix_decompose.hpp
+include/glm/gtx/matrix_decompose.inl
include/glm/gtx/matrix_interpolation.hpp
include/glm/gtx/matrix_interpolation.inl
include/glm/gtx/matrix_major_storage.hpp
@@ -175,7 +181,6 @@ include/glm/gtx/mixed_product.hpp
include/glm/gtx/mixed_product.inl
include/glm/gtx/multiple.hpp
include/glm/gtx/multiple.inl
-include/glm/gtx/noise.hpp
include/glm/gtx/norm.hpp
include/glm/gtx/norm.inl
include/glm/gtx/normal.hpp
@@ -196,14 +201,14 @@ include/glm/gtx/projection.hpp
include/glm/gtx/projection.inl
include/glm/gtx/quaternion.hpp
include/glm/gtx/quaternion.inl
-include/glm/gtx/random.hpp
+include/glm/gtx/range.hpp
include/glm/gtx/raw_data.hpp
include/glm/gtx/raw_data.inl
-include/glm/gtx/reciprocal.hpp
include/glm/gtx/rotate_normalized_axis.hpp
include/glm/gtx/rotate_normalized_axis.inl
include/glm/gtx/rotate_vector.hpp
include/glm/gtx/rotate_vector.inl
+include/glm/gtx/scalar_multiplication.hpp
include/glm/gtx/scalar_relational.hpp
include/glm/gtx/scalar_relational.inl
include/glm/gtx/simd_mat4.hpp
@@ -222,11 +227,8 @@ include/glm/gtx/transform.hpp
include/glm/gtx/transform.inl
include/glm/gtx/transform2.hpp
include/glm/gtx/transform2.inl
-include/glm/gtx/ulp.hpp
-include/glm/gtx/unsigned_int.hpp
-include/glm/gtx/unsigned_int.inl
-include/glm/gtx/vec1.hpp
-include/glm/gtx/vec1.inl
+include/glm/gtx/type_aligned.hpp
+include/glm/gtx/type_aligned.inl
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp