aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-12-07 03:46:53 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2017-12-07 03:46:53 +0800
commit1aaf849b21b0ed6d2f0e67f301ee06abe2ba5894 (patch)
tree9b48e2bbe672d8f632d7522c19aa0879c1b6ef09 /math
parent0ee1c33d162139729744fc783f1ad5df5511f841 (diff)
downloadfreebsd-ports-gnome-1aaf849b21b0ed6d2f0e67f301ee06abe2ba5894.tar.gz
freebsd-ports-gnome-1aaf849b21b0ed6d2f0e67f301ee06abe2ba5894.tar.zst
freebsd-ports-gnome-1aaf849b21b0ed6d2f0e67f301ee06abe2ba5894.zip
math/py-matplotlib: Allow build for Python 3.x
- x11-toolkits/{py-gtk2,py-wxPython28} do not support Python 3.x, so exclude the GTKBACKEND, GTKAGGBACKEND, and WXAGGBACKEND in that case. PR: 213636 Reported by: lbartoletti@tuxfamily.org Submitted by: rsmith@xs4all.nl (based on) Reviewed by: mat Approved by: maintainer timeout Differential Revision: https://reviews.freebsd.org/D13377
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 83b113e31c3c..704b2ec23b2a 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${PYNUMPY} \
USE_GITHUB= yes
-USES= compiler:c++11-lib gettext pkgconfig python:2.7 shebangfix uniquefiles:dirs
+USES= compiler:c++11-lib gettext pkgconfig python shebangfix uniquefiles:dirs
USE_PYTHON= autoplist distutils
CFLAGS+= -I${LOCALBASE}/include
@@ -35,6 +35,11 @@ OPTIONS_DEFINE= EXAMPLES GTKBACKEND GTKAGGBACKEND QT4AGGBACKEND \
QT5AGGBACKEND TKAGGBACKEND WXAGGBACKEND
OPTIONS_DEFAULT= GTKBACKEND GTKAGGBACKEND TKAGGBACKEND
OPTIONS_SUB= yes
+.if ${FLAVOR:U:Mpy3*}
+# x11-toolkits/py-gtk2, x11-toolkits/py-wxPython28 do not support Python 3
+OPTIONS_EXCLUDE= GTKBACKEND GTKAGGBACKEND WXAGGBACKEND
+.endif
+
GTKBACKEND_DESC= GTK backend support
GTKBACKEND_VARS= GTK_BACKEND=True
GTKBACKEND_VARS_OFF= GTK_BACKEND=False