aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2015-09-29 14:08:41 +0800
committerWen Heping <wen@FreeBSD.org>2015-09-29 14:08:41 +0800
commit1d21361e61b8ce943ede50c999aee7a9518b7fe7 (patch)
tree16a9cd1409839e28d4af57ce9c129c174073d721 /math
parent55b3c12cb5024a4f799b8ccc4c702a7ff2c4b6e5 (diff)
downloadfreebsd-ports-gnome-1d21361e61b8ce943ede50c999aee7a9518b7fe7.tar.gz
freebsd-ports-gnome-1d21361e61b8ce943ede50c999aee7a9518b7fe7.tar.zst
freebsd-ports-gnome-1d21361e61b8ce943ede50c999aee7a9518b7fe7.zip
- Update to 2.1.1
- Add LICENSE - Reset maintainer to ports@
Diffstat (limited to 'math')
-rw-r--r--math/py-gsl/Makefile13
-rw-r--r--math/py-gsl/distinfo4
-rw-r--r--math/py-gsl/files/patch-src_init_initmodule.c8
-rw-r--r--math/py-gsl/files/patch-src_transform_wavelet.c10
4 files changed, 18 insertions, 17 deletions
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index f49ae56489ee..c3eb47b3c585 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -2,22 +2,23 @@
# $FreeBSD$
PORTNAME= gsl
-PORTVERSION= 0.9.5
-PORTREVISION= 7
+PORTVERSION= 2.1.1
CATEGORIES= math python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pygsl-${PORTVERSION}
DIST_SUBDIR= python
-MAINTAINER= wen@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Python interface to GNU Scientific Library
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/include/numpy/arrayobject.h:${PORTSDIR}/math/py-numpy
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/math/py-gsl/distinfo b/math/py-gsl/distinfo
index 223dca486cb5..82273d6d66fc 100644
--- a/math/py-gsl/distinfo
+++ b/math/py-gsl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/pygsl-0.9.5.tar.gz) = 05d11160ff482e1f1f5f6a047aaef2776eedc1e8e1f98533a95299584fd4752d
-SIZE (python/pygsl-0.9.5.tar.gz) = 1674504
+SHA256 (python/pygsl-2.1.1.tar.gz) = 3d17e6deb5433b331a567a45ff467f41e9059def76e6ef0f21d8e891498f946a
+SIZE (python/pygsl-2.1.1.tar.gz) = 727636
diff --git a/math/py-gsl/files/patch-src_init_initmodule.c b/math/py-gsl/files/patch-src_init_initmodule.c
index d98ca6ec9054..771ed15d3e3c 100644
--- a/math/py-gsl/files/patch-src_init_initmodule.c
+++ b/math/py-gsl/files/patch-src_init_initmodule.c
@@ -1,6 +1,6 @@
---- src/init/initmodule.c.orig
+--- src/init/initmodule.c.orig 2015-09-27 12:30:47 UTC
+++ src/init/initmodule.c
-@@ -83,7 +83,7 @@
+@@ -111,7 +111,7 @@ PyGSL_set_debug_level(PyObject *self, Py
FUNC_MESS_BEGIN();
#if DEBUG == 1
@@ -9,11 +9,11 @@
int tmp, i, max, *ptr;
if(!PyArg_ParseTuple(args, "i", &tmp))
return NULL;
-@@ -108,6 +108,7 @@
+@@ -136,6 +136,7 @@ PyGSL_set_debug_level(PyObject *self, Py
Py_INCREF(Py_None);
FUNC_MESS_END();
return Py_None;
+ }
#else
- GSL_ERROR_NULL("PyGSL was not compiled with DEBUG = 1; Can not set DEBUG level!", GSL_EUNIMPL);
+ PyGSL_ERROR_NULL("PyGSL was not compiled with DEBUG = 1; Can not set DEBUG level!", GSL_EUNIMPL);
#endif
diff --git a/math/py-gsl/files/patch-src_transform_wavelet.c b/math/py-gsl/files/patch-src_transform_wavelet.c
index 51ad4d5a463e..72373da79a50 100644
--- a/math/py-gsl/files/patch-src_transform_wavelet.c
+++ b/math/py-gsl/files/patch-src_transform_wavelet.c
@@ -1,6 +1,6 @@
---- src/transform/wavelet.c.orig
+--- src/transform/wavelet.c.orig 2015-09-13 16:16:51 UTC
+++ src/transform/wavelet.c
-@@ -70,6 +70,7 @@
+@@ -147,6 +147,7 @@ PyGSL_wavelet_ ## direction(PyGSL_wavele
{ \
PyObject *tmp; \
FUNC_MESS_BEGIN(); \
@@ -8,7 +8,7 @@
pygsl_transform_help_s helps;\
struct _pygsl_transform_help_rf_s s; \
helps.info = &wavelet_info; \
-@@ -79,6 +80,7 @@
+@@ -156,6 +157,7 @@ PyGSL_wavelet_ ## direction(PyGSL_wavele
tmp = PyGSL_transform_((PyObject *) self, args, &helps); \
FUNC_MESS_END(); \
return tmp; \
@@ -16,7 +16,7 @@
}
PYGSL_WAVLET(forward)
PYGSL_WAVLET(inverse)
-@@ -89,6 +91,7 @@
+@@ -166,6 +168,7 @@ PyGSL_wavelet2d_ ## type ## direction(Py
{ \
PyObject *tmp; \
FUNC_MESS_BEGIN(); \
@@ -24,7 +24,7 @@
pygsl_transform_help_s helps;\
struct _pygsl_transform_help_rf_s s; \
helps.info = &wavelet_info; \
-@@ -98,6 +101,7 @@
+@@ -175,6 +178,7 @@ PyGSL_wavelet2d_ ## type ## direction(Py
tmp = PyGSL_transform_2d_((PyObject *) self, args, &helps); \
FUNC_MESS_END(); \
return tmp; \