aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2008-06-19 10:08:21 +0800
committermaho <maho@FreeBSD.org>2008-06-19 10:08:21 +0800
commit1ffbd514d5f7145c0f8810340557575988c7333e (patch)
tree4605efa487858690eb29b1a2ec6fb48ef6b9c818 /math
parent45a91cd48966eca0a2bc1d40108eeb18f4014cea (diff)
downloadfreebsd-ports-gnome-1ffbd514d5f7145c0f8810340557575988c7333e.tar.gz
freebsd-ports-gnome-1ffbd514d5f7145c0f8810340557575988c7333e.tar.zst
freebsd-ports-gnome-1ffbd514d5f7145c0f8810340557575988c7333e.zip
* remove ENABLE_TESTING which does nothing.
* Use the canonical regression-test target: this is run by pointyhat so we can ensure in the log that the library is in good shape. Submitted by: Pedro Giffuni
Diffstat (limited to 'math')
-rw-r--r--math/lapack/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 858f65cf4e2c..2695800453cb 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lapack
PORTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/lapack/
DISTFILES= lapack-${PORTVERSION}.tgz manpages-${PORTVERSION}.tgz
@@ -44,9 +45,6 @@ BLAS= -L${LOCALBASE}/lib -lblas
pre-fetch:
@${ECHO} "You can override FC and FFLAGS on the command line."
-.if !defined(ENABLE_TESTING) || ${ENABLE_TESTING} != "YES"
- @${ECHO} "Set ENABLE_TESTING to YES to enable testing and timing."
-.endif
.include "${FILESDIR}/manpages"
@@ -102,4 +100,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/manpages/man/manl/[m-s]*.l ${PREFIX}/man/manl
${INSTALL_MAN} ${WRKSRC}/manpages/man/manl/[t-z]*.l ${PREFIX}/man/manl
+regression-test: build
+ @${ECHO_CMD} "Testing static lapack library"
+ cd ${WRKSRC}/TESTING ; ${MAKE} ${.MAKEFLAGS} ARCH=ar
+
.include <bsd.port.post.mk>