aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-21 23:41:06 +0800
committermakc <makc@FreeBSD.org>2013-11-21 23:41:06 +0800
commit2135616a9e070ebc11896c5da3bab6be138d3174 (patch)
treea5a600fc2e9cd562658dc40ed2f379bc9c1a8346 /math
parentbd44bcfeda247454fd0b28cda212f082fc5d93b2 (diff)
downloadfreebsd-ports-gnome-2135616a9e070ebc11896c5da3bab6be138d3174.tar.gz
freebsd-ports-gnome-2135616a9e070ebc11896c5da3bab6be138d3174.tar.zst
freebsd-ports-gnome-2135616a9e070ebc11896c5da3bab6be138d3174.zip
- Remove now needless qmake_build from USE_QT4
- Get rid of QMAKEFLAGS - Convert to USES=dos2unix
Diffstat (limited to 'math')
-rw-r--r--math/qtiplot/Makefile8
-rw-r--r--math/qwtplot3d-qt4/Makefile5
2 files changed, 6 insertions, 7 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 27a3928f9cda..f1b6b92a8bf7 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -17,13 +17,13 @@ LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl \
# qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
# qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4
-USES= gmake qmake
+USES= dos2unix gmake qmake
USE_BZIP2= yes
USE_QT4= gui opengl svg qt3support network assistantclient \
- moc_build qmake_build rcc_build
+ moc_build rcc_build
USE_GL= glu
QMAKE_ARGS+= LOCALBASE=${LOCALBASE} PYTHON_CMD=${PYTHON_CMD}
-USE_DOS2UNIX= *.pro
+DOS2UNIX_GLOB= *.pro
DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
"${DATADIR}/qtiplot.png" \
@@ -96,7 +96,7 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC}/qtiplot && ${LOCALBASE}/bin/lrelease-qt4 -compress qtiplot.pro
+ cd ${WRKSRC}/qtiplot && ${LRELEASE} -compress qtiplot.pro
.endif
post-install:
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index c38e1b422f48..a26df193176d 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -11,11 +11,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= makc@FreeBSD.org
COMMENT= 3D plotting widgets for scientific data and math expressions
-USES= qmake
-USE_QT4= gui moc_build qmake_build opengl
+USES= dos2unix qmake
+USE_QT4= gui moc_build opengl
USE_GL= glu
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}