aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-01 23:01:28 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-01 23:01:28 +0800
commit266d1cee01a02349f9e2cf203e5feab25f23123f (patch)
tree09a4cf27c8a75f1c029544d55826df066e848d39 /math
parent54507d26ab1a38a6781ba87421fd79a029de990b (diff)
downloadfreebsd-ports-gnome-266d1cee01a02349f9e2cf203e5feab25f23123f.tar.gz
freebsd-ports-gnome-266d1cee01a02349f9e2cf203e5feab25f23123f.tar.zst
freebsd-ports-gnome-266d1cee01a02349f9e2cf203e5feab25f23123f.zip
math/openblas: fix build on powerpc64le
Use GCC to build, like on powerpc64. Since LE supports DYNAMIC_ARCH, add it. Correct check for 64-bit architectures. Approved by: tier 2 blanket
Diffstat (limited to 'math')
-rw-r--r--math/openblas/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 3bb2735f5aa5..b2e8e423919d 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -49,6 +49,7 @@ OPTIONS_SUB= yes
.if defined(BATCH) || defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT_i386= DYNAMIC_ARCH
OPTIONS_DEFAULT_amd64= DYNAMIC_ARCH
+OPTIONS_DEFAULT_powerpc64le= DYNAMIC_ARCH
.endif
DYNAMIC_ARCH_DESC= Support multiple CPU types on i386 and amd64
@@ -77,9 +78,13 @@ USE_GCC= yes
TARGET_CPU_ARCH= PPCG4
.endif
+.if ${ARCH} == powerpc64le
+USE_GCC= yes
+.endif
+
MAXTHREADS?= 64
-.if ! ${PORT_OPTIONS:MDYNAMIC_ARCH} && ( ${ARCH} == "amd64" || ${ARCH} == "i386" )
+.if ! ${PORT_OPTIONS:MDYNAMIC_ARCH} && ( ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "powerpc64le")
MANUAL_PACKAGE_BUILD= Optimizes for the build machine.
.endif
@@ -124,7 +129,7 @@ post-patch:
.if ${PORT_OPTIONS:MOPENMP}
@${ECHO} USE_OPENMP=1 >> ${WRKSRC}/Makefile.rule
.endif
-.if ${ARCH:M*64} == ""
+.if ${ARCH:M*64*} == ""
@${ECHO} BINARY=32 >> ${WRKSRC}/Makefile.rule
.else
@${ECHO} BINARY=64 >> ${WRKSRC}/Makefile.rule