aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-05-27 15:24:05 +0800
committeryuri <yuri@FreeBSD.org>2019-05-27 15:24:05 +0800
commit294991fe0bde3c141be254418c209522dfb22551 (patch)
treebcee29b9c3023698112b17fe612cff516df6c518 /math
parente795602564552560cf639a512522fe2c1116bc17 (diff)
downloadfreebsd-ports-gnome-294991fe0bde3c141be254418c209522dfb22551.tar.gz
freebsd-ports-gnome-294991fe0bde3c141be254418c209522dfb22551.tar.zst
freebsd-ports-gnome-294991fe0bde3c141be254418c209522dfb22551.zip
New port: math/exprtk: C++ mathematical expression library
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/exprtk/Makefile24
-rw-r--r--math/exprtk/distinfo3
-rw-r--r--math/exprtk/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 55b96a715aaf..914e14589ba9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -210,6 +210,7 @@
SUBDIR += ess
SUBDIR += eukleides
SUBDIR += eval
+ SUBDIR += exprtk
SUBDIR += facile
SUBDIR += fann
SUBDIR += fcl
diff --git a/math/exprtk/Makefile b/math/exprtk/Makefile
new file mode 100644
index 000000000000..bebe190d54e5
--- /dev/null
+++ b/math/exprtk/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= exprtk
+DISTVERSION= g20190519
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ mathematical expression library
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArashPartow
+GH_TAGNAME= 12fc5df
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/exprtk.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/exprtk.hpp ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/exprtk/distinfo b/math/exprtk/distinfo
new file mode 100644
index 000000000000..faa871f555cf
--- /dev/null
+++ b/math/exprtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558941442
+SHA256 (ArashPartow-exprtk-g20190519-12fc5df_GH0.tar.gz) = 14a147441142c5ef237afbc01aab0346ca70bf76c58509a9ecf75685c15aefb0
+SIZE (ArashPartow-exprtk-g20190519-12fc5df_GH0.tar.gz) = 1313333
diff --git a/math/exprtk/pkg-descr b/math/exprtk/pkg-descr
new file mode 100644
index 000000000000..83b86bbd9bb9
--- /dev/null
+++ b/math/exprtk/pkg-descr
@@ -0,0 +1,6 @@
+The C++ Mathematical Expression Toolkit Library (ExprTk) is a simple to use,
+easy to integrate and extremely efficient run-time mathematical expression
+parser and evaluation engine. ExprTk supports numerous forms of functional,
+logical and vector processing semantics and is very easily extendible.
+
+WWW: http://www.partow.net/programming/exprtk/index.html