aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-24 07:36:10 +0800
committerwen <wen@FreeBSD.org>2010-03-24 07:36:10 +0800
commit2ba57b4dddce6f645bb0f8f913d656d8e736bb0a (patch)
tree7a7d4a6f7f931b3c35cb7fc6e84ba5bfbf46fb34 /math
parent63c20381eabbff8ff8db24ea0979815102c0ae6b (diff)
downloadfreebsd-ports-gnome-2ba57b4dddce6f645bb0f8f913d656d8e736bb0a.tar.gz
freebsd-ports-gnome-2ba57b4dddce6f645bb0f8f913d656d8e736bb0a.tar.zst
freebsd-ports-gnome-2ba57b4dddce6f645bb0f8f913d656d8e736bb0a.zip
- Remove HDF5 option
- Update comment - Update pkg-descr PR: ports/144445 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile24
-rw-r--r--math/scilab/pkg-descr52
-rw-r--r--math/scilab/pkg-plist20
3 files changed, 52 insertions, 44 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index a7b316653489..6b732d26761f 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,12 +7,13 @@
PORTNAME= scilab
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= math cad parallel java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
EXTRACT_SUFX= -src.tar.gz
MAINTAINER= rfarmer@predatorlabs.net
-COMMENT= A free Matlab clone by INRIA & ENPC
+COMMENT= Scientific software package for numerical computations
# A partial dependencies list can be found at:
# http://wiki.scilab.org/Dependencies_of_Scilab_5.X
@@ -25,6 +26,7 @@ MAKE_JOBS_UNSAFE= yes
USE_FORTRAN= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-ocaml
@@ -34,7 +36,6 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib ${PTHREAD_LIBS}
OPTIONS= ATLAS "Use Atlas instead of Blas" OFF \
FFTW "Use FFTW" ON \
GUI "Build GUI (requires Java and required for docs)" ON \
- HDF5 "Use HDF5 (requires GUI)" OFF \
NLS "Build localization" OFF \
MATIO "Matlab compatibility" OFF \
PVM "Parallel Virtual Machine support" OFF \
@@ -76,11 +77,14 @@ PLIST_SUB+= TK=""
.if defined(WITHOUT_GUI)
CONFIGURE_ARGS+= --without-gui \
--without-javasci \
+ --without-hdf5 \
--disable-build-help
PLIST_SUB+= GUI="@comment "
PLIST_SUB+= NOGUI=""
NOPORTDOCS= YES
.else
+LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
+
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant \
${JAVALIBDIR}/flexdock-0.5.1.jar:${PORTSDIR}/devel/flexdock \
${JAVALIBDIR}/jogl.jar:${PORTSDIR}/graphics/jogl \
@@ -101,7 +105,8 @@ BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant \
${LOCALBASE}/share/xsl/docbook/javahelp/javahelp.xsl:${PORTSDIR}/textproc/docbook-xsl \
xsltproc:${PORTSDIR}/textproc/libxslt \
swig:${PORTSDIR}/devel/swig13 \
- ${LOCALBASE}/share/examples/saxon/data/books.dtd:${PORTSDIR}/textproc/saxon
+ ${LOCALBASE}/share/examples/saxon/data/books.dtd:${PORTSDIR}/textproc/saxon \
+ ${JAVALIBDIR}/jhdf5.jar:${PORTSDIR}/science/hdf-java
RUN_DEPENDS+= ${JAVALIBDIR}/flexdock-0.5.1.jar:${PORTSDIR}/devel/flexdock \
${JAVALIBDIR}/jogl.jar:${PORTSDIR}/graphics/jogl \
@@ -120,7 +125,8 @@ RUN_DEPENDS+= ${JAVALIBDIR}/flexdock-0.5.1.jar:${PORTSDIR}/devel/flexdock \
${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons \
${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
${LOCALBASE}/share/xsl/docbook/javahelp/javahelp.xsl:${PORTSDIR}/textproc/docbook-xsl \
- xsltproc:${PORTSDIR}/textproc/libxslt
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${JAVALIBDIR}/jhdf5.jar:${PORTSDIR}/science/hdf-java
USE_JAVA= yes
JAVA_VERSION= 1.5+
@@ -181,16 +187,6 @@ LIB_DEPENDS+= matio.1:${PORTSDIR}/math/matio
PLIST_SUB+= MATIO=""
.endif
-.if defined(WITHOUT_HDF5)
-CONFIGURE_ARGS+= --without-hdf5
-PLIST_SUB+= HDF5="@comment "
-.else
-LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
-BUILD_DEPENDS+= ${JAVALIBDIR}/jhdf5.jar:${PORTSDIR}/science/hdf-java
-RUN_DEPENDS+= ${JAVALIBDIR}/jhdf5.jar:${PORTSDIR}/science/hdf-java
-PLIST_SUB+= HDF5=""
-.endif
-
post-patch:
# Configure fixes
${REINPLACE_CMD} -e 's|/usr/share/java|${JAVALIBDIR}|g' ${WRKSRC}/configure
diff --git a/math/scilab/pkg-descr b/math/scilab/pkg-descr
index 4a2a27197c5e..a0c2df0b94e1 100644
--- a/math/scilab/pkg-descr
+++ b/math/scilab/pkg-descr
@@ -1,24 +1,36 @@
Scilab is a scientific software package for numerical computations in a
-user-friendly environment. It features:
+user-friendly environment.
- Elaborate data structures.
- Sophisticated interpreter and programming language with Matlab-like syntax.
- Hundreds of built-in math functions.
- Stunning graphics.
- Open structure.
- Many built-in libraries:
- Linear Algebra.
- Control.
- Package for linear matrix inequalities, optimization.
- Signal processing.
- Simulation.
- Optimization.
- Metanet.
- Symbolic capabilities through Maple interface.
+Main features
+ * Hundreds of mathematical functions
+ * High level programming language
+ * 2-D and 3-D graphics
+ * Advanced data structures and user defined data types
+ * Xcos: hybrid dynamic systems modeler and simulator
+2-D and 3-D visualization
+ * Lines
+ * Pie charts
+ * Histograms
+ * Surfaces
+ * Animations
+ * Graphics export in many formats: GIF, BMP, JPEG, SVG, PDF...
+Numerical computation
+ * Linear algebra
+ * Sparse matrices
+ * Polynomials and rational functions
+ * Simulation: explicit and implicit systems of differential
+ equations solvers
+ * Classic and robust control
+ * Differentiable and non-differentiable optimization
+Data analysis
+ * Interpolation, approximation
+ * Signal Processing
+ * Statistics
+Extended features
+ * Graphs and Networks
+ * Interface with Fortran, C, C++, Java
+ * Functions for calling Scilab from C, C++, Fortran and Java
+ * LabVIEW Gateway
+ * A large number of modules available via ATOMS
WWW: http://www.scilab.org
-
-Note: To configure your local printers, add their names to the PRINTERS
- variable in the scilab script.
-
-Scilab (c)INRIA-ENPC
diff --git a/math/scilab/pkg-plist b/math/scilab/pkg-plist
index 33b5553c6ce8..41d07d3b81ad 100644
--- a/math/scilab/pkg-plist
+++ b/math/scilab/pkg-plist
@@ -313,12 +313,12 @@ lib/scilab/libscixpad-disable.so.5
%%GUI%%lib/scilab/libscixpad.la
%%GUI%%lib/scilab/libscixpad.so
%%GUI%%lib/scilab/libscixpad.so.5
-%%HDF5%%lib/scilab/libscihdf5-forceload-disable.so
-%%HDF5%%lib/scilab/libscihdf5-forceload.la
-%%HDF5%%lib/scilab/libscihdf5-forceload-disable.so.5
-%%HDF5%%lib/scilab/libscihdf5-forceload-disable.la
-%%HDF5%%lib/scilab/libscihdf5-forceload.so
-%%HDF5%%lib/scilab/libscihdf5-forceload.so.5
+%%GUI%%lib/scilab/libscihdf5-forceload-disable.so
+%%GUI%%lib/scilab/libscihdf5-forceload.la
+%%GUI%%lib/scilab/libscihdf5-forceload-disable.so.5
+%%GUI%%lib/scilab/libscihdf5-forceload-disable.la
+%%GUI%%lib/scilab/libscihdf5-forceload.so
+%%GUI%%lib/scilab/libscihdf5-forceload.so.5
libdata/pkgconfig/scilab.pc
%%NLS%%share/locale/ca_ES/LC_MESSAGES/scilab.mo
%%NLS%%share/locale/de_DE/LC_MESSAGES/scilab.mo
@@ -5014,7 +5014,7 @@ libdata/pkgconfig/scilab.pc
%%DATADIR%%/modules/hdf5/etc/hdf5.start
%%DATADIR%%/modules/hdf5/license.txt
%%DATADIR%%/modules/hdf5/macros/buildmacros.sce
-%%HDF5%%%%DATADIR%%/modules/hdf5/jar/org.scilab.modules.hdf5.jar
+%%GUI%%%%DATADIR%%/modules/hdf5/jar/org.scilab.modules.hdf5.jar
%%DATADIR%%/modules/hdf5/readme.txt
%%DATADIR%%/modules/hdf5/sci_gateway/hdf5_gateway.xml
%%DATADIR%%/modules/hdf5/tests/unit_tests/testScilabBoolean.java
@@ -13509,7 +13509,7 @@ libdata/pkgconfig/scilab.pc
%%DATADIR%%/modules/xcos/images/palettes/freq_div.jpg
%%DATADIR%%/modules/xcos/images/palettes/generic_block3.jpg
%%DATADIR%%/modules/xcos/images/palettes/scifunc_block_m.jpg
-%%HDF5%%%%DATADIR%%/modules/xcos/jar/org.scilab.modules.xcos.jar
+%%GUI%%%%DATADIR%%/modules/xcos/jar/org.scilab.modules.xcos.jar
%%DATADIR%%/modules/xcos/license.txt
%%GUI%%%%DATADIR%%/modules/xcos/macros/%diagram_xcos.bin
%%DATADIR%%/modules/xcos/macros/%diagram_xcos.sci
@@ -13969,7 +13969,7 @@ libdata/pkgconfig/scilab.pc
@dirrm %%DATADIR%%/modules/xcos/tests
@dirrm %%DATADIR%%/modules/xcos/sci_gateway
@dirrm %%DATADIR%%/modules/xcos/macros
-%%HDF5%%@dirrm %%DATADIR%%/modules/xcos/jar
+%%GUI%%@dirrm %%DATADIR%%/modules/xcos/jar
@dirrm %%DATADIR%%/modules/xcos/images/palettes
@dirrm %%DATADIR%%/modules/xcos/images/icons
@dirrm %%DATADIR%%/modules/xcos/images/blocks
@@ -14519,7 +14519,7 @@ libdata/pkgconfig/scilab.pc
@dirrm %%DATADIR%%/modules/hdf5/sci_gateway
@dirrm %%DATADIR%%/modules/hdf5/macros
@dirrm %%DATADIR%%/modules/hdf5/etc
-%%HDF5%%@dirrm %%DATADIR%%/modules/hdf5/jar
+%%GUI%%@dirrm %%DATADIR%%/modules/hdf5/jar
@dirrm %%DATADIR%%/modules/hdf5
@dirrm %%DATADIR%%/modules/hashtable/macros
@dirrm %%DATADIR%%/modules/hashtable