aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-06-30 03:14:32 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-06-30 03:14:32 +0800
commit2d5c4ad8067b924164c3206cdce8b54a8c093663 (patch)
tree05a0c576c05d1655bfd18bc9c7635ce022551876 /math
parent2f1325aa1094d490bd9a23ff3f313464873d6a61 (diff)
downloadfreebsd-ports-gnome-2d5c4ad8067b924164c3206cdce8b54a8c093663.tar.gz
freebsd-ports-gnome-2d5c4ad8067b924164c3206cdce8b54a8c093663.tar.zst
freebsd-ports-gnome-2d5c4ad8067b924164c3206cdce8b54a8c093663.zip
- Switch to new test framework
- Switch to options helpers - Silence patching
Diffstat (limited to 'math')
-rw-r--r--math/ent/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/math/ent/Makefile b/math/ent/Makefile
index aeb3c2d2bc8e..47e964179233 100644
--- a/math/ent/Makefile
+++ b/math/ent/Makefile
@@ -16,25 +16,24 @@ USES= compiler zip
NO_WRKSUBDIR= yes
ALL_TARGET= ent
PLIST_FILES= bin/ent
+TEST_TARGET= check
PORTDOCS= ent.html entitle.gif
-OPTIONS_DEFINE= DOCS
-regression-test: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
post-patch:
- ${REINPLACE_CMD} -e 's|gcc|${CC}|; s|^CFLAGS |&+|' ${WRKSRC}/Makefile
-
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|^CFLAGS |&+|' ${WRKSRC}/Makefile
.if ${COMPILER_TYPE} == clang
- ${REINPLACE_CMD} -e 's|-g ||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-g ||' ${WRKSRC}/Makefile
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}