aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-09-02 13:52:42 +0800
committeryuri <yuri@FreeBSD.org>2019-09-02 13:52:42 +0800
commit2ddaa2bb3505f6fc28afd7fd4d4ffa0dce88428d (patch)
treeb08c9f8f4dee5c03b79530e3783bd9ebf2c6a3df /math
parentf7617f5e0706da4912117614efde2add67ebcf55 (diff)
downloadfreebsd-ports-gnome-2ddaa2bb3505f6fc28afd7fd4d4ffa0dce88428d.tar.gz
freebsd-ports-gnome-2ddaa2bb3505f6fc28afd7fd4d4ffa0dce88428d.tar.zst
freebsd-ports-gnome-2ddaa2bb3505f6fc28afd7fd4d4ffa0dce88428d.zip
math/g2o: Update 20170730_git-87-gbbe3c2b -> 20170730_git-239-ge7b5b7a
Reported by: adridg (reported plist issues in the old version)
Diffstat (limited to 'math')
-rw-r--r--math/g2o/Makefile11
-rw-r--r--math/g2o/distinfo6
-rw-r--r--math/g2o/pkg-plist46
3 files changed, 43 insertions, 20 deletions
diff --git a/math/g2o/Makefile b/math/g2o/Makefile
index 65e6f5293420..99ad390a1140 100644
--- a/math/g2o/Makefile
+++ b/math/g2o/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= g2o
-DISTVERSION= 20170730_git-87
-DISTVERSIONSUFFIX= -gbbe3c2b
-PORTREVISION= 5
+DISTVERSION= 20170730_git-239
+DISTVERSIONSUFFIX= -ge7b5b7a
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -13,9 +12,11 @@ LICENSE= LGPL3 GPLv3
LICENSE_COMB= dual
LIB_DEPENDS= libcxsparse.so:math/suitesparse \
- libQGLViewer-qt5.so:graphics/libQGLViewer
+ libQGLViewer-qt5.so:graphics/libQGLViewer \
+ libmetis.so:math/metis \
+ libopenblas.so:math/openblas
-USES= cmake compiler:c++11-lang gl eigen:3 qt:5
+USES= cmake compiler:c++11-lang gl eigen:3 blaslapack:netlib qt:5
USE_GITHUB= yes
GH_ACCOUNT= RainerKuemmerle
USE_GL= gl glu
diff --git a/math/g2o/distinfo b/math/g2o/distinfo
index c94ab397d653..216d0edb94dc 100644
--- a/math/g2o/distinfo
+++ b/math/g2o/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522223932
-SHA256 (RainerKuemmerle-g2o-20170730_git-87-gbbe3c2b_GH0.tar.gz) = 35ff08910d775f5b9a9ee046b5372953ae9e9d4d12b96e0bf499be128f4aad79
-SIZE (RainerKuemmerle-g2o-20170730_git-87-gbbe3c2b_GH0.tar.gz) = 1576650
+TIMESTAMP = 1567401757
+SHA256 (RainerKuemmerle-g2o-20170730_git-239-ge7b5b7a_GH0.tar.gz) = ae558f3be63697d7d4b278595a420af0bdfdbdba0726753d797480a1769996fa
+SIZE (RainerKuemmerle-g2o-20170730_git-239-ge7b5b7a_GH0.tar.gz) = 1585121
diff --git a/math/g2o/pkg-plist b/math/g2o/pkg-plist
index a751bdd368e9..ae8a0ef089d4 100644
--- a/math/g2o/pkg-plist
+++ b/math/g2o/pkg-plist
@@ -1,5 +1,7 @@
bin/g2o
bin/g2o_anonymize_observations
+bin/g2o_incremental
+bin/g2o_online
bin/g2o_simulator2d
bin/g2o_simulator3d
bin/g2o_viewer
@@ -99,7 +101,30 @@ include/g2o/core/sparse_block_matrix_ccs.h
include/g2o/core/sparse_block_matrix_diagonal.h
include/g2o/core/sparse_optimizer.h
include/g2o/core/sparse_optimizer_terminate_action.h
+include/g2o/examples/interactive_slam/g2o_incremental/g2o_incremental_api.h
+include/g2o/examples/interactive_slam/g2o_incremental/graph_optimizer_sparse_incremental.h
+include/g2o/examples/interactive_slam/g2o_incremental/linear_solver_cholmod_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/fast_output.h
+include/g2o/examples/interactive_slam/g2o_interactive/g2o_interactive_api.h
+include/g2o/examples/interactive_slam/g2o_interactive/g2o_slam_interface.h
+include/g2o/examples/interactive_slam/g2o_interactive/graph_optimizer_sparse_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/types_slam2d_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/types_slam3d_online.h
+include/g2o/examples/interactive_slam/slam_parser/interface/abstract_slam_interface.h
+include/g2o/examples/interactive_slam/slam_parser/interface/parser_interface.h
+include/g2o/examples/interactive_slam/slam_parser/interface/slam_context_interface.h
+include/g2o/examples/interactive_slam/slam_parser/parser/FlexLexer.h
+include/g2o/examples/interactive_slam/slam_parser/parser/bison_parser.h
+include/g2o/examples/interactive_slam/slam_parser/parser/commands.h
+include/g2o/examples/interactive_slam/slam_parser/parser/driver.h
+include/g2o/examples/interactive_slam/slam_parser/parser/location.hh
+include/g2o/examples/interactive_slam/slam_parser/parser/position.hh
+include/g2o/examples/interactive_slam/slam_parser/parser/scanner.h
+include/g2o/examples/interactive_slam/slam_parser/parser/slam_context.h
+include/g2o/examples/interactive_slam/slam_parser/parser/stack.hh
include/g2o/freeglut/freeglut_minimal.h
+include/g2o/solvers/cholmod/linear_solver_cholmod.h
+include/g2o/solvers/csparse/csparse_extension.h
include/g2o/solvers/csparse/csparse_helper.h
include/g2o/solvers/csparse/g2o_csparse_api.h
include/g2o/solvers/csparse/g2o_csparse_extension_api.h
@@ -189,6 +214,7 @@ include/g2o/types/slam3d/edge_se3_pointxyz.h
include/g2o/types/slam3d/edge_se3_pointxyz_depth.h
include/g2o/types/slam3d/edge_se3_pointxyz_disparity.h
include/g2o/types/slam3d/edge_se3_prior.h
+include/g2o/types/slam3d/edge_se3_xyzprior.h
include/g2o/types/slam3d/edge_xyz_prior.h
include/g2o/types/slam3d/g2o_types_slam3d_api.h
include/g2o/types/slam3d/isometry3d_gradients.h
@@ -214,26 +240,22 @@ include/g2o/types/slam3d_addons/types_slam3d_addons.h
include/g2o/types/slam3d_addons/vertex_line3d.h
include/g2o/types/slam3d_addons/vertex_plane.h
include/g2o/types/slam3d_addons/vertex_se3_euler.h
-include/slam_parser/interface/abstract_slam_interface.h
-include/slam_parser/interface/parser_interface.h
-include/slam_parser/interface/slam_context_interface.h
-include/slam_parser/parser/FlexLexer.h
-include/slam_parser/parser/bison_parser.h
-include/slam_parser/parser/commands.h
-include/slam_parser/parser/driver.h
-include/slam_parser/parser/location.hh
-include/slam_parser/parser/position.hh
-include/slam_parser/parser/scanner.h
-include/slam_parser/parser/slam_context.h
-include/slam_parser/parser/stack.hh
+lib/cmake/g2o/g2oConfig.cmake
+lib/cmake/g2o/g2oConfigVersion.cmake
+lib/cmake/g2o/g2oTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/g2o/g2oTargets.cmake
lib/libg2o_cli.so
lib/libg2o_core.so
lib/libg2o_csparse_extension.so
lib/libg2o_ext_freeglut_minimal.so
+lib/libg2o_hierarchical.so
+lib/libg2o_incremental.so
+lib/libg2o_interactive.so
lib/libg2o_interface.so
lib/libg2o_opengl_helper.so
lib/libg2o_parser.so
lib/libg2o_simulator.so
+lib/libg2o_solver_cholmod.so
lib/libg2o_solver_csparse.so
lib/libg2o_solver_dense.so
lib/libg2o_solver_eigen.so