aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-13 21:42:36 +0800
committerThierry Thomas <thierry@FreeBSD.org>2020-04-13 21:42:36 +0800
commit307dc7a1324949e8101eeaeb2e22b3b3743cdaa0 (patch)
treedf4d587fe6f7e2639c62358e29abae827962567f /math
parent1f9a25a7661a6f5de7b523e3d3211b05cda0bab7 (diff)
downloadfreebsd-ports-gnome-307dc7a1324949e8101eeaeb2e22b3b3743cdaa0.tar.gz
freebsd-ports-gnome-307dc7a1324949e8101eeaeb2e22b3b3743cdaa0.tar.zst
freebsd-ports-gnome-307dc7a1324949e8101eeaeb2e22b3b3743cdaa0.zip
Force local headers.
Diffstat (limited to 'math')
-rw-r--r--math/lrcalc/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/math/lrcalc/Makefile b/math/lrcalc/Makefile
index 4ac593a86334..30d1e00ecbb3 100644
--- a/math/lrcalc/Makefile
+++ b/math/lrcalc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lrcalc
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= https://sites.math.rutgers.edu/~asbuch/lrcalc/
@@ -16,6 +17,14 @@ USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+INCL2FIX= lrcalc.c maple.c schublib.h symfcn.c symfcn.h
+
TEST_TARGET= check
+pre-configure:
+.for i in ${INCL2FIX}
+ ${REINPLACE_CMD} -e 's|<vectarg.h>|"vectarg.h"|;s|<vector.h>|"vector.h"|' \
+ -e 's|<hashtab.h>|"hashtab.h"|;s|<alloc.h>|"alloc.h"|' ${WRKSRC}/src/${i}
+.endfor
+
.include <bsd.port.mk>