aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
commit31445311fce915521f6c1940134b8dc155688036 (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /math
parent3672f197c67f0c967088c7faaced7d9627772e4d (diff)
downloadfreebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.gz
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.zst
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.zip
- Convert to new perl framework
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-GMPf/Makefile3
-rw-r--r--math/p5-Math-GMPq/Makefile3
-rw-r--r--math/p5-Math-GMPz/Makefile3
-rw-r--r--math/p5-Math-Int64/Makefile3
-rw-r--r--math/p5-Math-Prime-XS/Makefile3
-rw-r--r--math/p5-Number-Uncertainty/Makefile3
6 files changed, 12 insertions, 6 deletions
diff --git a/math/p5-Math-GMPf/Makefile b/math/p5-Math-GMPf/Makefile
index c472f6ea7c29..ed768df9e0f4 100644
--- a/math/p5-Math-GMPf/Makefile
+++ b/math/p5-Math-GMPf/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Math::GMPf.3
diff --git a/math/p5-Math-GMPq/Makefile b/math/p5-Math-GMPq/Makefile
index 4aeebcfd96b3..776046c90da9 100644
--- a/math/p5-Math-GMPq/Makefile
+++ b/math/p5-Math-GMPq/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Math::GMPq.3
diff --git a/math/p5-Math-GMPz/Makefile b/math/p5-Math-GMPz/Makefile
index d8387741e423..c8d9bf49b374 100644
--- a/math/p5-Math-GMPz/Makefile
+++ b/math/p5-Math-GMPz/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Math::GMPz.3
diff --git a/math/p5-Math-Int64/Makefile b/math/p5-Math-Int64/Makefile
index 06281af95a94..b02186e51d95 100644
--- a/math/p5-Math-Int64/Makefile
+++ b/math/p5-Math-Int64/Makefile
@@ -13,7 +13,8 @@ COMMENT= Manipulate 64 bits integers in Perl
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Math::Int64.3 \
Math::Int64::die_on_overflow.3 \
diff --git a/math/p5-Math-Prime-XS/Makefile b/math/p5-Math-Prime-XS/Makefile
index acd4f5d647e9..29a53727f7f6 100644
--- a/math/p5-Math-Prime-XS/Makefile
+++ b/math/p5-Math-Prime-XS/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Math::Prime::XS.3
diff --git a/math/p5-Number-Uncertainty/Makefile b/math/p5-Number-Uncertainty/Makefile
index fc56a9009121..57741f7ed1c7 100644
--- a/math/p5-Number-Uncertainty/Makefile
+++ b/math/p5-Number-Uncertainty/Makefile
@@ -17,7 +17,8 @@ COMMENT= An object-orientated uncertainty object
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Number::Uncertainty.3