aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-08-15 04:39:30 +0800
committerstephen <stephen@FreeBSD.org>2012-08-15 04:39:30 +0800
commit32a41af33a4b0076d4948c1eb2c28136594ab854 (patch)
tree33530e289708c295b00aff9957a94f9957cb1bb6 /math
parent9150c21b6fd33d5d4c3f5f931f373a20b440f994 (diff)
downloadfreebsd-ports-gnome-32a41af33a4b0076d4948c1eb2c28136594ab854.tar.gz
freebsd-ports-gnome-32a41af33a4b0076d4948c1eb2c28136594ab854.tar.zst
freebsd-ports-gnome-32a41af33a4b0076d4948c1eb2c28136594ab854.zip
- New port, math/octave-forge-lssa.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is lssa. A package implementing tools to compute spectral decompositions of irregularly-spaced time series. Currently includes functions based off the Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C (see http://www.jstatsoft.org/v11/i02). WWW: http://octave.sourceforge.net/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-lssa/Makefile27
-rw-r--r--math/octave-forge-lssa/distinfo2
-rw-r--r--math/octave-forge-lssa/pkg-descr13
-rw-r--r--math/octave-forge-lssa/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index dd0294daea28..717e60888bb3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -298,6 +298,7 @@
SUBDIR += octave-forge-irsa
SUBDIR += octave-forge-java
SUBDIR += octave-forge-linear-algebra
+ SUBDIR += octave-forge-lssa
SUBDIR += octave-forge-mapping
SUBDIR += octave-forge-mechanics
SUBDIR += octave-forge-miscellaneous
diff --git a/math/octave-forge-lssa/Makefile b/math/octave-forge-lssa/Makefile
new file mode 100644
index 000000000000..37225622aa1c
--- /dev/null
+++ b/math/octave-forge-lssa/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: octave-forge-lssa
+# Date created: 14 August 2012
+# Whom: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-lssa
+PORTVERSION= 0.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-lssa/distinfo b/math/octave-forge-lssa/distinfo
new file mode 100644
index 000000000000..0416ddde1fea
--- /dev/null
+++ b/math/octave-forge-lssa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/lssa-0.1.1.tar.gz) = fb4c91b9284668af7f0e1e7e0592cc9aa3d19fccef8592ac235e196aaad9ec4e
+SIZE (octave-forge/lssa-0.1.1.tar.gz) = 24883
diff --git a/math/octave-forge-lssa/pkg-descr b/math/octave-forge-lssa/pkg-descr
new file mode 100644
index 000000000000..6a905bfb9f98
--- /dev/null
+++ b/math/octave-forge-lssa/pkg-descr
@@ -0,0 +1,13 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is lssa.
+
+ A package implementing tools to compute spectral decompositions of
+ irregularly-spaced time series. Currently includes functions based off the
+ Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C (see
+ http://www.jstatsoft.org/v11/i02).
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-lssa/pkg-plist b/math/octave-forge-lssa/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-lssa/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty