aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-10-20 04:20:43 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-10-20 04:20:43 +0800
commit3d9d4f6f1cdee0e1e83362e8c781575b0b56a825 (patch)
treecb192a5f453be307b208b24ee0011d76366980cb /math
parentc6d7ec0d649f47c7fa647831375fb34d75f9608f (diff)
downloadfreebsd-ports-gnome-3d9d4f6f1cdee0e1e83362e8c781575b0b56a825.tar.gz
freebsd-ports-gnome-3d9d4f6f1cdee0e1e83362e8c781575b0b56a825.tar.zst
freebsd-ports-gnome-3d9d4f6f1cdee0e1e83362e8c781575b0b56a825.zip
- Use USES=localbase
- Strip shared library - Bump PORTREVISION for package change
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-GMPz/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/p5-Math-GMPz/Makefile b/math/p5-Math-GMPz/Makefile
index 0a952f1b2f0f..6a91b24150f2 100644
--- a/math/p5-Math-GMPz/Makefile
+++ b/math/p5-Math-GMPz/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Math-GMPz
PORTVERSION= 0.40
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,8 +18,12 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
USE_PERL5= configure
-USES= perl5
+USES= localbase perl5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/GMPz.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/Random/Random.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/V/V.so
.include <bsd.port.mk>