aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 16:27:46 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 16:27:46 +0800
commit40d981465fe902d95c38cd561907133ec8ad05b7 (patch)
treebd5880fc2a7e14f8cc7db1f5de129755ca993d33 /math
parentfad14a751db78fb23381bd9b2b70a0945f1350b5 (diff)
downloadfreebsd-ports-gnome-40d981465fe902d95c38cd561907133ec8ad05b7.tar.gz
freebsd-ports-gnome-40d981465fe902d95c38cd561907133ec8ad05b7.tar.zst
freebsd-ports-gnome-40d981465fe902d95c38cd561907133ec8ad05b7.zip
Create at least a bit more proper libraries:
- run ranlib on the static library - give a soname to the shared library - make the real file the the library with a version in the name - make the .so the symlink Bump portrevision for the ports using the library
Diffstat (limited to 'math')
-rw-r--r--math/ccmath/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/math/ccmath/Makefile b/math/ccmath/Makefile
index 5448892a824c..d9cf7e3a045c 100644
--- a/math/ccmath/Makefile
+++ b/math/ccmath/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ccmath
PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SUNSITE/libs
@@ -38,13 +38,16 @@ do-build:
.endfor
(cd ${WRKSRC}/matrix; ${CC} ${COPT} -c qrb*.c)
${MV} ${WRKSRC}/matrix/*.o ${WRKSRC}/tmp
- (cd ${WRKSRC}/tmp; ${AR} r libccm.a *.o; ${CC} -shared -o libccm.so *.o)
+ (cd ${WRKSRC}/tmp; \
+ ${AR} r libccm.a *.o; \
+ ${RANLIB} libccm.a; \
+ ${CC} -shared -Wl,-soname=libccm.so.1 -o libccm.so.1 *.o)
do-install:
@${INSTALL_DATA} ${WRKSRC}/ccmath.h ${STAGEDIR}${PREFIX}/include
@${INSTALL_DATA} ${WRKSRC}/tmp/libccm.a ${STAGEDIR}${PREFIX}/lib
- @${INSTALL_PROGRAM} ${WRKSRC}/tmp/libccm.so ${STAGEDIR}${PREFIX}/lib
- @${LN} -s libccm.so ${STAGEDIR}${PREFIX}/lib/libccm.so.1
+ @${INSTALL_LIB} ${WRKSRC}/tmp/libccm.so.1 ${STAGEDIR}${PREFIX}/lib
+ @${LN} -s libccm.so.1 ${STAGEDIR}${PREFIX}/lib/libccm.so
@${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/ccmath
@${INSTALL_DATA} ${WRKSRC}/manual/* ${STAGEDIR}${PREFIX}/share/doc/ccmath