aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormeta <meta@FreeBSD.org>2018-09-21 14:30:15 +0800
committermeta <meta@FreeBSD.org>2018-09-21 14:30:15 +0800
commit464e9fadc5350464d521440c49f95f0f80077d7c (patch)
tree1ac85b84bcd304a2492d73029a9c74da076c9d4f /math
parent78201fa8f2ef52901d5f84cfcab6d3cab3d60050 (diff)
downloadfreebsd-ports-gnome-464e9fadc5350464d521440c49f95f0f80077d7c.tar.gz
freebsd-ports-gnome-464e9fadc5350464d521440c49f95f0f80077d7c.tar.zst
freebsd-ports-gnome-464e9fadc5350464d521440c49f95f0f80077d7c.zip
math/singular: add USES=ncurses warned by stage-qa
Also, * replace some hardcoded "/bin/bash" not been replaced with shebangfix PR: 229864 Submitted by: meta (myself) Approved by: maintainer timeout, pi (mentor)
Diffstat (limited to 'math')
-rw-r--r--math/singular/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/singular/Makefile b/math/singular/Makefile
index d23f43af35ca..ef2fe58189a9 100644
--- a/math/singular/Makefile
+++ b/math/singular/Makefile
@@ -2,6 +2,7 @@
PORTNAME= singular
PORTVERSION= 4.1.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/SOURCES/4-1-1/
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
-USES= gmake libtool perl5 pkgconfig shebangfix
+USES= gmake libtool ncurses perl5 pkgconfig shebangfix
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -23,4 +24,10 @@ MAKE_JOBS_UNSAFE= yes
SHEBANG_FILES= libpolys/libpolys-config.in \
libsingular-config.in
+# not a shebang but "/bin/bash" is hardcoded in some files
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|g" \
+ ${WRKSRC}/emacs/.emacs-general
+
+
.include <bsd.port.mk>