aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2015-06-22 10:15:50 +0800
committerstephen <stephen@FreeBSD.org>2015-06-22 10:15:50 +0800
commit46526b34de5e5f34d0dc3617761aef065ef32a58 (patch)
tree271ab67f406311d70b161ade24ee0cd408a06d97 /math
parent30e953f048a5c377bbcb5d2e783d67c96f3b9c5e (diff)
downloadfreebsd-ports-gnome-46526b34de5e5f34d0dc3617761aef065ef32a58.tar.gz
freebsd-ports-gnome-46526b34de5e5f34d0dc3617761aef065ef32a58.tar.zst
freebsd-ports-gnome-46526b34de5e5f34d0dc3617761aef065ef32a58.zip
- Attempt to fix errors in http://beefy5.nyi.freebsd.org/data/101i386-default/390032/logs/octave-forge-interval-1.0.0.log.
I am hoping the gcc compiler will work better than the clang compiler. I'll monitor the resulting error messages to see if I am correct.
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-interval/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/math/octave-forge-interval/Makefile b/math/octave-forge-interval/Makefile
index 07bc1267c42f..61a92e224f36 100644
--- a/math/octave-forge-interval/Makefile
+++ b/math/octave-forge-interval/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
LIB_DEPENDS= libmpfr.so:${PORTSDIR}/math/mpfr
-USES= compiler:c++11-lang
+USES= compiler:openmp
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
@@ -27,10 +27,4 @@ post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000000
-BROKEN= Doesn't build on FreeBSD 9 or older
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>