aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-08-15 06:35:50 +0800
committerak <ak@FreeBSD.org>2013-08-15 06:35:50 +0800
commit472387c1864e149c8de23f290e91793ad7fbf8ca (patch)
treee9aa43bc0924dc359b2756757c2c0994f118aa35 /math
parentf2d5090c7c455bef6c3cbb6ddcb5bc50b3fe334b (diff)
downloadfreebsd-ports-gnome-472387c1864e149c8de23f290e91793ad7fbf8ca.tar.gz
freebsd-ports-gnome-472387c1864e149c8de23f290e91793ad7fbf8ca.tar.zst
freebsd-ports-gnome-472387c1864e149c8de23f290e91793ad7fbf8ca.zip
- Remove MAKE_JOBS_SAFE variable
Approved by: portmgr (bdrewery)
Diffstat (limited to 'math')
-rw-r--r--math/aamath/Makefile1
-rw-r--r--math/abakus/Makefile1
-rw-r--r--math/analitza/Makefile1
-rw-r--r--math/cantor/Makefile1
-rw-r--r--math/cloog/Makefile1
-rw-r--r--math/djbfft/Makefile1
-rw-r--r--math/fftw/Makefile1
-rw-r--r--math/fricas/Makefile1
-rw-r--r--math/giacxcas/Makefile1
-rw-r--r--math/gmp/Makefile1
-rw-r--r--math/gnumeric/Makefile1
-rw-r--r--math/gnuplot/Makefile1
-rw-r--r--math/grace/Makefile1
-rw-r--r--math/graphthing/Makefile1
-rw-r--r--math/gri/Makefile1
-rw-r--r--math/kalgebra/Makefile1
-rw-r--r--math/kbruch/Makefile1
-rw-r--r--math/kcalc/Makefile1
-rw-r--r--math/kig/Makefile1
-rw-r--r--math/kmplot/Makefile1
-rw-r--r--math/labplot/Makefile1
-rw-r--r--math/lapack/Makefile1
-rw-r--r--math/lapacke/Makefile1
-rw-r--r--math/levmar/Makefile1
-rw-r--r--math/liborigin/Makefile1
-rw-r--r--math/libtommath/Makefile1
-rw-r--r--math/polymake/Makefile1
-rw-r--r--math/primegen/Makefile1
-rw-r--r--math/qtiplot/Makefile1
-rw-r--r--math/qtoctave/Makefile1
-rw-r--r--math/rocs/Makefile1
-rw-r--r--math/sage/Makefile1
-rw-r--r--math/scilab/Makefile1
-rw-r--r--math/speedcrunch/Makefile1
-rw-r--r--math/tetgen/Makefile1
-rw-r--r--math/tomsfastmath/Makefile1
-rw-r--r--math/vtk5/Makefile1
-rw-r--r--math/xspread/Makefile1
-rw-r--r--math/yacas/Makefile1
39 files changed, 0 insertions, 39 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index 75b84fa1d0e9..63d336a3a731 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Renders ASCII art from mathematical expressions
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME}
MAN1= ${PORTNAME}.1
diff --git a/math/abakus/Makefile b/math/abakus/Makefile
index 9a7cae1a8dc6..2f1647d6c0d6 100644
--- a/math/abakus/Makefile
+++ b/math/abakus/Makefile
@@ -21,7 +21,6 @@ USES= bison cmake
CMAKE_ARGS= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include" \
-DCMAKE_REQUIRED_FLAGS:STRING="${LDFLAGS}" \
-DFLEX_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/flex
-MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 0d70578dc6d4..c08c0e93423f 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -19,6 +19,5 @@ USE_QT4= corelib gui opengl svg xml \
moc_build qmake_build rcc_build uic_build
USE_GL= glu
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 5a2f98e80c8a..b47ff3c696d6 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -22,7 +22,6 @@ USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= MAXIMA OCTAVE R
MAXIMA_DESC= Maxima backend
diff --git a/math/cloog/Makefile b/math/cloog/Makefile
index ee8f5e65211a..c95fc74a881a 100644
--- a/math/cloog/Makefile
+++ b/math/cloog/Makefile
@@ -15,7 +15,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-gmp-prefix=${PREFIX}
CONFIGURE_ENV= pkgconfig_libdir=${PREFIX}/libdata/pkgconfig/
-MAKE_JOBS_SAFE= yes
post-install:
${LN} -s ${PREFIX}/lib/libcloog-isl.so.4 \
diff --git a/math/djbfft/Makefile b/math/djbfft/Makefile
index f424c13c4c9b..486391f71ffe 100644
--- a/math/djbfft/Makefile
+++ b/math/djbfft/Makefile
@@ -17,7 +17,6 @@ COMMENT= An extremely fast library for floating-point convolution
DISABLE_SIZE= yes
ALL_TARGET=
INSTALL_TARGET=setup check
-MAKE_JOBS_SAFE= yes
HEADER_FILES= complex4.h complex8.h fftc4.h fftc8.h fftfreq.h \
fftr4.h fftr8.h real4.h real8.h
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index d7083119f1a2..249107974a15 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -32,7 +32,6 @@ AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
PLIST_SUB= FFTW_SUFX="${FFTW_SUFX}"
diff --git a/math/fricas/Makefile b/math/fricas/Makefile
index c3ac32cf0666..e72a69c2b946 100644
--- a/math/fricas/Makefile
+++ b/math/fricas/Makefile
@@ -25,7 +25,6 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lisp=sbcl
USE_LDCONFIG= ${PREFIX}/lib/fricas/target/${CONFIGURE_TARGET}/lib
-MAKE_JOBS_SAFE= yes
STRIP= #nothing, these binaries fail if stripped
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index de64e6d9d0ce..2404f2bf6242 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -31,7 +31,6 @@ USE_XORG= xcursor xft xi
USE_TEX= latex:build dvipsk:build
USE_LDCONFIG= yes
USES= gettext
-MAKE_JOBS_SAFE= yes
DOCSDIR= ${PREFIX}/share/doc/giac
PORTDOCS= *
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index e7273771f3e1..3114da95544d 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -25,7 +25,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--infodir=${PREFIX}/info \
--mandir=${PREFIX}/man \
--enable-cxx
-MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
INFO= gmp
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 2b1c315c7b78..76d83da4da84 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -30,7 +30,6 @@ INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_JOBS_SAFE= yes
GLIB_SCHEMAS= org.gnome.gnumeric.dialogs.gschema.xml \
org.gnome.gnumeric.gschema.xml \
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 2806d7feb3fa..7c28a4744fdd 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -16,7 +16,6 @@ CONFIGURE_ARGS+=--with-lasergnu \
--without-lisp-files \
--without-tutorial \
--with-bitmap-terminals
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF PLOT TEX THINSPLINES WX X11
GRIDBOX_DESC= Use the gridbox optimization for hidden3d
diff --git a/math/grace/Makefile b/math/grace/Makefile
index c0260b768779..e39ca2b600ba 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -35,7 +35,6 @@ CONFIGURE_ARGS= --enable-grace-home=${DATADIR} \
--with-helpviewer="xdg-open %s" \
--without-bundled-xbae
ALL_TARGET= # empty
-MAKE_JOBS_SAFE= yes
MAN1= convcal.1 grace.1 grconvert.1
MLINKS= grace.1 gracebat.1 \
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index 3c7ae98b0f23..2847f6c70fee 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -21,7 +21,6 @@ WX_CONF_ARGS= absolute
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
-MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/graphthing bin/gt
diff --git a/math/gri/Makefile b/math/gri/Makefile
index 99df35a90568..5e37562db08a 100644
--- a/math/gri/Makefile
+++ b/math/gri/Makefile
@@ -15,7 +15,6 @@ USES= readline
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-FreeBSD
-MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index 4e70f46586ef..d8f81b9620e8 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -21,6 +21,5 @@ USES= cmake:outsource
USE_QT4= corelib declarative gui opengl \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 9c178b3f4258..f82ea0e6eee5 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -16,7 +16,6 @@ USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAKE_JOBS_SAFE= yes
MAN1= kbruch.1
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index f7c59b71a5b5..187291942fe1 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -19,6 +19,5 @@ USE_XZ= yes
USE_KDE4= kdeprefix kdehier automoc4 kdelibs
USES= cmake:outsource
USE_QT4= xml qmake_build moc_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 0f4aad3d5dee..38247188718c 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -16,7 +16,6 @@ USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= gui xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAKE_JOBS_SAFE= yes
MAN1= kig.1
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index db4f82c3fb1b..4043d3e6b067 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -16,7 +16,6 @@ USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAKE_JOBS_SAFE= yes
MAN1= kmplot.1
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index a074aa57dc41..6d5601127086 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -24,7 +24,6 @@ USE_KDE4= automoc4 kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
USES= cmake
CMAKE_ARGS= -DOPJ_LIBRARY:STRING=""
-MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index fcb4659628a8..1d443d7b3909 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -26,7 +26,6 @@ SHARED_DESC= Build shared libraries and PIC archives
STATIC_DESC= Build (non-PIC) archives
MAKE_ENV= BLASLIB="${BLASLIB}"
-MAKE_JOBS_SAFE= yes
PLIST_SUB= SVERSION="${SVERSION}"
WRKSRC = ${WRKDIR}/lapack-${PORTVERSION}
diff --git a/math/lapacke/Makefile b/math/lapacke/Makefile
index f2f3c0ceb666..04f293df9b1e 100644
--- a/math/lapacke/Makefile
+++ b/math/lapacke/Makefile
@@ -18,7 +18,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_LDCONFIG= yes
USE_FORTRAN= yes
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= PROFILE XLAPACKE
PROFILE_DESC= Build a profiling library
diff --git a/math/levmar/Makefile b/math/levmar/Makefile
index 204d05138d1f..81b1bbf69c3a 100644
--- a/math/levmar/Makefile
+++ b/math/levmar/Makefile
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_LDCONFIG= yes
USE_FORTRAN= yes
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= PROFILE
PROFILE_DESC= Build a profiling library
diff --git a/math/liborigin/Makefile b/math/liborigin/Makefile
index 17c6dc7ac4c3..4d324aaabf77 100644
--- a/math/liborigin/Makefile
+++ b/math/liborigin/Makefile
@@ -15,7 +15,6 @@ CONFLICTS_INSTALL= labplot-2.*
USES= cmake:outsource
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 2d59bdc98167..7c19de03a07c 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -18,7 +18,6 @@ USE_GMAKE= yes
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
-MAKE_JOBS_SAFE= yes
PLIST_FILES= include/tommath.h include/tommath_class.h \
include/tommath_superclass.h lib/libtommath.a
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index cfdce3314cb8..a712c9def124 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -34,7 +34,6 @@ JAVA_BUILD= yes
JAVA_RUN= yes
JAVA_VERSION= 1.6
-MAKE_JOBS_SAFE= yes
MAKE_ENV+= ProcessDep=none
NO_INSTALL_MANPAGES= yes
diff --git a/math/primegen/Makefile b/math/primegen/Makefile
index 8303ba0dbac5..c613e076b258 100644
--- a/math/primegen/Makefile
+++ b/math/primegen/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= A small, fast library to generate prime numbers in order
ALL_TARGET=
-MAKE_JOBS_SAFE= yes
MAN1= primes.1 primegaps.1
MAN3= primegen.3
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index f41cfb52ab95..1280d7f94ada 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -26,7 +26,6 @@ HAS_CONFIGURE= yes
QMAKE_ARGS+= -recursive PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
PYTHON_CMD=${PYTHON_CMD}
USE_DOS2UNIX= *.pro
-MAKE_JOBS_SAFE= yes
MAN1= qtiplot.1
DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index f6b1090ef292..8ec59cb34f18 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -15,7 +15,6 @@ USE_QT4= designer gui network script svg xml \
linguist_build
USES= cmake
CMAKE_ARGS+= -DWITH_UseRPMTools:Bool=Off
-MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e '/COMMAND "lrelease"/s,lrelease,$${QT_LRELEASE_EXECUTABLE},' \
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index b314f7c602dc..efeb69929fa0 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -20,6 +20,5 @@ USE_QT4= gui qtestlib script scripttools webkit xml \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 9e5848d485ae..23ce1b4ac4c9 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -35,7 +35,6 @@ USE_TK= yes
USE_GMAKE= yes
USE_TEX= latex:build
USES= iconv
-MAKE_JOBS_SAFE= yes
LDFLAGS:= -Wl,-rpath=${WRKSRC}/local/lib ${LDFLAGS}
FFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib ${FPM_FLAG}
CFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib ${FPM_FLAG}
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index b748e03e4d7b..11ccb36ae201 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -21,7 +21,6 @@ EXTRACT_DEPENDS+= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
pcre.3:${PORTSDIR}/devel/pcre
-MAKE_JOBS_SAFE= yes
USE_FORTRAN= yes
USES= gettext
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index a84e22ee2caf..2bd7708da4a2 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -14,7 +14,6 @@ USE_QT4= qmake_build moc_build rcc_build uic_build gui xml
USES= cmake
CMAKE_SOURCE_PATH= src
-MAKE_JOBS_SAFE= yes
LRELEASE_CMD= ${LOCALBASE}/bin/lrelease-qt4
LRELEASE_ARGS= -compress -silent
diff --git a/math/tetgen/Makefile b/math/tetgen/Makefile
index 345b85ed6a69..fa090e3b7d0d 100644
--- a/math/tetgen/Makefile
+++ b/math/tetgen/Makefile
@@ -23,7 +23,6 @@ OPTIONS_DEFINE= EXAMPLES
MAKEFILE= makefile
ALL_TARGET= tetgen tetlib
-MAKE_JOBS_SAFE= yes
PORTEXAMPLES= example.poly
PLIST_FILES= bin/tetgen include/tetgen.h lib/libtet.a
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
index a0472c7d468a..398572936923 100644
--- a/math/tomsfastmath/Makefile
+++ b/math/tomsfastmath/Makefile
@@ -15,7 +15,6 @@ MAKEFILE= makefile
USE_BZIP2= yes
USE_GMAKE= yes
ALL_TARGET= default
-MAKE_JOBS_SAFE= yes
PLIST_FILES= include/tfm.h lib/libtfm.a
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 3a38308648b7..d44a4e678444 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -27,7 +27,6 @@ USES= cmake:outsource
USE_XORG= xt
USE_LDCONFIG= ${PREFIX}/lib/vtk-${PORTVERSION:R}
CXXFLAGS+= -DUSE_INTERP_ERRORLINE
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= SHARED VTKMPEG2 GL2PS OSMESA QT4 JAVA PYTHON TCLTK \
DBGLEAKS LEGACY
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index a0f00df48a7d..f09175fbf53a 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -22,7 +22,6 @@ OPTIONS_DEFINE= X11 DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
MAN1= xspread.1 pxspread.1
PORTDOCS= *
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 8b5b60db5dd0..3956cf1bd887 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -20,7 +20,6 @@ USE_PERL5_BUILD=yes
USE_GMAKE= yes
#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>