aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-31 23:23:13 +0800
committermat <mat@FreeBSD.org>2016-03-31 23:23:13 +0800
commit47384b7b765d30db8a3f19efbc728da56db408c1 (patch)
treea7da32f6c0064d6be598b00d61f30117a3f396dd /math
parent7d34bddd896fa9a7fe8636ebc3af9f081ede5884 (diff)
downloadfreebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.tar.gz
freebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.tar.zst
freebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.zip
Cleanup dependencies on lang/p5-Scalar-List-Utils.
The different cases are: - Only bring it if the one bundled with Perl is outdated. - The version bundled with all our Perl is sufficient. - Scalar-List-Util is not really needed by the port. (looking for /(Sub|Scalar|List)::Util/ returns nothing.) While there, do some minor cleanup that caught my eye. PR: 208378 With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'math')
-rw-r--r--math/p5-Graph/Makefile5
-rw-r--r--math/p5-Math-Algebra-Symbols/Makefile5
-rw-r--r--math/p5-Math-Polygon-Tree/Makefile2
3 files changed, 4 insertions, 8 deletions
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index 392d670e4cd9..a1ea9305eeeb 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Graph
PORTVERSION= 0.96
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
@@ -12,8 +12,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Graph, the Perl module for graph operations
-BUILD_DEPENDS= p5-Heap>=0:${PORTSDIR}/devel/p5-Heap \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Heap>=0:${PORTSDIR}/devel/p5-Heap
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/math/p5-Math-Algebra-Symbols/Makefile b/math/p5-Math-Algebra-Symbols/Makefile
index 02cbcaae71ec..a824f301ae67 100644
--- a/math/p5-Math-Algebra-Symbols/Makefile
+++ b/math/p5-Math-Algebra-Symbols/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Math-Algebra-Symbols
PORTVERSION= 1.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +14,6 @@ COMMENT= Symbolic Algebra in Pure Perl
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
USES= perl5 shebangfix
SHEBANG_FILES= symbols.pl
perl_OLD_CMD= perl
diff --git a/math/p5-Math-Polygon-Tree/Makefile b/math/p5-Math-Polygon-Tree/Makefile
index 1d22bb49b479..6ebf51779e5d 100644
--- a/math/p5-Math-Polygon-Tree/Makefile
+++ b/math/p5-Math-Polygon-Tree/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Math-Polygon-Tree
PORTVERSION= 0.08
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:LIOSHA
@@ -12,7 +13,6 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Class for fast check if point is inside polygon
BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Math-Geometry-Planar-GPC-PolygonXS>=0:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-PolygonXS
RUN_DEPENDS:= ${BUILD_DEPENDS}