aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-08-30 17:56:44 +0800
committerijliao <ijliao@FreeBSD.org>2004-08-30 17:56:44 +0800
commit479eebe335bd62b7191a563c41fdaaa3053e40b4 (patch)
treebaafc6d57ad3b47982d7c02a38fc8f975c86b892 /math
parentff24aaf3624f662171bd930d7171a7cc6013ebfd (diff)
downloadfreebsd-ports-gnome-479eebe335bd62b7191a563c41fdaaa3053e40b4.tar.gz
freebsd-ports-gnome-479eebe335bd62b7191a563c41fdaaa3053e40b4.tar.zst
freebsd-ports-gnome-479eebe335bd62b7191a563c41fdaaa3053e40b4.zip
add qgfe 1.0
Gnuplot Front End
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/qgfe/Makefile39
-rw-r--r--math/qgfe/distinfo2
-rw-r--r--math/qgfe/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 2aa69404d072..9d64e6438405 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -184,6 +184,7 @@
SUBDIR += py-numeric17
SUBDIR += py-probstat
SUBDIR += py-scientific
+ SUBDIR += qgfe
SUBDIR += qhull
SUBDIR += qscanplot
SUBDIR += qalculate
diff --git a/math/qgfe/Makefile b/math/qgfe/Makefile
new file mode 100644
index 000000000000..6367205bac07
--- /dev/null
+++ b/math/qgfe/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# Ports collection makefile for: qgfe
+# Date created: Aug 30, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qgfe
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= http://perso.club-internet.fr/pascal.brachet/qgfe/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gnuplot Front End
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_QT_VER= 3
+MAKE_ENV= QTDIR=${X11BASE} \
+ MOC=${MOC}
+
+PLIST_FILES= bin/qgfe
+
+post-patch:
+ @${REINPLACE_CMD} -e "s@strstream.h@sstream@" \
+ -e "s,ostrstream,ostringstream," ${WRKSRC}/logScaleOp.cpp
+
+pre-build:
+ @cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qgfe ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/math/qgfe/distinfo b/math/qgfe/distinfo
new file mode 100644
index 000000000000..7e8976fcf5ee
--- /dev/null
+++ b/math/qgfe/distinfo
@@ -0,0 +1,2 @@
+MD5 (qgfe_1.0.tar.bz2) = 0e94e4e5212afdcdd1a3e0866a057935
+SIZE (qgfe_1.0.tar.bz2) = 69874
diff --git a/math/qgfe/pkg-descr b/math/qgfe/pkg-descr
new file mode 100644
index 000000000000..a7af884965cc
--- /dev/null
+++ b/math/qgfe/pkg-descr
@@ -0,0 +1,4 @@
+Qgfe is a graphical interface to the powerful gnuplot program for Unix systems.
+A good knowledge of Gnuplot is required to use Qgfe.
+
+WWW: http://perso.club-internet.fr/pascal.brachet/qgfe/