aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-01 14:24:52 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-01 14:24:52 +0800
commit4d6f7a79a49154613836011ebea709109ea33ac7 (patch)
treee27af371296c713c228bb78960f8d15e48a8cedc /math
parentef675b6e39ecb0036fc7694bce843b9acf92f2cd (diff)
downloadfreebsd-ports-gnome-4d6f7a79a49154613836011ebea709109ea33ac7.tar.gz
freebsd-ports-gnome-4d6f7a79a49154613836011ebea709109ea33ac7.tar.zst
freebsd-ports-gnome-4d6f7a79a49154613836011ebea709109ea33ac7.zip
New port: math/py-pyodesys: Straightforward numerical integration of ODE systems from Python
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyodesys/Makefile25
-rw-r--r--math/py-pyodesys/distinfo3
-rw-r--r--math/py-pyodesys/pkg-descr15
4 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0755a0263fcb..4062a40eb2cd 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -675,6 +675,7 @@
SUBDIR += py-pymc
SUBDIR += py-pymc3
SUBDIR += py-pyneqsys
+ SUBDIR += py-pyodesys
SUBDIR += py-pysparse
SUBDIR += py-pysym
SUBDIR += py-pyvtk
diff --git a/math/py-pyodesys/Makefile b/math/py-pyodesys/Makefile
new file mode 100644
index 000000000000..59bb94fe61b7
--- /dev/null
+++ b/math/py-pyodesys/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pyodesys
+DISTVERSION= 0.11.9
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Straightforward numerical integration of ODE systems from Python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sym>=0.3.1:math/py-sym@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sympy>=1.1.1:math/py-sympy@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pyodesys/distinfo b/math/py-pyodesys/distinfo
new file mode 100644
index 000000000000..07de6987799c
--- /dev/null
+++ b/math/py-pyodesys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522563241
+SHA256 (pyodesys-0.11.9.tar.gz) = 60ade7b48423ab98534260548624f0a9b20e788fa8a2dcee3a790478137019a0
+SIZE (pyodesys-0.11.9.tar.gz) = 97005
diff --git a/math/py-pyodesys/pkg-descr b/math/py-pyodesys/pkg-descr
new file mode 100644
index 000000000000..de5a9de6433d
--- /dev/null
+++ b/math/py-pyodesys/pkg-descr
@@ -0,0 +1,15 @@
+pyodesys provides a straightforward way of numerically integrating systems of
+ordinary differential equations (initial value problems). It unifies the
+interface of several libraries for performing the numerical integration as well
+as several libraries for symbolic representation. It also provides a convenience
+class for representing and integrating ODE systems defined by symbolic
+expressions, e.g. SymPy expressions. This allows the user to write concise code
+and rely on pyodesys to handle the subtle differences between libraries.
+
+The numerical integration is performed using either:
+* scipy.integrate.ode
+* pygslodeiv2
+* pyodeint
+* pycvodes
+
+WWW: https://github.com/bjodah/pyodesys