aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-01-06 12:15:12 +0800
committerlinimon <linimon@FreeBSD.org>2004-01-06 12:15:12 +0800
commit5019157bd6e0efafe8c9ba91e28c37bad81e0bf7 (patch)
treedbcf9d3c6899dc283a271d554043492e83409634 /math
parent6918af459f1bd9a65c5413acc5a7c662057400cf (diff)
downloadfreebsd-ports-gnome-5019157bd6e0efafe8c9ba91e28c37bad81e0bf7.tar.gz
freebsd-ports-gnome-5019157bd6e0efafe8c9ba91e28c37bad81e0bf7.tar.zst
freebsd-ports-gnome-5019157bd6e0efafe8c9ba91e28c37bad81e0bf7.zip
Add math/koctave, a KDE GUI for the math/octave package. It contains
an editor with syntax highlighning and a help browser; you can work almost the same way as in Matlab (c) , i.e. use the editor and execute your code from there with (F5) or press run. One difference is the command window; it is meant for "quick commands" and not a history as in Matlab you can add commands to the list in settings. (Note to submitter: it is not necessary to remove all the directories in pkg-plist that are installed by any standard X-related port). PR: ports/55143 Submitted by: Kay Lehmann <kay_lehmann@web.de>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile2
-rw-r--r--math/koctave/Makefile27
-rw-r--r--math/koctave/distinfo1
-rw-r--r--math/koctave/pkg-descr10
-rw-r--r--math/koctave/pkg-plist15
5 files changed, 55 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b957ee51fc3c..979c632e0d9f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -67,10 +67,12 @@
SUBDIR += guppi
SUBDIR += hexcalc
SUBDIR += it++
+ SUBDIR += itl
SUBDIR += jacal
SUBDIR += jama
SUBDIR += javanns
SUBDIR += kaskade
+ SUBDIR += koctave
SUBDIR += kseg
SUBDIR += lapack
SUBDIR += lapack++
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
new file mode 100644
index 000000000000..b8d589e5fae7
--- /dev/null
+++ b/math/koctave/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: koctave
+# Date created: 01 August 2003
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= koctave3
+PORTVERSION= 0.65
+CATEGORIES= math kde
+MASTER_SITES= http://bubben.homelinux.net/~matti/koctave/
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= KDEGUI for octave
+
+RUN_DEPENDS= octave:${PORTSDIR}/math/octave
+
+USE_BZIP2= yes
+USE_LIBTOOL= yes
+USE_QT_VER= 3
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--program-transform-name=koctave3
+
+.include <bsd.port.mk>
diff --git a/math/koctave/distinfo b/math/koctave/distinfo
new file mode 100644
index 000000000000..a279a5d30037
--- /dev/null
+++ b/math/koctave/distinfo
@@ -0,0 +1 @@
+MD5 (koctave3-0.65.tar.bz2) = f094f30ed2ec150bb6ae95676b2647e0
diff --git a/math/koctave/pkg-descr b/math/koctave/pkg-descr
new file mode 100644
index 000000000000..dc9cd33879c7
--- /dev/null
+++ b/math/koctave/pkg-descr
@@ -0,0 +1,10 @@
+kOctave is a KDE GUI for Octave; look at Octave's homepage
+if you don't know what it is. kOctave contains an editor
+with syntax highlighting and a help browser; you can work
+almost the same way as in Matlab (c), i.e. use the editor
+and execute your code from there with (F5) or press run.
+One difference is the command window, it is meant for
+"quick commands" and not a history as in Matlab you can
+add commands to the list in settings.
+
+WWW: http://bubben.homelinux.net/~matti/koctave/
diff --git a/math/koctave/pkg-plist b/math/koctave/pkg-plist
new file mode 100644
index 000000000000..7f492170f78a
--- /dev/null
+++ b/math/koctave/pkg-plist
@@ -0,0 +1,15 @@
+bin/koctave3
+share/applnk/Applications/koctave3.desktop
+share/applnk/share/apps/koctave3/editorui.rc
+share/applnk/share/apps/koctave3/koctave3ui.rc
+share/apps/koctave3/koctave3ui.rc
+share/doc/HTML/en/koctave3/index.cache.bz2
+share/doc/HTML/en/koctave3/index.docbook
+share/icons/hicolor/16x16/apps/koctave3.png
+share/icons/hicolor/32x32/apps/koctave3.png
+share/icons/locolor/16x16/apps/koctave3.png
+share/icons/locolor/32x32/apps/koctave3.png
+@dirrm share/doc/HTML/en/koctave3/common
+@dirrm share/doc/HTML/en/koctave3
+@dirrm share/apps/koctave3
+@dirrm share/applnk/share/apps/koctave3