aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2013-05-07 02:26:22 +0800
committerglarkin <glarkin@FreeBSD.org>2013-05-07 02:26:22 +0800
commit5120d0b75c4e62c6aa44b69a842b38576337f3d7 (patch)
tree4bb52c4b024befde1f9099e156529f870a8e021f /math
parenta777942470c464c727da2d2066271eb38d96015d (diff)
downloadfreebsd-ports-gnome-5120d0b75c4e62c6aa44b69a842b38576337f3d7.tar.gz
freebsd-ports-gnome-5120d0b75c4e62c6aa44b69a842b38576337f3d7.tar.zst
freebsd-ports-gnome-5120d0b75c4e62c6aa44b69a842b38576337f3d7.zip
- Fix build problem with graphics/graphviz already installed [1]
- Trim Makefile header [1] - Use DOCSDIR in pkg-plist PR: ports/178185 Submitted by: Rainer Hurling <rhurlin@gwdg.de> (maintainer) [1]
Diffstat (limited to 'math')
-rw-r--r--math/ggobi/Makefile15
-rw-r--r--math/ggobi/pkg-plist6
2 files changed, 13 insertions, 8 deletions
diff --git a/math/ggobi/Makefile b/math/ggobi/Makefile
index 152249d86fcb..06d90d4e285a 100644
--- a/math/ggobi/Makefile
+++ b/math/ggobi/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: ggobi
-# Date created: 31 January 2010
-# Whom: rhurlin
-#
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
# $FreeBSD$
-#
PORTNAME= ggobi
PORTVERSION= 2.1.9
@@ -33,6 +29,15 @@ post-patch:
${WRKSRC}/src/ggobi-renderer-factory.c \
${WRKSRC}/src/ggobi-renderer.c
+post-configure:
+# build gets irritated by the presence of an external graphviz version
+ @${REINPLACE_CMD} -e 's|#define HAVE_LIBGVC 1|/* #define HAVE_LIBGVC 1 */|' \
+ ${WRKSRC}/plugins/GraphLayout/config.h
+ @${REINPLACE_CMD} -e 's|LIBGVC_CFLAGS = -I${LOCALBASE}/include/graphviz|LIBGVC_CFLAGS =|' \
+ ${WRKSRC}/plugins/GraphLayout/Makefile
+ @${REINPLACE_CMD} -e 's|LIBGVC_LIBS = -L${LOCALBASE}/lib/graphviz -lgvc -lgraph -lcdt|LIBGVC_LIBS =|' \
+ ${WRKSRC}/plugins/GraphLayout/Makefile
+
post-install:
${MKDIR} ${PREFIX}/etc/xdg/ggobi
${INSTALL_DATA} ${WRKSRC}/ggobirc ${PREFIX}/etc/xdg/ggobi/ggobirc.sample
diff --git a/math/ggobi/pkg-plist b/math/ggobi/pkg-plist
index 42e5b0467b5b..b23f3f7ae21d 100644
--- a/math/ggobi/pkg-plist
+++ b/math/ggobi/pkg-plist
@@ -129,9 +129,9 @@ share/pixmaps/ggobi.png
@unexec if cmp -s %D/etc/xdg/ggobi/ggobirc.sample %D/etc/xdg/ggobi/ggobirc; then rm -f %D/etc/xdg/ggobi/ggobirc; fi
etc/xdg/ggobi/ggobirc.sample
@exec if [ ! -f %B/ggobirc ]; then cp -p %D/%F %B/ggobirc; fi
-share/doc/ggobi/XML.pdf
-share/doc/ggobi/manual.pdf
-@dirrm share/doc/ggobi
+%%DOCSDIR%%/XML.pdf
+%%DOCSDIR%%/manual.pdf
+@dirrm %%DOCSDIR%%
@dirrmtry share/applications
@dirrmtry etc/xdg/ggobi
@dirrmtry etc/xdg