aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2017-06-03 00:42:15 +0800
committerpawel <pawel@FreeBSD.org>2017-06-03 00:42:15 +0800
commit57c536e7429f05c6c0261daa0214ebae28542739 (patch)
treecb7c23771fd70b8d7fa32b3ff86a967777a6a0d7 /math
parentc22398a83f86a40a2365fd897134aebc3d2764a1 (diff)
downloadfreebsd-ports-gnome-57c536e7429f05c6c0261daa0214ebae28542739.tar.gz
freebsd-ports-gnome-57c536e7429f05c6c0261daa0214ebae28542739.tar.zst
freebsd-ports-gnome-57c536e7429f05c6c0261daa0214ebae28542739.zip
- Add missing NLS option to OPTIONS_DEFINE, LICENSE_FILE
- Register missing dependencies found by stage-qa - Convert to USES=localbase - Use options helpers - Strip gretl-gtk2 plugins - Regenerate patches with make makepatch, use correct patch naming
Diffstat (limited to 'math')
-rw-r--r--math/gretl/Makefile122
-rw-r--r--math/gretl/files/patch-Makefile.in8
-rw-r--r--math/gretl/files/patch-gui2_Makefile.in (renamed from math/gretl/files/patch-gui2__Makefile.in)10
-rw-r--r--math/gretl/files/patch-lib_Makefile.in (renamed from math/gretl/files/patch-lib__Makefile.in)6
-rw-r--r--math/gretl/files/patch-plugin_Makefile.in (renamed from math/gretl/files/patch-plugin__Makefile.in)6
-rw-r--r--math/gretl/files/patch-plugin__workbook.c10
-rw-r--r--math/gretl/files/patch-plugin_workbook.c10
-rw-r--r--math/gretl/files/patch-share_Makefile.in (renamed from math/gretl/files/patch-share__Makefile.in)10
-rw-r--r--math/gretl/files/patch-share__bcih__Makefile.in11
-rw-r--r--math/gretl/files/patch-share_bcih_Makefile.in11
10 files changed, 87 insertions, 117 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 78a7614fd06d..0598f3a2287a 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gretl
PORTVERSION= 1.9.13
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= math finance
MASTER_SITES= SF
@@ -11,96 +11,63 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNU Regression, Econometrics, and Time-series Library
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
- libfftw3.so:math/fftw3
+ libfftw3.so:math/fftw3 \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= fortran gmake libtool pathfix pkgconfig tar:bzip2
-WANT_GNOME= yes
+USES= fortran gmake localbase libtool ncurses pathfix pkgconfig \
+ readline tar:bzip2
ALL_TARGET= # empty
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake \
--disable-xdg-utils
-CONFIGURE_ENV= ac_cv_lib_dl_dlopen=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}"
-
-OPTIONS_DEFINE= ATLAS GUI ODBC OPENMP R UNZIP
-
-ATLAS_DESC= Use ATLAS for BLAS and LAPACK
-GUI_DESC= Graphical user interface and plugins
-R_DESC= libR support
-UNZIP_DESC= UnZip compression support via libgsf
+CONFIGURE_ENV= ac_cv_lib_dl_dlopen="" \
+ LAPACK_LIBS="${LAPACK} ${BLAS}"
+OPTIONS_DEFINE= ATLAS GUI NLS ODBC OPENMP R UNZIP
OPTIONS_DEFAULT= GUI OPENMP UNZIP
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= libatlas.so:math/atlas
-BLAS= -lf77blas
-LAPACK= -lalapack -lcblas
-.else
-LIB_DEPENDS+= libblas.so:math/blas \
- liblapack.so:math/lapack
-BLAS= -lblas
-LAPACK= -llapack
-.endif
-
-.if ${PORT_OPTIONS:MGUI}
-CONFIGURE_ARGS+= --enable-gtk2=yes --enable-gui=yes
-INSTALLS_ICONS= yes
-USE_GNOME= gtksourceview2
-USES+= desktop-file-utils shared-mime-info
-BUILD_DEPENDS+= gnuplot:math/gnuplot
-RUN_DEPENDS+= gnuplot:math/gnuplot
-PLIST_SUB+= GUI=""
-.else
-USE_GNOME= glib20 libxml2
-CONFIGURE_ARGS+= --enable-gui=no --enable-xdg=no
-PLIST_SUB+= GUI="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --enable-nls=yes
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --enable-nls=no
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MODBC}
-CONFIGURE_ARGS+= --with-odbc
-LIB_DEPENDS+= libodbc.so:databases/unixODBC
-PLIST_SUB+= ODBC=""
-.else
-CONFIGURE_ARGS+= --without-odbc
-PLIST_SUB+= ODBC="@comment "
-.endif
+ATLAS_DESC= Use ATLAS for BLAS and LAPACK
+ATLAS_LIB_DEPENDS= libatlas.so:math/atlas
+ATLAS_LIB_DEPENDS_OFF= libblas.so:math/blas \
+ liblapack.so:math/lapack
+ATLAS_VARS= BLAS=-lf77blas LAPACK="-lalapack -lcblas"
+ATLAS_VARS_OFF= BLAS=-lblas LAPACK=-llapack
-.if ${PORT_OPTIONS:MOPENMP}
-CONFIGURE_ARGS+= --enable-openmp
-.endif
+GUI_DESC= Graphical user interface and plugins
+GUI_CONFIGURE_ON= --enable-gtk2=yes --enable-gui=yes
+GUI_CONFIGURE_OFF= --enable-gui=no --enable-xdg=no
+GUI_VARS= INSTALLS_ICONS=yes
+GUI_USE= GNOME=cairo,gtksourceview2
+GUI_USE_OFF= GNOME=glib20,libxml2
+GUI_USES= desktop-file-utils shared-mime-info
+GUI_BUILD_DEPENDS= gnuplot:math/gnuplot
+GUI_LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+GUI_RUN_DEPENDS= gnuplot:math/gnuplot
+
+NLS_CONFIGURE_ON= --enable-nls=yes
+NLS_CONFIGURE_OFF= --enable-nls=no
+NLS_USES= gettext
+
+ODBC_CONFIGURE_WITH= odbc
+ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+
+OPENMP_CONFIGURE_ON= --enable-openmp
-.if ${PORT_OPTIONS:MR}
-CONFIGURE_ARGS+= --with-libR
-LIB_DEPENDS+= libR.so:math/R
-.else
-CONFIGURE_ARGS+= --without-libR
-.endif
+R_DESC= libR support
+R_CONFIGURE_WITH= libR
+R_LIB_DEPENDS= libR.so:math/R
-.if ${PORT_OPTIONS:MUNZIP}
-CONFIGURE_ARGS+= --with-gsf
-USE_GNOME+= libgsf
-PLIST_SUB+= NO_UNZIP="@comment "
-.else
-CONFIGURE_ARGS+= --without-gsf
-PLIST_SUB+= NO_UNZIP=""
-.endif
+UNZIP_DESC= UnZip compression support via libgsf
+UNZIP_CONFIGURE_WITH= gsf
+UNZIP_USE= GNOME=libgsf
.if !empty(MACHINE_CPU:Msse2)
CONFIGURE_ARGS+= --enable-sse2=yes
@@ -120,4 +87,7 @@ regression-test test check: build
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_ARGS} check
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gretl-gtk2/*.so
+
.include <bsd.port.mk>
diff --git a/math/gretl/files/patch-Makefile.in b/math/gretl/files/patch-Makefile.in
index c4dab95e3ebc..611f5571557c 100644
--- a/math/gretl/files/patch-Makefile.in
+++ b/math/gretl/files/patch-Makefile.in
@@ -1,7 +1,7 @@
---- Makefile.in.orig Thu Sep 12 00:35:22 2002
-+++ Makefile.in Mon Oct 21 10:02:37 2002
-@@ -22,8 +22,9 @@
- GUIDIR = gui
+--- Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ Makefile.in
+@@ -40,8 +40,9 @@ ifeq ($(use_xdg),yes)
+ XDGDIR = xdg
endif
-INSTALL_PROGRAM = ${INSTALL} -m 755
diff --git a/math/gretl/files/patch-gui2__Makefile.in b/math/gretl/files/patch-gui2_Makefile.in
index a69067182f13..50cb6aacc54c 100644
--- a/math/gretl/files/patch-gui2__Makefile.in
+++ b/math/gretl/files/patch-gui2_Makefile.in
@@ -1,6 +1,6 @@
---- gui2/Makefile.in.orig 2013-03-30 13:23:00.000000000 -0400
-+++ gui2/Makefile.in 2013-11-20 00:31:53.000000000 -0500
-@@ -122,7 +122,7 @@
+--- gui2/Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ gui2/Makefile.in
+@@ -122,7 +122,7 @@ ifeq ($(mac_native),yes)
PROG = gretl
else
PROG = gretl_x11$(EXEEXT)
@@ -9,7 +9,7 @@
endif
vpath %.c $(topsrc)/gui2
-@@ -215,7 +215,7 @@
+@@ -215,7 +215,7 @@ $(GRETL_LANG): $(MKLANG)
.PHONY:
@@ -18,7 +18,7 @@
install-strip: $(PROG) install-data
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s $(PROG) $(DESTDIR)$(bindir)/$(PROG)
-@@ -229,7 +229,7 @@
+@@ -229,7 +229,7 @@ install-ui: installdirs
$(INSTALL_DATA) $(topsrc)/gui2/gretlmodel.xml $(DESTDIR)$(uidir)
install-script: installdirs
diff --git a/math/gretl/files/patch-lib__Makefile.in b/math/gretl/files/patch-lib_Makefile.in
index 3c88d3c6119c..452107df6f28 100644
--- a/math/gretl/files/patch-lib__Makefile.in
+++ b/math/gretl/files/patch-lib_Makefile.in
@@ -1,6 +1,6 @@
---- lib/Makefile.in.orig 2013-08-16 13:12:54.000000000 -0400
-+++ lib/Makefile.in 2013-11-18 21:43:54.000000000 -0500
-@@ -70,7 +70,7 @@
+--- lib/Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ lib/Makefile.in
+@@ -70,7 +70,7 @@ INSTALLDIRS = $(DESTDIR)$(libdir) $(DESTDIR)$(included
LIBGRETL = libgretl-1.0.la
diff --git a/math/gretl/files/patch-plugin__Makefile.in b/math/gretl/files/patch-plugin_Makefile.in
index c7d66c786d8f..caa22f807288 100644
--- a/math/gretl/files/patch-plugin__Makefile.in
+++ b/math/gretl/files/patch-plugin_Makefile.in
@@ -1,6 +1,6 @@
---- plugin/Makefile.in.orig 2013-02-19 10:08:31.000000000 -0500
-+++ plugin/Makefile.in 2013-04-20 18:20:25.000000000 -0400
-@@ -350,13 +350,13 @@
+--- plugin/Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ plugin/Makefile.in
+@@ -354,13 +354,13 @@ $(GRETLLIB):
.PHONY:
install: $(GRETLLIB) $(PLUGINS) $(URCDATA) $(DWDATA) installdirs
diff --git a/math/gretl/files/patch-plugin__workbook.c b/math/gretl/files/patch-plugin__workbook.c
deleted file mode 100644
index d91482092391..000000000000
--- a/math/gretl/files/patch-plugin__workbook.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugin/workbook.c.orig Fri May 31 22:22:42 2002
-+++ plugin/workbook.c Sat Jul 27 08:45:00 2002
-@@ -24,6 +24,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <glib.h>
-+#include <wchar.h>
-
- #ifdef G_OS_WIN32
- # include "../winconfig.h"
diff --git a/math/gretl/files/patch-plugin_workbook.c b/math/gretl/files/patch-plugin_workbook.c
new file mode 100644
index 000000000000..4c434adc5ca8
--- /dev/null
+++ b/math/gretl/files/patch-plugin_workbook.c
@@ -0,0 +1,10 @@
+--- plugin/workbook.c.orig 2010-11-25 16:42:23 UTC
++++ plugin/workbook.c
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <glib.h>
++#include <wchar.h>
+
+ #include "libgretl.h"
+
diff --git a/math/gretl/files/patch-share__Makefile.in b/math/gretl/files/patch-share_Makefile.in
index 147ec53b6811..0a000d32ec31 100644
--- a/math/gretl/files/patch-share__Makefile.in
+++ b/math/gretl/files/patch-share_Makefile.in
@@ -1,6 +1,6 @@
---- share/Makefile.in.orig 2011-02-10 16:40:30.000000000 -0500
-+++ share/Makefile.in 2011-03-02 07:43:03.000000000 -0500
-@@ -13,7 +13,7 @@
+--- share/Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ share/Makefile.in
+@@ -12,7 +12,7 @@ tooldir = $(topsrc)/tools
sharesrc = $(topsrc)/share
pdfdir = ../doc/tex
@@ -9,8 +9,8 @@
AUTO_HELPFILES = \
gretlgui.hlp \
-@@ -80,22 +80,22 @@
- $(INSTALL_DATA) $(sharesrc)/functions/criteria.gfn $(DESTDIR)$(gretldir)/functions
+@@ -86,22 +86,22 @@ install_functions:
+ $(INSTALL_DATA) $(sharesrc)/functions/packages.xml $(DESTDIR)$(gretldir)/functions
install_man: gretl.1
- $(tooldir)/mkinstalldirs $(DESTDIR)$(prefix)/share/man/man1
diff --git a/math/gretl/files/patch-share__bcih__Makefile.in b/math/gretl/files/patch-share__bcih__Makefile.in
deleted file mode 100644
index 188de04e97d5..000000000000
--- a/math/gretl/files/patch-share__bcih__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- share/bcih/Makefile.in.orig 2011-08-21 15:13:15.000000000 -0400
-+++ share/bcih/Makefile.in 2011-10-18 21:24:45.000000000 -0400
-@@ -2,7 +2,7 @@
-
- CC = @CC@
- HOSTCC = @HOSTCC@
--INSTALL_DATA = cp -fp
-+INSTALL_DATA = @INSTALL_DATA@
- swap_ends = @swap_ends@
-
- ifeq ($(HOSTCC),)
diff --git a/math/gretl/files/patch-share_bcih_Makefile.in b/math/gretl/files/patch-share_bcih_Makefile.in
new file mode 100644
index 000000000000..ff533c011c5a
--- /dev/null
+++ b/math/gretl/files/patch-share_bcih_Makefile.in
@@ -0,0 +1,11 @@
+--- share/bcih/Makefile.in.orig 2017-06-01 20:13:36 UTC
++++ share/bcih/Makefile.in
+@@ -2,7 +2,7 @@ topsrc = @top_srcdir@
+
+ CC = @CC@
+ HOSTCC = @HOSTCC@
+-INSTALL_DATA = cp -fp
++INSTALL_DATA = @INSTALL_DATA@
+ swap_ends = @swap_ends@
+
+ ifeq ($(HOSTCC),)