aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-07 20:26:00 +0800
committergerald <gerald@FreeBSD.org>2009-01-07 20:26:00 +0800
commit5a0497fe568a19e5067bbb9a71129e8fa9707b22 (patch)
tree0d43e16688b484bf40bf206b82468acde441adaa /math
parent3983b5d2f8a4192f390053e08c911790e070940a (diff)
downloadfreebsd-ports-gnome-5a0497fe568a19e5067bbb9a71129e8fa9707b22.tar.gz
freebsd-ports-gnome-5a0497fe568a19e5067bbb9a71129e8fa9707b22.tar.zst
freebsd-ports-gnome-5a0497fe568a19e5067bbb9a71129e8fa9707b22.zip
Omit F77, FFLAGS and CFLAGS from CONFIGURE_ENV since these are handled
by the ports infrastructure. Employ USE_FORTRAN, simplifying things. Reviewed by: pav
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index c21d8c9f123f..203df47c12dd 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
pvm:${PORTSDIR}/net/pvm
+USE_FORTRAN=yes
+CONFIGURE_ARGS+= --with-gfortran
USE_XORG= x11
GNU_CONFIGURE= yes
USE_GETTEXT= yes
@@ -44,8 +46,7 @@ CONFIGURE_ARGS= --with-tk \
--with-gtk2
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV+= F77=${F77} CFLAGS="${CFLAGS}" FFLAGS="${FFLAGS}" \
- PVM_ROOT=${LOCALBASE}/lib/pvm
+CONFIGURE_ENV+= PVM_ROOT=${LOCALBASE}/lib/pvm
.include <bsd.port.pre.mk>
@@ -67,13 +68,6 @@ BLAS_LIBS?= -llapack -lblas
.endif
MAKE_ENV+= BLAS_LIBS="-L${LOCALBASE}/lib ${BLAS_LIBS}"
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-RUN_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-F77= gfortran42
-FC= gfortran42
-CONFIGURE_ARGS+= --with-gfortran
-
.if ${ARCH} == "alpha" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= does not compile on alpha 5.x, ia64, sparc64
.endif