aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-09-10 02:01:31 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-09-10 02:01:31 +0800
commit6b99a5f6a8623cde2d0b70e54413feed2f0113b0 (patch)
tree3ee085417de138f0deaf86fcfed5d76d69f5f35e /math
parentf8684b5960d4b090e538f01550d00ece1e3797cc (diff)
downloadfreebsd-ports-gnome-6b99a5f6a8623cde2d0b70e54413feed2f0113b0.tar.gz
freebsd-ports-gnome-6b99a5f6a8623cde2d0b70e54413feed2f0113b0.tar.zst
freebsd-ports-gnome-6b99a5f6a8623cde2d0b70e54413feed2f0113b0.zip
math/openblas: fix build on powerpc64 with clang, remove OPENMP option on powerpc64
On powerpc64 OpenMP is always used when USE_THREADS is defined (which we do unconditionally). This means that OPENMP option on powerpc64 doesn't have any effect and it should be removed. Clang also has some problems when linking Fortran libraries with OpenMP, so use GCC for powerpc64. PR: 240379 Approved by: phd_kimberlite@yahoo.co.jp (maintainer), linimon (mentor)
Diffstat (limited to 'math')
-rw-r--r--math/openblas/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 7ad26b93f06e..660934c4a4a0 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -41,6 +41,7 @@ OPTIONS_DEFINE= INTERFACE64 OPENMP
OPTIONS_DEFINE_i386= DYNAMIC_ARCH AVX AVX2
OPTIONS_DEFINE_amd64= ${OPTIONS_DEFINE_i386}
OPTIONS_DEFINE_powerpc64= POWER6
+OPTIONS_EXCLUDE_powerpc64= OPENMP
.if defined(BATCH) || defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT_i386= DYNAMIC_ARCH
@@ -57,6 +58,7 @@ POWER6_DESC= Optimize for POWER6, instead of the default PPC970
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc64
+USE_GCC= yes
. if ${PORT_OPTIONS:MPOWER6}
TARGET_CPU_ARCH= POWER6
.else