aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
committerasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
commit71102e95212bab836c7a1f7b6a46879128507258 (patch)
tree092d32b70a72fb7f03924e677d49b93599639b89 /math
parent1adcc2f9a259e053ec9c8749e6e4ca4193bd4a56 (diff)
downloadfreebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.gz
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.zst
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.zip
Remove LOOP_VAR and replace it with tiny Makefiles using MASTERDIR to
share most files. Repository copy the default to explicitly named directories to avoid any confusion. Greatly simplify the shared Makefiles, since we are now in different subdirectories, we don't need "a4-install" stuff. While I'm here, consistently name the variables. Here are the guidelines (master port is in brackets) DOCFORMAT: [html] pdf ps KONFONT: 14dot [16dot] PAPERSIZE: a4 [letter] letterdj RESOLUTION: 118 240 [300] 360 400 600 "math/r" has been copied to "R-a4" and "R-letter", to follow the spirit of the original port. "japanese/kon" is renamed to "kon2-*", since that seems to be the basename.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile5
-rw-r--r--math/R-a4/Makefile12
-rw-r--r--math/R-letter/Makefile29
-rw-r--r--math/R-project/Makefile29
-rw-r--r--math/R/Makefile29
5 files changed, 42 insertions, 62 deletions
diff --git a/math/Makefile b/math/Makefile
index 6a89dc2351b6..6587ded9ec3b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1,6 +1,8 @@
-# $Id: Makefile,v 1.50 1998/08/30 18:30:51 steve Exp $
+# $Id: Makefile,v 1.51 1998/10/26 11:59:39 vanilla Exp $
#
+ SUBDIR += R-a4
+ SUBDIR += R-letter
SUBDIR += Scilab
SUBDIR += add
SUBDIR += apc
@@ -28,7 +30,6 @@
SUBDIR += pari
SUBDIR += plplot
SUBDIR += pygist
- SUBDIR += r
SUBDIR += rng
SUBDIR += sc
SUBDIR += siag
diff --git a/math/R-a4/Makefile b/math/R-a4/Makefile
new file mode 100644
index 000000000000..dd26db4cc423
--- /dev/null
+++ b/math/R-a4/Makefile
@@ -0,0 +1,12 @@
+# New ports collection makefile for: R (a4)
+# Version required: R-0.62.2
+# Date created: Tue Jun 23 07:36:55 EST 1998
+# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
+#
+# $Id: Makefile,v 1.7 1998/11/18 11:40:41 asami Exp $
+#
+
+PAPERSIZE= a4
+MASTERDIR= ${.CURDIR}/../R-letter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/R-letter/Makefile b/math/R-letter/Makefile
index f576872464a3..ce6ef7085c0c 100644
--- a/math/R-letter/Makefile
+++ b/math/R-letter/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: R
+# New ports collection makefile for: R (letter)
# Version required: R-0.62.2
# Date created: Tue Jun 23 07:36:55 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id: Makefile,v 1.6 1998/08/20 10:21:20 asami Exp $
+# $Id: Makefile,v 1.7 1998/11/18 11:40:41 asami Exp $
#
DISTNAME= R-0.62.2
-PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.62.2
+PKGNAME= R-${PAPERSIZE}-0.62.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.biostat.washington.edu/mirrors/R/CRAN/src/base/ \
@@ -27,31 +27,20 @@ BROKEN= package
GNU_CONFIGURE= yes
USE_PERL5= yes
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
CONFIGURE_ENV= R_PAPERSIZE=${PAPERSIZE}
-.if !defined(PAPERSIZE)
-PAPERSIZE=a4
-.elif ${PAPERSIZE} == LETTER || ${PAPERSIZE} == Letter
-PAPERSIZE=letter
-.elif ${PAPERSIZE} == A4
-PAPERSIZE=a4
-.elif ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter
-PAPERSIZE_INVALID=yes
+PAPERSIZE?= letter
+.if ${PAPERSIZE} != letter && ${PAPERSIZE} != a4
+.BEGIN:
+ @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${ECHO} "Possible values are: a4 and letter."
+ @${FALSE}
.endif
ALL_TARGET=all help html
MAN1= R.1 Rdconv.1
-pre-fetch:
-.if defined(PAPERSIZE_INVALID)
- @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and Letter."
- @${FALSE}
-.endif
-
test:
@(cd ${WRKSRC}; make test-All)
diff --git a/math/R-project/Makefile b/math/R-project/Makefile
index f576872464a3..ce6ef7085c0c 100644
--- a/math/R-project/Makefile
+++ b/math/R-project/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: R
+# New ports collection makefile for: R (letter)
# Version required: R-0.62.2
# Date created: Tue Jun 23 07:36:55 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id: Makefile,v 1.6 1998/08/20 10:21:20 asami Exp $
+# $Id: Makefile,v 1.7 1998/11/18 11:40:41 asami Exp $
#
DISTNAME= R-0.62.2
-PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.62.2
+PKGNAME= R-${PAPERSIZE}-0.62.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.biostat.washington.edu/mirrors/R/CRAN/src/base/ \
@@ -27,31 +27,20 @@ BROKEN= package
GNU_CONFIGURE= yes
USE_PERL5= yes
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
CONFIGURE_ENV= R_PAPERSIZE=${PAPERSIZE}
-.if !defined(PAPERSIZE)
-PAPERSIZE=a4
-.elif ${PAPERSIZE} == LETTER || ${PAPERSIZE} == Letter
-PAPERSIZE=letter
-.elif ${PAPERSIZE} == A4
-PAPERSIZE=a4
-.elif ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter
-PAPERSIZE_INVALID=yes
+PAPERSIZE?= letter
+.if ${PAPERSIZE} != letter && ${PAPERSIZE} != a4
+.BEGIN:
+ @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${ECHO} "Possible values are: a4 and letter."
+ @${FALSE}
.endif
ALL_TARGET=all help html
MAN1= R.1 Rdconv.1
-pre-fetch:
-.if defined(PAPERSIZE_INVALID)
- @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and Letter."
- @${FALSE}
-.endif
-
test:
@(cd ${WRKSRC}; make test-All)
diff --git a/math/R/Makefile b/math/R/Makefile
index f576872464a3..ce6ef7085c0c 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: R
+# New ports collection makefile for: R (letter)
# Version required: R-0.62.2
# Date created: Tue Jun 23 07:36:55 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id: Makefile,v 1.6 1998/08/20 10:21:20 asami Exp $
+# $Id: Makefile,v 1.7 1998/11/18 11:40:41 asami Exp $
#
DISTNAME= R-0.62.2
-PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.62.2
+PKGNAME= R-${PAPERSIZE}-0.62.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.biostat.washington.edu/mirrors/R/CRAN/src/base/ \
@@ -27,31 +27,20 @@ BROKEN= package
GNU_CONFIGURE= yes
USE_PERL5= yes
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
CONFIGURE_ENV= R_PAPERSIZE=${PAPERSIZE}
-.if !defined(PAPERSIZE)
-PAPERSIZE=a4
-.elif ${PAPERSIZE} == LETTER || ${PAPERSIZE} == Letter
-PAPERSIZE=letter
-.elif ${PAPERSIZE} == A4
-PAPERSIZE=a4
-.elif ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter
-PAPERSIZE_INVALID=yes
+PAPERSIZE?= letter
+.if ${PAPERSIZE} != letter && ${PAPERSIZE} != a4
+.BEGIN:
+ @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${ECHO} "Possible values are: a4 and letter."
+ @${FALSE}
.endif
ALL_TARGET=all help html
MAN1= R.1 Rdconv.1
-pre-fetch:
-.if defined(PAPERSIZE_INVALID)
- @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and Letter."
- @${FALSE}
-.endif
-
test:
@(cd ${WRKSRC}; make test-All)