aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-21 12:10:09 +0800
committeredwin <edwin@FreeBSD.org>2005-12-21 12:10:09 +0800
commit750a58e06ad168384ca74057478ab58b8d5e4645 (patch)
treeb4cb9569c5f6cbb1ab631149c7eac12a65e6091e /math
parent03482dd9cf9913fbad3b5723d4675227172ec903 (diff)
downloadfreebsd-ports-gnome-750a58e06ad168384ca74057478ab58b8d5e4645.tar.gz
freebsd-ports-gnome-750a58e06ad168384ca74057478ab58b8d5e4645.tar.zst
freebsd-ports-gnome-750a58e06ad168384ca74057478ab58b8d5e4645.zip
[NEW PORT] math/plman: A Propositional Logic sentence shell/interpreter
PLMan, or Propositional LogicMan, is a user-friendly and powerful propositional logic (sometimes called sentential logic or propositional calculus) sentence shell/interpreter written in Java, capable of handling many existing propositional systems of propositional logic, especially the important ones. Author: Takayuki Hoshi <hoshi103@chapman.edu> WWW: http://plman.sourceforge.net/ PR: ports/90277 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/plman/Makefile49
-rw-r--r--math/plman/distinfo3
-rw-r--r--math/plman/files/patch-bin-plman11
-rw-r--r--math/plman/pkg-descr8
-rw-r--r--math/plman/pkg-plist8
6 files changed, 80 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 9d1f54c9775f..f7bdcd15a6ee 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -208,6 +208,7 @@
SUBDIR += php5-bcmath
SUBDIR += php5-gmp
SUBDIR += physcalc
+ SUBDIR += plman
SUBDIR += ploticus
SUBDIR += ploticus-nox11
SUBDIR += plplot
diff --git a/math/plman/Makefile b/math/plman/Makefile
new file mode 100644
index 000000000000..4991f3df40f8
--- /dev/null
+++ b/math/plman/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: plman
+# Date created: 2005-12-12
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plman
+PORTVERSION= 2.5.1
+CATEGORIES= math java
+MASTER_SITES= http://${PORTNAME}.sourceforge.net/dist/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}.sourceforge.net/
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\./_/g}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= nivit@email.it
+COMMENT= A Propositional Logic sentence shell/interpreter
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+NO_BUILD= yes
+
+USE_JAVA= yes
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+JAVA_VERSION= 1.4+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+REPLACE_FILES= ${WRKSRC}/bin/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+FIND_DATA= lib
+FIND_DOCS= docs
+
+post-patch:
+ for FILE in ${REPLACE_FILES}; do \
+ ${REINPLACE_CMD} -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" $${FILE} ;\
+ done;
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}/${FIND_DATA}
+ cd ${WRKSRC} && ${FIND} ${FIND_DATA} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/${FIND_DOCS} && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/plman/distinfo b/math/plman/distinfo
new file mode 100644
index 000000000000..65dd973268df
--- /dev/null
+++ b/math/plman/distinfo
@@ -0,0 +1,3 @@
+MD5 (plman2_5_1.zip) = c10b7e110a266360edfc72be23df7f50
+SHA256 (plman2_5_1.zip) = b558d6b1afbdc0ed06a0c920ff8bdc7b7502c6ced968302300074c7867111a88
+SIZE (plman2_5_1.zip) = 1372138
diff --git a/math/plman/files/patch-bin-plman b/math/plman/files/patch-bin-plman
new file mode 100644
index 000000000000..90e1a84fe9a2
--- /dev/null
+++ b/math/plman/files/patch-bin-plman
@@ -0,0 +1,11 @@
+$FreeBSD$
+--- bin/plman Tue Nov 23 11:32:50 2004
++++ bin/plman.port Mon Dec 12 12:57:36 2005
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+
+-PLMAN_PATH='MODIFY HERE!!' # Example: ~/bin/plman
++PLMAN_PATH='%%DATADIR%%' # Example: ~/bin/plman
+
+ # Execute plman
+ java -classpath "${PLMAN_PATH}/lib/plman.jar":"${PLMAN_PATH}/lib/ant.jar" PropositionalLogicParser $*
diff --git a/math/plman/pkg-descr b/math/plman/pkg-descr
new file mode 100644
index 000000000000..796c8b97ec48
--- /dev/null
+++ b/math/plman/pkg-descr
@@ -0,0 +1,8 @@
+PLMan, or Propositional LogicMan, is a user-friendly and powerful
+propositional logic (sometimes called sentential logic or
+propositional calculus) sentence shell/interpreter written in Java,
+capable of handling many existing propositional systems of
+propositional logic, especially the important ones.
+
+Author: Takayuki Hoshi <hoshi103@chapman.edu>
+WWW: http://plman.sourceforge.net/
diff --git a/math/plman/pkg-plist b/math/plman/pkg-plist
new file mode 100644
index 000000000000..2edcc32b026e
--- /dev/null
+++ b/math/plman/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/plman
+%%PORTDOCS%%%%DOCSDIR%%/PLMan_Users_Manual.pdf
+%%DATADIR%%/lib/ant.jar
+%%DATADIR%%/lib/plman.jar
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%