aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-24 03:39:09 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-24 03:39:09 +0800
commit75eb220ebb45b9a825e79a285a504e6833fd7f50 (patch)
treebf71117bdf5bccf269c81904b7bffc3514351e25 /math
parent0affa6686ad89ecb4a0fdd5a5014d398da32935d (diff)
downloadfreebsd-ports-gnome-75eb220ebb45b9a825e79a285a504e6833fd7f50.tar.gz
freebsd-ports-gnome-75eb220ebb45b9a825e79a285a504e6833fd7f50.tar.zst
freebsd-ports-gnome-75eb220ebb45b9a825e79a285a504e6833fd7f50.zip
- Add option (on by default) to make the help browser work
- Relocate JGraphx substitution to allow running Scilab Java components from WRKDIR before install (necessary to build docs) - DATADIR/.atoms shouldn't be GUI only PR: ports/153402 Submitted by: Rob Farmer (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index c1f37d2aee74..547c39e42701 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scilab
PORTVERSION= 5.3.0
+PORTREVISION= 1
CATEGORIES= math cad parallel java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/:scilab \
http://www.predatorlabs.net/dl/:jgraphx \
@@ -35,7 +36,8 @@ FFLAGS+= -fPIC
OPTIONS= ATLAS "Use Atlas instead of Blas" OFF \
FFTW "Use FFTW" ON \
- GUI "Build GUI (requires Java and required for docs)" ON \
+ GUI "Build GUI (requires Java)" ON \
+ HELP "Help Browser (Java based, requires GUI)" ON \
NLS "Build localization" OFF \
MATIO "Matlab compatibility" OFF \
OCAML "Build ocaml modelica compiler (requires GUI)" OFF \
@@ -127,7 +129,8 @@ JAVA_RUN= yes
USE_XORG= x11
CONFIGURE_ARGS+= --with-jdk=${JAVA_HOME} \
- --with-docbook=${LOCALBASE}/share/xsl/docbook
+ --with-docbook=${LOCALBASE}/share/xsl/docbook \
+ --enable-build-help
DESKTOP_ENTRIES= "SciLab" \
"${COMMENT}" \
@@ -136,6 +139,10 @@ DESKTOP_ENTRIES= "SciLab" \
.endif
+.if !defined(WITHOUT_HELP)
+ALL_TARGET= all doc
+.endif
+
.if defined(WITHOUT_FFTW)
CONFIGURE_ARGS+= --without-fftw
.else
@@ -213,7 +220,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$jardir/jeuclid-core*.jar|${LOCALBASE}/share/java/jeuclid/repo/jeuclid-core*.jar|' ${WRKSRC}/configure
@${MKDIR} ${WRKSRC}/thirdparty
@${CP} ${DISTDIR}/${JGRAPHX_JAR} ${WRKSRC}/thirdparty/jgraphx.jar
- @${REINPLACE_CMD} -e 's|@JGRAPHX@|${DATADIR}/modules/jgraphx.jar|g' ${WRKSRC}/etc/classpath.xml.in
@# Run fixes
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/etc/librarypath.xml
@@ -222,9 +228,10 @@ post-patch:
.endif
pre-install:
+ @${MKDIR} ${DATADIR}/.atoms
.if !defined(WITHOUT_GUI)
@${MKDIR} ${DATADIR}/modules && ${INSTALL_DATA} ${DISTDIR}/${JGRAPHX_JAR} ${DATADIR}/modules/jgraphx.jar
- @${MKDIR} ${DATADIR}/.atoms
+ @${REINPLACE_CMD} -e 's|${WRKSRC}/thirdparty/jgraphx.jar|${DATADIR}/modules/jgraphx.jar|g' ${WRKSRC}/etc/classpath.xml
.endif
post-install: