aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-01 01:03:13 +0800
committerkrion <krion@FreeBSD.org>2004-03-01 01:03:13 +0800
commit79f71a030a51d51c1d4e88dd0b48d6e1f11495a5 (patch)
tree2f826b86cefcaa668c79a73478ef1131ba0fad8c /math
parentd38161b221317e97a87e42083b2d21a4bce9f4b8 (diff)
downloadfreebsd-ports-gnome-79f71a030a51d51c1d4e88dd0b48d6e1f11495a5.tar.gz
freebsd-ports-gnome-79f71a030a51d51c1d4e88dd0b48d6e1f11495a5.tar.zst
freebsd-ports-gnome-79f71a030a51d51c1d4e88dd0b48d6e1f11495a5.zip
- Fix build on alpha
PR: ports/63532 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'math')
-rw-r--r--math/freefem++/Makefile4
-rw-r--r--math/freefem++/files/patch-src::AnyType.hpp12
2 files changed, 12 insertions, 4 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 16883ca42f05..649f24dcb3c1 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -30,10 +30,6 @@ DOCS= BUGS COPYRIGHT HISTORY README DOC/manual.pdf
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on alpha 5.x"
-.endif
-
.if ${OSVERSION} < 501103
USE_GCC= 3.2
.endif
diff --git a/math/freefem++/files/patch-src::AnyType.hpp b/math/freefem++/files/patch-src::AnyType.hpp
new file mode 100644
index 000000000000..1b26f3907ef5
--- /dev/null
+++ b/math/freefem++/files/patch-src::AnyType.hpp
@@ -0,0 +1,12 @@
+--- ./src/AnyType.hpp.orig Sat May 31 11:53:05 2003
++++ ./src/AnyType.hpp Sun Feb 29 16:13:27 2004
+@@ -5,7 +5,8 @@
+ class basicForEachType;
+ typedef const basicForEachType * aType;
+
+-typedef unsigned char AnyData[24];
++//typedef unsigned char AnyData[24];
++typedef unsigned char AnyData[2*(sizeof(void*)+2*sizeof(double))];
+
+ extern map<const string,basicForEachType *> map_type;
+