aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-10-03 12:20:28 +0800
committerstephen <stephen@FreeBSD.org>2011-10-03 12:20:28 +0800
commit7ac21bfea490d345d849c492501a5d9883862fae (patch)
tree63ead7082558e7c224610a28f4aa71c0747452f7 /math
parentd979a3693e1bcfca865dcd6e53de31400afc4232 (diff)
downloadfreebsd-ports-gnome-7ac21bfea490d345d849c492501a5d9883862fae.tar.gz
freebsd-ports-gnome-7ac21bfea490d345d849c492501a5d9883862fae.tar.zst
freebsd-ports-gnome-7ac21bfea490d345d849c492501a5d9883862fae.zip
- Update to 2011.1
Submitted by: wenheping@gmail.com (private email)
Diffstat (limited to 'math')
-rw-r--r--math/qhull/Makefile35
-rw-r--r--math/qhull/distinfo6
-rw-r--r--math/qhull/files/extra-patch-CMakeLists.txt7
-rw-r--r--math/qhull/files/patch-configure10
-rw-r--r--math/qhull/files/patch-eg::Makefile.in11
-rw-r--r--math/qhull/files/patch-src::Makefile.in11
-rw-r--r--math/qhull/pkg-plist166
7 files changed, 119 insertions, 127 deletions
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 9e57efb815c1..0a1823becc47 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -5,34 +5,33 @@
# $FreeBSD$
PORTNAME= qhull
-PORTVERSION= 1.0
-PORTREVISION= 2
+PORTVERSION= 2011.1
CATEGORIES= math
MASTER_SITES= http://www.qhull.org/download/
-DISTNAME= ${PORTNAME}-2003.1
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
MAINTAINER= stephen@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
-PATCH_SITES= http://www.qhull.org/download/
-PATCHFILES= poly.c-qh_gethash.patch
-PATCH_DIST_STRIP= -p2
-
-USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USE_CMAKE= yes
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= qhull.1 rbox.1
+CONFLICTS= qhull-1.0*
+
+post-patch:
.if !defined(NOPORTDOCS)
-MAN1= qhull.1 rbox.1
+ ${REINPLACE_CMD} -e 's#share/doc/packages#share/doc#g' \
+ ${WRKSRC}/CMakeLists.txt
+.else
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-CMakeLists.txt
.endif
-pre-configure:
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e "s|src html eg config|src config|" \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|install-docDATA install-examplesDATA||" \
- ${WRKSRC}/src/Makefile.in
-.endif
+post-install:
+ ${LN} -sf ${PREFIX}/lib/libqhull6.so.6.2.0.1385 \
+ ${PREFIX}/lib/libqhull6.so.6
.include <bsd.port.mk>
diff --git a/math/qhull/distinfo b/math/qhull/distinfo
index b3dcf5883a01..afa5f1773a9a 100644
--- a/math/qhull/distinfo
+++ b/math/qhull/distinfo
@@ -1,4 +1,2 @@
-SHA256 (qhull-2003.1.tar.gz) = 68725c96603a426da748d38d0f83e7a9dd6a0bfc483525debe04001846475b0b
-SIZE (qhull-2003.1.tar.gz) = 724313
-SHA256 (poly.c-qh_gethash.patch) = fb42b86fa80e1d4e671043a07ff3bdf4ad641094f93630241877fce096916737
-SIZE (poly.c-qh_gethash.patch) = 684
+SHA256 (qhull-2011.1-src.tgz) = adae4425f51c2eaf491e822dc5b0a0c2fdebc258841e1c185bbb8a5200c754c4
+SIZE (qhull-2011.1-src.tgz) = 687728
diff --git a/math/qhull/files/extra-patch-CMakeLists.txt b/math/qhull/files/extra-patch-CMakeLists.txt
new file mode 100644
index 000000000000..576f6ac53670
--- /dev/null
+++ b/math/qhull/files/extra-patch-CMakeLists.txt
@@ -0,0 +1,7 @@
+--- CMakeLists.txt.orig 2011-09-03 23:42:33.000000000 +0000
++++ CMakeLists.txt 2011-09-03 23:42:48.000000000 +0000
+@@ -331,4 +331,3 @@
+ install(FILES ${road_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/road)
+ install(FILES html/qhull.man DESTINATION ${MAN_INSTALL_DIR} RENAME qhull.1)
+ install(FILES html/rbox.man DESTINATION ${MAN_INSTALL_DIR} RENAME rbox.1)
+-install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
diff --git a/math/qhull/files/patch-configure b/math/qhull/files/patch-configure
deleted file mode 100644
index 5bb34aa5fe4c..000000000000
--- a/math/qhull/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Fri Feb 6 16:33:25 2004
-+++ configure Wed Apr 28 23:45:04 2004
-@@ -18958,6 +18958,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/math/qhull/files/patch-eg::Makefile.in b/math/qhull/files/patch-eg::Makefile.in
deleted file mode 100644
index f9877a8061e3..000000000000
--- a/math/qhull/files/patch-eg::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- eg/Makefile.in.orig Fri Feb 6 16:33:23 2004
-+++ eg/Makefile.in Wed Apr 28 23:06:27 2004
-@@ -138,7 +138,7 @@
-
- # to:
- docdir = $(prefix)/share/doc/$(PACKAGE)
--examplesdir = $(docdir)/examples
-+examplesdir = $(prefix)/share/examples/$(PACKAGE)
-
- # which:
- examples_DATA = \
diff --git a/math/qhull/files/patch-src::Makefile.in b/math/qhull/files/patch-src::Makefile.in
deleted file mode 100644
index 9623670c7d08..000000000000
--- a/math/qhull/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Fri Feb 6 16:33:23 2004
-+++ src/Makefile.in Wed Apr 28 23:37:31 2004
-@@ -198,7 +198,7 @@
-
- # to:
- docdir = $(prefix)/share/doc/$(PACKAGE)
--examplesdir = $(docdir)/examples
-+examplesdir = $(prefix)/share/examples/$(PACKAGE)
-
- # which:
- examples_DATA = \
diff --git a/math/qhull/pkg-plist b/math/qhull/pkg-plist
index 75d2a12ad700..6104ddc0e04b 100644
--- a/math/qhull/pkg-plist
+++ b/math/qhull/pkg-plist
@@ -1,79 +1,99 @@
bin/qconvex
+bin/qconvex-6.2.0.1385
bin/qdelaunay
+bin/qdelaunay-6.2.0.1385
bin/qhalf
+bin/qhalf-6.2.0.1385
bin/qhull
+bin/qhull-6.2.0.1385
bin/qvoronoi
+bin/qvoronoi-6.2.0.1385
+bin/user_eg
+bin/user_eg-6.2.0.1385
+bin/user_eg2
+bin/user_eg2-6.2.0.1385
+bin/user_eg3
+bin/user_eg3-6.2.0.1385
bin/rbox
-include/qhull/geom.h
-include/qhull/mem.h
-include/qhull/poly.h
-include/qhull/qhull_a.h
-include/qhull/stat.h
-include/qhull/io.h
-include/qhull/merge.h
-include/qhull/qhull.h
-include/qhull/qset.h
-include/qhull/user.h
-lib/libqhull.a
-lib/libqhull.la
-lib/libqhull.so
-lib/libqhull.so.5
-@comment These doc files must be ditributed even with NOPORTDOCS
-%%DOCSDIR%%/Announce.txt
-%%DOCSDIR%%/COPYING.txt
-%%DOCSDIR%%/README.txt
-%%DOCSDIR%%/REGISTER.txt
-%%DOCSDIR%%/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/Changes.txt
-%%PORTDOCS%%%%DOCSDIR%%/qh-geom.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-globa.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-io.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-mem.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-merge.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-poly.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-qhull.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-set.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-stat.htm
-%%PORTDOCS%%%%DOCSDIR%%/qh-user.htm
-%%PORTDOCS%%%%EXAMPLESDIR%%/user_eg.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/user_eg2.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/qhull_interface.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/Mborland
-%%PORTDOCS%%%%EXAMPLESDIR%%/q_eg
-%%PORTDOCS%%%%EXAMPLESDIR%%/q_egtest
-%%PORTDOCS%%%%EXAMPLESDIR%%/q_test
-%%PORTDOCS%%%%EXAMPLESDIR%%/Qhull-go.bat
-%%PORTDOCS%%%%EXAMPLESDIR%%/q_test.bat
-%%PORTDOCS%%%%DOCSDIR%%/html/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qconvex.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qdelau_f.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qdelaun.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--4d.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--cone.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--dt.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--geom.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--half.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh--rand.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-eg.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-faq.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-get.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-impre.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-in.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optc.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optf.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optg.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-opto.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optp.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optq.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-optt.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qh-quick.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qhalf.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qhull.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qvoron_f.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/qvoronoi.htm
-%%PORTDOCS%%%%DOCSDIR%%/html/rbox.htm
-@dirrm include/qhull
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%
+bin/rbox-6.2.0.1385
+include/libqhull/geom.h
+include/libqhull/io.h
+include/libqhull/libqhull.h
+include/libqhull/mem.h
+include/libqhull/merge.h
+include/libqhull/poly.h
+include/libqhull/qhull_a.h
+include/libqhull/qset.h
+include/libqhull/random.h
+include/libqhull/stat.h
+include/libqhull/user.h
+include/libqhullcpp/Coordinates.h
+include/libqhullcpp/PointCoordinates.h
+include/libqhullcpp/Qhull.h
+include/libqhullcpp/QhullError.h
+include/libqhullcpp/QhullFacet.h
+include/libqhullcpp/QhullFacetList.h
+include/libqhullcpp/QhullFacetSet.h
+include/libqhullcpp/QhullHyperplane.h
+include/libqhullcpp/QhullIterator.h
+include/libqhullcpp/QhullLinkedList.h
+include/libqhullcpp/QhullPoint.h
+include/libqhullcpp/QhullPointSet.h
+include/libqhullcpp/QhullPoints.h
+include/libqhullcpp/QhullQh.h
+include/libqhullcpp/QhullRidge.h
+include/libqhullcpp/QhullSet.h
+include/libqhullcpp/QhullSets.h
+include/libqhullcpp/QhullStat.h
+include/libqhullcpp/QhullVertex.h
+include/libqhullcpp/QhullVertexSet.h
+include/libqhullcpp/RboxPoints.h
+include/libqhullcpp/UsingLibQhull.h
+include/libqhullcpp/functionObjects.h
+include/road/RoadError.h
+include/road/RoadLogEvent.h
+include/road/RoadTest.h
+lib/libqhull6.so
+lib/libqhull6.so.6
+lib/libqhull6.so.6.2.0.1385
+lib/libqhullcpp.a
+lib/libqhullstatic.a
+lib/libqhullstatic_p.a
+@dirrm include/libqhull
+@dirrm include/libqhullcpp
+@dirrm include/road
+%%PORTDOCS%%%%DOCSDIR%%/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/normal_voronoi_knauss_oesterle.jpg
+%%PORTDOCS%%%%DOCSDIR%%/qconvex.htm
+%%PORTDOCS%%%%DOCSDIR%%/qdelau_f.htm
+%%PORTDOCS%%%%DOCSDIR%%/qdelaun.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh--4d.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh--cone.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh--dt.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh--geom.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh--half.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh--rand.gif
+%%PORTDOCS%%%%DOCSDIR%%/qh-code.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-eg.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-faq.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-get.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-impre.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optc.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optf.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optg.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-opto.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optp.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optq.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-optt.htm
+%%PORTDOCS%%%%DOCSDIR%%/qh-quick.htm
+%%PORTDOCS%%%%DOCSDIR%%/qhalf.htm
+%%PORTDOCS%%%%DOCSDIR%%/qhull-cpp.xml
+%%PORTDOCS%%%%DOCSDIR%%/qhull.htm
+%%PORTDOCS%%%%DOCSDIR%%/qhull.man
+%%PORTDOCS%%%%DOCSDIR%%/qhull.txt
+%%PORTDOCS%%%%DOCSDIR%%/qvoron_f.htm
+%%PORTDOCS%%%%DOCSDIR%%/qvoronoi.htm
+%%PORTDOCS%%%%DOCSDIR%%/rbox.htm
+%%PORTDOCS%%%%DOCSDIR%%/rbox.man
+%%PORTDOCS%%%%DOCSDIR%%/rbox.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%