aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-27 21:47:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-27 21:47:46 +0800
commit7b8617d5e9da0fcb3efb29a4bc95db5bf08078f7 (patch)
tree6bdc6f0c60fcbd850222d31926649e646fff1d48 /math
parent5a073c98c7bf4815edcb27ebc9b246311cc1b8f3 (diff)
downloadfreebsd-ports-gnome-7b8617d5e9da0fcb3efb29a4bc95db5bf08078f7.tar.gz
freebsd-ports-gnome-7b8617d5e9da0fcb3efb29a4bc95db5bf08078f7.tar.zst
freebsd-ports-gnome-7b8617d5e9da0fcb3efb29a4bc95db5bf08078f7.zip
- Switch to USES=libtool, drop .la files
- Strip libraries
Diffstat (limited to 'math')
-rw-r--r--math/libneural/Makefile8
-rw-r--r--math/libneural/pkg-plist2
2 files changed, 7 insertions, 3 deletions
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 6bfe93e45ec7..ae6f1c0e4f56 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -3,16 +3,17 @@
PORTNAME= libneural
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math devel
MASTER_SITES= http://www.freebsdbrasil.com.br/~jmelo/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
-USE_AUTOTOOLS= libtool
+USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
@@ -21,4 +22,7 @@ post-patch:
s|endl|std::&|g; s|cerr|std::&|g; s|cout|std::&|g; s|cin|std::&|g; s|[oi]fstream |std::&|g' \
${WRKSRC}/lib/neuron.cc ${WRKSRC}/lib/nnwork.cc ${WRKSRC}/examples/*.cc
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libneural.so
+
.include <bsd.port.mk>
diff --git a/math/libneural/pkg-plist b/math/libneural/pkg-plist
index dd19dbd3f825..86d22d4b7740 100644
--- a/math/libneural/pkg-plist
+++ b/math/libneural/pkg-plist
@@ -1,6 +1,6 @@
include/neuron.h
include/nnwork.h
lib/libneural.a
-lib/libneural.la
lib/libneural.so
lib/libneural.so.0
+lib/libneural.so.0.0.0