aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-14 07:21:37 +0800
committerMark Linimon <linimon@FreeBSD.org>2017-05-14 07:21:37 +0800
commit7e4f41c6908ce98d98c9a87bb0998ff78c715166 (patch)
tree4ae3b8a2f12ec648a3f08b6e08e43bdddbde045b /math
parentaaf8b327e5095da79cd603bcd11cc3bb1af0e5b5 (diff)
downloadfreebsd-ports-gnome-7e4f41c6908ce98d98c9a87bb0998ff78c715166.tar.gz
freebsd-ports-gnome-7e4f41c6908ce98d98c9a87bb0998ff78c715166.tar.zst
freebsd-ports-gnome-7e4f41c6908ce98d98c9a87bb0998ff78c715166.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'math')
-rw-r--r--math/clrng/Makefile1
-rw-r--r--math/gringo/Makefile2
-rw-r--r--math/openlibm/Makefile4
3 files changed, 5 insertions, 2 deletions
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
index b1cc46431c26..fcfddc0d909b 100644
--- a/math/clrng/Makefile
+++ b/math/clrng/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= opencl>=0:devel/opencl
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -std=c11
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index 4336a1d0895d..8ff3f9ab64a8 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= re2c:devel/re2c
+BROKEN_powerpc64= fails to compile: term.cc: error: pow is not a member of std
+
USES= bison compiler:c++11-lib scons
MAKE_ARGS+= ${MAKE_ENV}
diff --git a/math/openlibm/Makefile b/math/openlibm/Makefile
index a3f84c17f4e2..40bee825e437 100644
--- a/math/openlibm/Makefile
+++ b/math/openlibm/Makefile
@@ -21,8 +21,8 @@ GH_PROJECT= openlibm
USES= gmake
USE_LDCONFIG= yes
-BROKEN_aarch64= Does not compile: the clang compiler does not support -march=aarch64
-BROKEN_powerpc64= Does not build
+BROKEN_aarch64= does not compile: the clang compiler does not support -march=aarch64
+BROKEN_powerpc64= does not build: gmake: clang: Command not found
.include <bsd.port.pre.mk>