aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-10-14 14:20:22 +0800
committerwen <wen@FreeBSD.org>2015-10-14 14:20:22 +0800
commit854e016b53b6d84290cba3f49e58da0d67bcb331 (patch)
treecdcee1413ad656ba970690a1f319e2d2d4970c7f /math
parent931c6a05a65ae68cde7362bc81333b1c69f39217 (diff)
downloadfreebsd-ports-gnome-854e016b53b6d84290cba3f49e58da0d67bcb331.tar.gz
freebsd-ports-gnome-854e016b53b6d84290cba3f49e58da0d67bcb331.tar.zst
freebsd-ports-gnome-854e016b53b6d84290cba3f49e58da0d67bcb331.zip
- Update to version 2.2.1
- Change to USES=localbase - Remove WX_UNICODE=yes (obsolete now) - Parse pkg-message via SUB_FILES - Integrate SAGA GIS toolchain files (sripting) PR: 203508 Submitted by: rhurlin@gwdg.de(maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/saga/Makefile18
-rw-r--r--math/saga/distinfo4
-rw-r--r--math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.cpp13
-rw-r--r--math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.h13
-rw-r--r--math/saga/files/pkg-message.in (renamed from math/saga/pkg-message)13
-rw-r--r--math/saga/pkg-plist35
6 files changed, 53 insertions, 43 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 18a50d7ed063..91b845fcb892 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 2.2.0
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -28,15 +27,14 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
--enable-python
CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
-CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib -lopencv_contrib
+LDFLAGS+= -lopencv_contrib
USE_LDCONFIG= yes
USE_CXXSTD= c++11
USE_WX= 3.0+
-USES= autoreconf compiler:gcc-c++11-lib iconv:wchar_t dos2unix libtool python:2
+USES= autoreconf libtool localbase compiler:gcc-c++11-lib \
+ iconv:wchar_t dos2unix python:2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WX_UNICODE= yes
DESKTOP_ENTRIES= "SAGA GIS" "${COMMENT}" "${DATADIR}/saga.png" \
"saga_gui" "Science;Geoscience;Math;" true
@@ -61,6 +59,8 @@ VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:${PORTSDIR}/graphics/vigra
.include <bsd.port.pre.mk>
+SUB_FILES= pkg-message
+
post-extract:
@${REINPLACE_CMD} -e 's|wx-config |${WX_CONFIG} |g' \
${WRKSRC}/configure.ac \
@@ -82,7 +82,7 @@ post-patch:
${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.am
@${REINPLACE_CMD} -e 's|\[cv\]|\[opencv_core\]|' \
${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2537)" + "\\n"|' \
+ @${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2600)" + "\\n"|' \
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
.if ${ARCH} == "powerpc"
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
@@ -98,11 +98,13 @@ post-configure:
${WRKSRC}/src/saga_core/saga_gui/Makefile
post-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga_tip.txt ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.lng.txt ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.ger.txt ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.png ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/scripting
+ (cd ${WRKSRC}/src/scripting && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/scripting)
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
${STAGEDIR}${PREFIX}/share/applications/
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_api-${PORTVERSION}.so
diff --git a/math/saga/distinfo b/math/saga/distinfo
index 0722d40cd0a8..d329a66a13ca 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (saga_2.2.0.tar.gz) = 50b2e642331c817606bc954302e53757c4ffa6f6d6f468e12caeaaa7a182edaf
-SIZE (saga_2.2.0.tar.gz) = 3914509
+SHA256 (saga_2.2.1.tar.gz) = 325e0890c28dc19c4ec727f58672be67480b2a4dd6604252c0cc4cc08aad34d0
+SIZE (saga_2.2.1.tar.gz) = 4007209
diff --git a/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.cpp b/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.cpp
deleted file mode 100644
index d249aff6ec3b..000000000000
--- a/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/modules/imagery/imagery_opencv/opencv_nnet.cpp.orig 2015-02-26 07:51:59 UTC
-+++ src/modules/imagery/imagery_opencv/opencv_nnet.cpp
-@@ -60,8 +60,8 @@
-
- //---------------------------------------------------------
- #include "opencv_nnet.h"
--#include "opencv\cxcore.h"
--#include "opencv\ml.h"
-+#include <opencv/cxcore.h>
-+#include <opencv/ml.h>
-
- ///////////////////////////////////////////////////////////
- // //
diff --git a/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.h b/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.h
deleted file mode 100644
index f7eb47ecce27..000000000000
--- a/math/saga/files/patch-src_modules_imagery_imagery__opencv_opencv__nnet.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/modules/imagery/imagery_opencv/opencv_nnet.h.orig 2015-02-26 07:51:59 UTC
-+++ src/modules/imagery/imagery_opencv/opencv_nnet.h
-@@ -64,8 +64,8 @@
-
- //---------------------------------------------------------
- #include "MLB_Interface.h"
--#include "opencv\cxcore.h"
--#include "opencv\ml.h"
-+#include <opencv/cxcore.h>
-+#include <opencv/ml.h>
-
- ///////////////////////////////////////////////////////////
- // //
diff --git a/math/saga/pkg-message b/math/saga/files/pkg-message.in
index 542a81c2bd5a..2d99f7c1309a 100644
--- a/math/saga/pkg-message
+++ b/math/saga/files/pkg-message.in
@@ -20,12 +20,13 @@ modules.
######################################################################
-Since version 2.1.0 it is not necessary any more, to use a leading
-"lib" for module library names on Unix-like systems. Now you will have
-to alter back your scripts by removing "lib" from the name (like it is
-on MS Windows).
+From SAGA GIS 2.2.0 on, there is some example and test data installed.
-e.g.:
- saga_cmd ta_morphometry instead of saga_cmd libta_morphometry
+Predefined ToolChains are located at
+ %%DATADIR%%/scripting/toolchains/
+
+Python scripts with examples, helpers and test data reside at
+ %%DATADIR%%/scripting/python/
######################################################################
+
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index 17a3e1a42018..6a04486fe622 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -4,6 +4,7 @@ include/saga/saga_core/saga_api/api_core.h
include/saga/saga_core/saga_api/compatibility.h
include/saga/saga_core/saga_api/data_manager.h
include/saga/saga_core/saga_api/dataobject.h
+include/saga/saga_core/saga_api/datetime.h
include/saga/saga_core/saga_api/geo_tools.h
include/saga/saga_core/saga_api/grid.h
include/saga/saga_core/saga_api/grid_pyramid.h
@@ -90,6 +91,7 @@ lib/saga/libsim_erosion.so
lib/saga/libsim_fire_spreading.so
lib/saga/libsim_hydrology.so
lib/saga/libsim_ihacres.so
+lib/saga/libsim_rivflow.so
lib/saga/libstatistics_grid.so
lib/saga/libstatistics_kriging.so
lib/saga/libstatistics_points.so
@@ -116,8 +118,39 @@ share/pixmaps/saga.png
@mode 0666
%%DATADIR%%/saga.ger.txt
%%DATADIR%%/saga.lng.txt
-%%DATADIR%%/saga_tip.txt
@mode
%%DATADIR%%/saga.png
%%DATADIR%%/saga_prj.dic
%%DATADIR%%/saga_prj.srs
+%%DATADIR%%/saga_tip.txt
+%%DATADIR%%/scripting/python/examples/00_grid_create_dummy.py
+%%DATADIR%%/scripting/python/examples/01_grid_asc_to_saga.py
+%%DATADIR%%/scripting/python/examples/02_grid_morphometry.py
+%%DATADIR%%/scripting/python/examples/03_grid_difference.py
+%%DATADIR%%/scripting/python/examples/04_grid_contour.py
+%%DATADIR%%/scripting/python/examples/05_shp2xyz.py
+%%DATADIR%%/scripting/python/examples/06_xyz2shp.py
+%%DATADIR%%/scripting/python/helpers/print_version.py
+%%DATADIR%%/scripting/python/helpers/saga_cmd_param_interface/environment.py
+%%DATADIR%%/scripting/python/helpers/saga_cmd_param_interface/param_interface.py
+%%DATADIR%%/scripting/python/helpers/saga_cmd_param_interface/tools.py
+%%DATADIR%%/scripting/python/test_data/test.mgrd
+%%DATADIR%%/scripting/python/test_data/test.sdat
+%%DATADIR%%/scripting/python/test_data/test.sgrd
+%%DATADIR%%/scripting/python/test_data/test_ascii.asc
+%%DATADIR%%/scripting/python/test_data/test_pts.dbf
+%%DATADIR%%/scripting/python/test_data/test_pts.mshp
+%%DATADIR%%/scripting/python/test_data/test_pts.shp
+%%DATADIR%%/scripting/python/test_data/test_pts.shx
+%%DATADIR%%/scripting/python/test_data/test_pts_xyz.xyz
+%%DATADIR%%/scripting/toolchains/cluster_terrain.xml
+%%DATADIR%%/scripting/toolchains/gridding.xml
+%%DATADIR%%/scripting/toolchains/imagery_lczc.xml
+%%DATADIR%%/scripting/toolchains/obia.xml
+%%DATADIR%%/scripting/toolchains/points_to_contour.xml
+%%DATADIR%%/scripting/toolchains/sieve_and_clump.xml
+%%DATADIR%%/scripting/toolchains/temperature_downscaling.xml
+%%DATADIR%%/scripting/toolchains/terrain_analysis.xml
+%%DATADIR%%/scripting/toolchains/terrain_segmentation.xml
+%%DATADIR%%/scripting/toolchains/twi.xml
+%%DATADIR%%/scripting/toolchains/upslope_height.xml